<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#" amp="" i-amphtml-layout="" i-amphtml-no-boilerplate="" transformed="self;v=1">
<head><meta charset="UTF-8"><style amp-runtime="" i-amphtml-version="012109102127000">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</style><meta name="viewport" content="width=device-width,initial-scale=1"><meta name="p:domain_verify" content="515924c6254f019e959b78c32d9231b2"><meta name="yandex-verification" content="72c7b8b2ca382a85"><meta name="description" content="Fall is here! There are plenty of family-friendly activities to do this weekend for you to participate in celebration of the season!"><meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large"><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="6 Fun Things To Do This Weekend In Collin County! (09/30)"><meta property="og:description" content="Fall is here! There are plenty of family-friendly activities to do this weekend for you to participate in celebration of the season!"><meta property="og:url" content="https://localprofile.com/2021/09/30/to-do-this-weekend-collin-sept-30-2021/"><meta property="og:site_name" content="Local Profile"><meta property="article:publisher" content="https://www.facebook.com/LocalProfile"><meta property="article:tag" content="to do"><meta property="article:tag" content="Things to do"><meta property="article:tag" content="things to do this weekend"><meta property="article:section" content="Things To Do"><meta property="og:updated_time" content="2021-09-29T16:58:05-05:00"><meta property="og:image" content="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg"><meta property="og:image:secure_url" content="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg"><meta property="og:image:width" content="980"><meta property="og:image:height" content="674"><meta property="og:image:alt" content="Autumn at the Arboretum is a perfect thing to do this weekend to celebrate the coming of October!"><meta property="og:image:type" content="image/jpeg"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:title" content="6 Fun Things To Do This Weekend In Collin County! (09/30)"><meta name="twitter:description" content="Fall is here! There are plenty of family-friendly activities to do this weekend for you to participate in celebration of the season!"><meta name="twitter:site" content="@localprofile_cc"><meta name="twitter:creator" content="@localprofile_cc"><meta name="twitter:image" content="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg"><meta property="ia:markup_url" content="https://localprofile.com/2021/09/30/to-do-this-weekend-collin-sept-30-2021/?ia_markup=1"><meta name="generator" content="Site Kit by Google 1.42.0"><meta name="theme-color" content="#fff"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="mobile-web-app-capable" content="yes"><meta name="apple-touch-fullscreen" content="YES"><meta name="apple-mobile-web-app-title" content="Local Profile"><meta name="application-name" content="Local Profile"><meta name="generator" content="AMP Plugin v2.0.11; mode=standard"><meta name="msapplication-TileImage" content="https://i1.wp.com/localprofile.com/wp-content/uploads/2019/02/cropped-android-chrome-512x512.png?fit=270%2C270&amp;ssl=1"><title>6 Fun Things To Do This Weekend In Collin County! (09/30)</title><link rel="preconnect" href="https://cdn.ampproject.org"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin=""><link rel="dns-prefetch" href="//cdn.broadstreetads.com"><link rel="dns-prefetch" href="//stats.wp.com"><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="dns-prefetch" href="//s.w.org"><link rel="dns-prefetch" href="//i0.wp.com"><link rel="dns-prefetch" href="//i1.wp.com"><link rel="dns-prefetch" href="//i2.wp.com"><link rel="dns-prefetch" href="//c0.wp.com"><link rel="preload" as="script" href="https://cdn.ampproject.org/v0.js"><script type="text/javascript" src="https://cdn.ampproject.org/v0.js" id="amp-runtime-js" async></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-access-0.1.js" id="amp-access-js" async custom-element="amp-access"></script><script src="https://cdn.ampproject.org/v0/amp-ad-0.1.js" async="" custom-element="amp-ad"></script><script src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js" async="" custom-element="amp-analytics"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-animation-0.1.js" id="amp-animation-js" async custom-element="amp-animation"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-bind-0.1.js" id="amp-bind-js" async custom-element="amp-bind"></script><script src="https://cdn.ampproject.org/v0/amp-form-0.1.js" async="" custom-element="amp-form"></script><script src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.js" async="" custom-element="amp-install-serviceworker"></script><script src="https://cdn.ampproject.org/v0/amp-mustache-0.2.js" async="" custom-template="amp-mustache"></script><script src="https://cdn.ampproject.org/v0/amp-sidebar-0.1.js" async="" custom-element="amp-sidebar"></script><script src="https://cdn.ampproject.org/v0/amp-social-share-0.1.js" async="" custom-element="amp-social-share"></script><link rel="icon" href="https://localprofile.com/wp-content/uploads/2019/02/cropped-android-chrome-512x512-100x100.png" sizes="32x32"><link rel="icon" href="https://i1.wp.com/localprofile.com/wp-content/uploads/2019/02/cropped-android-chrome-512x512.png?fit=192%2C192&amp;ssl=1" sizes="192x192"><link crossorigin="anonymous" rel="stylesheet" id="newspack-sacha-fonts-css" href="https://fonts.googleapis.com/css?family=IBM+Plex+Serif%3A400%2C400i%2C700%2C700i&amp;subset=latin%2Clatin-ext&amp;display=swap" type="text/css" media="all"><link crossorigin="anonymous" rel="stylesheet" id="newspack-font-import-css" href="https://fonts.googleapis.com/css2?family=Montserrat:ital,wght@0,400;0,700;1,300;1,700&amp;family=Playfair+Display:ital@0;1&amp;display=swap" type="text/css" media="all"><style amp-custom="">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</style><link rel="profile" href="https://gmpg.org/xfn/11"><!-- Jetpack Site Verification Tags --><!-- Search Engine Optimization by Rank Math PRO - https://s.rankmath.com/home --><link rel="canonical" href="https://localprofile.com/2021/09/30/to-do-this-weekend-collin-sept-30-2021/"><script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":"Place","@id":"https://localprofile.com/#place","geo":{"@type":"GeoCoordinates","latitude":"33.0178635","longitude":"-96.7552263"},"hasMap":"https://www.google.com/maps/search/?api=1&amp;query=33.0178635,-96.7552263","address":{"@type":"PostalAddress","streetAddress":"1413 Gables Ct","addressLocality":"Plano","addressRegion":"Texas","postalCode":"75075","addressCountry":"United States"}},{"@type":["NewsMediaOrganization","Organization"],"@id":"https://localprofile.com/#organization","name":"Local Profile","url":"https://localprofile.com","email":"connect@localprofile.com","address":{"@type":"PostalAddress","streetAddress":"1413 Gables Ct","addressLocality":"Plano","addressRegion":"Texas","postalCode":"75075","addressCountry":"United States"},"logo":{"@type":"ImageObject","@id":"https://localprofile.com/#logo","url":"https://localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png","caption":"Local Profile","inLanguage":"en-US","width":"606","height":"268"},"contactPoint":[{"@type":"ContactPoint","telephone":"+1-972-769-7272","contactType":"sales"}],"location":{"@id":"https://localprofile.com/#place"}},{"@type":"WebSite","@id":"https://localprofile.com/#website","url":"https://localprofile.com","name":"Local Profile","publisher":{"@id":"https://localprofile.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?fit=980%2C674&amp;ssl=1","url":"https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?fit=980%2C674&amp;ssl=1","width":"980","height":"674","caption":"Autumn at the Arboretum is a perfect thing to do this weekend to celebrate the coming of October!","inLanguage":"en-US"},{"@type":"BreadcrumbList","@id":"https://localprofile.com/2021/09/30/to-do-this-weekend-collin-sept-30-2021/#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://localprofile.com/tag/to-do/","name":"to do"}},{"@type":"ListItem","position":"2","item":{"@id":"https://localprofile.com/2021/09/30/to-do-this-weekend-collin-sept-30-2021/","name":"6 fun things to do this weekend in Collin County! (09/30)"}}]},{"@type":"Person","@id":"https://localprofile.com/author/jordan/","name":"Jordan Jarrett","url":"https://localprofile.com/author/jordan/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/93271734e931516925dc26f37f369e5f?s=96&amp;d=mm&amp;r=g","url":"https://secure.gravatar.com/avatar/93271734e931516925dc26f37f369e5f?s=96&amp;d=mm&amp;r=g","caption":"Jordan Jarrett","inLanguage":"en-US"},"worksFor":{"@id":"https://localprofile.com/#organization"}},{"@type":"WebPage","@id":"https://localprofile.com/2021/09/30/to-do-this-weekend-collin-sept-30-2021/#webpage","url":"https://localprofile.com/2021/09/30/to-do-this-weekend-collin-sept-30-2021/","name":"6 Fun Things To Do This Weekend In Collin County! (09/30)","datePublished":"2021-09-30T04:59:00-05:00","dateModified":"2021-09-30T04:59:00-05:00","author":{"@id":"https://localprofile.com/author/jordan/"},"isPartOf":{"@id":"https://localprofile.com/#website"},"primaryImageOfPage":{"@id":"https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?fit=980%2C674&amp;ssl=1"},"inLanguage":"en-US","breadcrumb":{"@id":"https://localprofile.com/2021/09/30/to-do-this-weekend-collin-sept-30-2021/#breadcrumb"}},{"@type":"NewsArticle","headline":"6 Fun Things To Do This Weekend In Collin County! (09/30)","keywords":"to do this weekend","datePublished":"2021-09-30T04:59:00-05:00","dateModified":"2021-09-30T04:59:00-05:00","author":{"@id":"https://localprofile.com/author/jordan/"},"publisher":{"@id":"https://localprofile.com/#organization"},"description":"Fall is here! There are plenty of family-friendly activities to do this weekend for you to participate in celebration of the season!","copyrightYear":"2021","copyrightHolder":{"@id":"https://localprofile.com/#organization"},"name":"6 Fun Things To Do This Weekend In Collin County! (09/30)","@id":"https://localprofile.com/2021/09/30/to-do-this-weekend-collin-sept-30-2021/#richSnippet","isPartOf":{"@id":"https://localprofile.com/2021/09/30/to-do-this-weekend-collin-sept-30-2021/#webpage"},"image":{"@id":"https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?fit=980%2C674&amp;ssl=1"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://localprofile.com/2021/09/30/to-do-this-weekend-collin-sept-30-2021/#webpage"}}]}</script><!-- /Rank Math WordPress SEO plugin --><link rel="alternate" type="application/rss+xml" title="Local Profile » Feed" href="https://localprofile.com/feed/"><link rel="alternate" type="application/rss+xml" title="Local Profile » Comments Feed" href="https://localprofile.com/comments/feed/"><link rel="https://api.w.org/" href="https://localprofile.com/wp-json/"><link rel="alternate" type="application/json" href="https://localprofile.com/wp-json/wp/v2/posts/48198"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://localprofile.com/xmlrpc.php?rsd"><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://localprofile.com/wp-includes/wlwmanifest.xml"><link rel="shortlink" href="https://localprofile.com/?p=48198"><!-- Custom Logo: hide header text --><link rel="alternate" type="application/json+oembed" href="https://localprofile.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flocalprofile.com%2F2021%2F09%2F30%2Fto-do-this-weekend-collin-sept-30-2021%2F"><link rel="alternate" type="text/xml+oembed" href="https://localprofile.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flocalprofile.com%2F2021%2F09%2F30%2Fto-do-this-weekend-collin-sept-30-2021%2F&amp;format=xml"><!-- 
<script async data-cfasync="false" src="https://www.googletagmanager.com/gtag/js?id=UA-19203311-1" type="text/javascript"></script>
<script type="text/javascript" data-cfasync="false">
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments)};
  gtag('js', new Date());

  gtag('config', 'UA-19203311-1');
</script>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1012961/PPv2_001_Square_Home', [300, 250], 'div-gpt-ad-1505679060349-0').addService(googletag.pubads());
    googletag.defineSlot('/1012961/PPv2_001_Square_Home', [300, 250], 'div-gpt-ad-1513948600828-0').addService(googletag.pubads());
    googletag.defineSlot('/1012961/PPv2_001_Square_Home', [300, 250], 'div-gpt-ad-1513948600828-1').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
--><script id="amp-access" type="application/json">
			{"namespace":"popups","authorization":"https:\/\/localprofile.com\/wp-content\/plugins\/newspack-popups\/includes\/..\/api\/campaigns\/index.php?cid=CLIENT_ID(newspack-cid)&ref=DOCUMENT_REFERRER&popups=[{\"id\":\"id_29097\",\"f\":\"daily\",\"utm\":null,\"s\":\"\",\"n\":false,\"d\":false,\"t\":\"i\"},{\"id\":\"id_47540\",\"f\":\"daily\",\"utm\":null,\"s\":\"\",\"n\":false,\"d\":false,\"t\":\"o\"}]&settings={\"suppress_newsletter_campaigns\":\"1\",\"suppress_all_newsletter_campaigns_if_one_dismissed\":\"1\",\"suppress_donation_campaigns_if_donor\":false,\"newspack_popups_non_interative_mode\":false,\"newspack_popups_donor_landing_page\":\"\",\"all_segments\":{\"5faef319b4aea\":{\"min_posts\":0,\"max_posts\":0,\"is_subscribed\":false,\"is_donor\":true,\"is_not_subscribed\":false,\"is_not_donor\":false,\"priority\":0}},\"newspack_popups_active_campaign_group\":false}&visit={\"post_id\":\"48198\",\"categories\":\"1835\",\"is_post\":true}","noPingback":true}		</script><link rel="manifest" href="https://localprofile.com/wp-json/wp/v2/web-app-manifest"><link rel="apple-touch-startup-image" href="https://i1.wp.com/localprofile.com/wp-content/uploads/2019/02/cropped-android-chrome-512x512.png?fit=192%2C192&amp;ssl=1"><!-- BEGIN Parse.ly 2.6.0 --><script type="application/ld+json">
{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/localprofile.com\/2021\/09\/30\/to-do-this-weekend-collin-sept-30-2021\/"},"headline":"6 fun things to do this weekend in Collin County! (09\/30)","url":"http:\/\/localprofile.com\/2021\/09\/30\/to-do-this-weekend-collin-sept-30-2021\/","thumbnailUrl":"https:\/\/i2.wp.com\/localprofile.com\/wp-content\/uploads\/2021\/09\/autumn-at-the-arboretum.jpeg?resize=150%2C150&ssl=1","image":{"@type":"ImageObject","url":"https:\/\/i2.wp.com\/localprofile.com\/wp-content\/uploads\/2021\/09\/autumn-at-the-arboretum.jpeg?resize=150%2C150&ssl=1"},"dateCreated":"2021-09-30T09:59:00Z","datePublished":"2021-09-30T09:59:00Z","dateModified":"2021-09-30T09:59:00Z","articleSection":"Things To Do","author":[{"@type":"Person","name":"Jordan Jarrett"}],"creator":["Jordan Jarrett"],"publisher":{"@type":"Organization","name":"Local Profile","logo":"https:\/\/localprofile.com\/wp-content\/uploads\/2020\/06\/lp-logo-color.png"},"keywords":["things to do","things to do this weekend","to do"]}
</script><!-- END Parse.ly --><!--noscript--><!--/noscript--><link rel="apple-touch-icon" href="https://i1.wp.com/localprofile.com/wp-content/uploads/2019/02/cropped-android-chrome-512x512.png?fit=180%2C180&amp;ssl=1"></head>

<body class="post-template-default single single-post postid-48198 single-format-standard wp-custom-logo wp-embed-responsive theme-newspack-theme woocommerce-no-js singular hide-homepage-title hide-site-tagline h-nsub h-db h-ll h-sh has-sidebar cat-things-to-do has-featured-image single-featured-image-behind has-large-featured-image" data-amp-auto-lightbox-disable>
<amp-ad type="broadstreetads" width="1440" height="360" data-network="6972" data-zone="89042" data-keywords="not_home_page,not_landing_page,is_article_page,things-to-do,to-do-this-weekend-collin-sept-30-2021,post" layout="responsive" data-amp-original-style="max-width: 1440px; margin: 0 auto;" class="amp-wp-1941ee4 i-amphtml-layout-responsive i-amphtml-layout-size-defined" id="i-amp-0" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:25.0000%;"></i-amphtml-sizer></amp-ad>		<amp-layout amp-access="popups.id_47540" amp-access-hide class="newspack-lightbox newspack-popup newspack-lightbox-placement-center    i-amphtml-layout-container" role="button" tabindex="0" id="ce68" i-amphtml-layout="container">
			<div class="newspack-popup-wrapper  amp-wp-430ac8e" data-popup-status="publish" data-amp-original-style="background-color:#EEEEEE;color:#000">
				<div class="newspack-popup">
										
<div class="wp-block-group newspack-pattern subscribe__style-1"><div class="wp-block-group__inner-container">
<div class="wp-block-media-text has-media-on-the-right is-stacked-on-mobile is-vertically-aligned-center is-image-fill has-white-color has-text-color has-background amp-wp-4acd9eb" data-amp-original-style="background-color:#263373;grid-template-columns:auto 68%"><figure class="wp-block-media-text__media amp-wp-f684c78" data-amp-original-style="background-image:url(https://i0.wp.com/localprofile.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-12-at-8.42.36-PM-1.png?fit=960%2C933&amp;ssl=1);background-position:54% 0%"><amp-img src="https://i0.wp.com/localprofile.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-12-at-8.42.36-PM-1.png?fit=960%2C933&amp;ssl=1" alt="" class="wp-image-28004 size-full amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" width="960" height="933" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzkzMycgd2lkdGg9Jzk2MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img src="https://i0.wp.com/localprofile.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-12-at-8.42.36-PM-1.png?fit=960%2C933&amp;ssl=1" alt="" class="wp-image-28004 size-full" width="960" height="933"></noscript></amp-img></figure><div class="wp-block-media-text__content">
<h2 id="h-have-you-subscribed-to-our-free-weekly-newsletter">Have you subscribed to our free weekly newsletter? </h2>



<h2 id="h-it-s-awesome">It’s awesome.</h2>


<amp-layout id="n3d9" class="i-amphtml-layout-container" i-amphtml-layout="container">
	<div class="wp-block-jetpack-mailchimp" data-blog-id="177389529">
		<form aria-describedby="wp-block-jetpack-mailchimp_consent-text" action-xhr="https://public-api.wordpress.com/rest/v1.1/sites/177389529/email_follow/amp/subscribe/" method="post" id="mailchimp_form" target="_top" on="submit-success:AMP.setState( { mailing_list_status: 'subscribed', mailing_list_email: event.response.email } )">
			<p>
				<input aria-label="Enter your email" placeholder="Enter your email" required title="Enter your email" type="email" name="email">
			</p>
									
<div class="wp-block-jetpack-button wp-block-button" style=""><button class="wp-block-button__link has-text-color has-background has-white-background-color amp-wp-4be9315" data-id-attr="mailchimp-button-block-1" id="mailchimp-button-block-1" type="submit" data-amp-original-style="color: #ff5959;">SIGN UP</button></div>
			<p id="wp-block-jetpack-mailchimp_consent-text">
				Stay up-to-date with all the latest local news and events, delivered directly to your inbox, every Monday. <strong>Subscribe now.</strong>			</p>

			
				<div submit-success>
					<template type="amp-mustache">
						<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_success wp-block-jetpack-mailchimp__is-amp">
							Success! You're on the list.						</div>
					</template>
				</div>
				<div submit-error>
					<template type="amp-mustache">
						<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_error wp-block-jetpack-mailchimp__is-amp">
							Whoops! There was an error and we couldn't process your subscription. Please reload the page and try again.						</div>
					</template>
				</div>
				<div submitting>
					<template type="amp-mustache">
						<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_processing wp-block-jetpack-mailchimp__is-amp" role="status">
							Processing…						</div>
					</template>
				</div>

			
		</form>
			</div>
	</amp-layout></div></div>



<div aria-hidden="true" class="wp-block-spacer amp-wp-687c3be" data-amp-original-style="height:20px"></div>
</div></div>
								<form class="popup-not-interested-form ce681 popup-action-form ce68 align-center" method="POST" action-xhr="https://localprofile.com/wp-content/plugins/newspack-popups/includes/../api/campaigns/index.php" target="_top">
							<input name="popup_id" type="hidden" value="id_47540">
		<input name="cid" type="hidden" value="CLIENT_ID(newspack-cid)" data-amp-replace="CLIENT_ID">
		<input name="mailing_list_status" type="hidden" data-amp-bind-value="mailing_list_status">
		<input name="is_newsletter_popup" type="hidden" value="">
						<input name="suppress_forever" type="hidden" value="1">
				<button on="tap:ce68.hide" aria-label="" data-amp-original-style="background-color:#EEEEEE;color:#000" class="amp-wp-430ac8e">I'm not interested</button>
			</form>
							<form class="popup-dismiss-form ce680 popup-action-form ce68 align-center" method="POST" action-xhr="https://localprofile.com/wp-content/plugins/newspack-popups/includes/../api/campaigns/index.php" target="_top">
								<input name="popup_id" type="hidden" value="id_47540">
		<input name="cid" type="hidden" value="CLIENT_ID(newspack-cid)" data-amp-replace="CLIENT_ID">
		<input name="mailing_list_status" type="hidden" data-amp-bind-value="mailing_list_status">
		<input name="is_newsletter_popup" type="hidden" value="">
								<button on="tap:ce68.hide" class="newspack-lightbox__close amp-wp-430ac8e" aria-label="Close Pop-up" data-amp-original-style="background-color:#EEEEEE;color:#000">
							<svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewbox="0 0 24 24" role="img" aria-hidden="true" focusable="false"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12 19 6.41z"></path></svg>
						</button>
					</form>
				</div>
			</div>
			<form class="popup-dismiss-form ce680 popup-action-form ce68" method="POST" action-xhr="https://localprofile.com/wp-content/plugins/newspack-popups/includes/../api/campaigns/index.php" target="_top">
						<input name="popup_id" type="hidden" value="id_47540">
		<input name="cid" type="hidden" value="CLIENT_ID(newspack-cid)" data-amp-replace="CLIENT_ID">
		<input name="mailing_list_status" type="hidden" data-amp-bind-value="mailing_list_status">
		<input name="is_newsletter_popup" type="hidden" value="">
						<button class="newspack-lightbox-shim amp-wp-cb2a876" on="tap:ce68.hide" data-amp-original-style="opacity: 0.3;background-color:#000000;"></button>
			</form>
		</amp-layout>
				<amp-animation id="a_ce68" layout="nodisplay" trigger="visibility" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
			<script type="application/json">
				{
					"duration": "125ms",
					"fill": "both",
					"iterations": "1",
					"direction": "alternate",
					"animations": [
						{
							"selector": "#ce68",
							"delay": "5500",
							"keyframes": {
								"opacity": ["0", "1"],
								"visibility": ["hidden", "visible"]
							}
						},
						{
							"selector": "#ce68",
							"delay": "5000",
							"keyframes": {
								"transform": ["translateY(100vh)", "translateY(0vh)"]
							}
						},
						{
								"selector": "#ce68 .newspack-popup-wrapper",
								"delay": "5625",
								"keyframes": {
																			"opacity": ["0", "1"]
																	}
						}
					]
				}
			</script>
		</amp-animation>
				<amp-analytics class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed">
			<script type="application/json">
				{"requests":{"event":"https:\/\/localprofile.com\/wp-content\/plugins\/newspack-popups\/includes\/..\/api\/campaigns\/index.php"},"triggers":{"trackPageview":{"on":"visible","request":"event","visibilitySpec":{"selector":"#ce68","visiblePercentageMin":90,"totalTimeMin":500,"continuousTimeMin":200},"extraUrlParams":{"popup_id":"id_47540","cid":"CLIENT_ID(newspack-cid)"}},"formSubmitSuccess":{"on":"amp-form-submit-success","request":"event","selector":"#ce68 .wp-block-jetpack-mailchimp form","extraUrlParams":{"popup_id":"id_47540","cid":"CLIENT_ID(newspack-cid)","mailing_list_status":"subscribed","email":"${formFields[email]}"}}}}			</script>
		</amp-analytics>
					<amp-sidebar id="mobile-sidebar" layout="nodisplay" side="right" class="mobile-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>

		
<form role="search" method="get" class="search-form" action="https://localprofile.com/" target="_top">
	<label for="search-form-2">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-2" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	<nav class="main-navigation nav1 dd-menu" aria-label="Top Menu" toolbar-target="site-navigation" toolbar="(min-width: 767px)">
		<ul id="menu-primary-menu-2" class="main-menu"><li id="menu-item-47077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47077"><a href="https://localprofile.com/category/latest/">Latest</a></li>
<li id="menu-item-47074" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47074"><a href="https://localprofile.com/category/covid-19/">COVID-19</a></li>
<li id="menu-item-47070" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47070"><a href="https://localprofile.com/category/food-and-drink/">Food + Drink</a></li>
<li id="menu-item-47071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47071"><a href="https://localprofile.com/category/business/">Business</a></li>
<li id="menu-item-47072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47072"><a href="https://localprofile.com/category/community/">Community</a></li>
<li id="menu-item-33933" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33933"><a href="#" aria-haspopup="true" aria-expanded="false">MORE</a><button class="submenu-expand" tabindex="-1" role="presentation"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-47075" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47075"><a href="https://localprofile.com/category/arts-and-culture/">Arts + Culture</a></li>
	<li id="menu-item-47089" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47089"><a href="https://localprofile.com/category/health/">Health</a></li>
	<li id="menu-item-47078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47078"><a href="https://localprofile.com/category/lifestyle/">Lifestyle</a></li>
	<li id="menu-item-47079" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-47079"><a href="https://localprofile.com/category/things-to-do/">Things To Do</a></li>
	<li id="menu-item-47080" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47080"><a href="https://localprofile.com/category/top-listings/">Top Listings</a></li>
	<li id="menu-item-47521" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47521"><a href="https://localprofile.com/category/business/women-in-business/">Women In Business</a></li>
</ul>
</li>
</ul>	</nav>
	<nav class="secondary-menu nav2 dd-menu" aria-label="Secondary Menu" toolbar-target="secondary-nav-contain" toolbar="(min-width: 767px)">
		<ul id="menu-top-menu" class="secondary-menu"><li id="menu-item-47557" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47557"><a href="https://localprofile.com/2019/02/26/local-plano-profile-becomes-local-profile-collin-county/">About</a></li>
<li id="menu-item-34148" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34148"><a href="https://localprofile.com/magazine/">Magazine</a></li>
<li id="menu-item-33928" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33928"><a href="https://localprofile.com/newsletters/">Newsletter</a></li>
<li id="menu-item-33926" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33926"><a href="https://localprofile.com/advertise/">Advertise</a></li>
</ul>	</nav>
	<nav class="social-navigation" aria-label="Social Links Menu" toolbar="(min-width: 767px)" toolbar-target="social-nav-contain">
		<ul id="menu-social-menu" class="social-links-menu"><li id="menu-item-30800" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30800"><a href="https://www.facebook.com/LocalProfile"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path></svg></a></li>
<li id="menu-item-30802" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30802"><a href="https://www.instagram.com/localprofile_cc/"><span class="screen-reader-text">Instagram</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path></svg></a></li>
<li id="menu-item-47230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47230"><a href="https://twitter.com/localprofile_cc?lang=en"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li id="menu-item-30804" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30804"><a href="https://www.linkedin.com/company/localprofile"><span class="screen-reader-text">LinkedIn</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M19.7,3H4.3C3.582,3,3,3.582,3,4.3v15.4C3,20.418,3.582,21,4.3,21h15.4c0.718,0,1.3-0.582,1.3-1.3V4.3 C21,3.582,20.418,3,19.7,3z M8.339,18.338H5.667v-8.59h2.672V18.338z M7.004,8.574c-0.857,0-1.549-0.694-1.549-1.548 c0-0.855,0.691-1.548,1.549-1.548c0.854,0,1.547,0.694,1.547,1.548C8.551,7.881,7.858,8.574,7.004,8.574z M18.339,18.338h-2.669 v-4.177c0-0.996-0.017-2.278-1.387-2.278c-1.389,0-1.601,1.086-1.601,2.206v4.249h-2.667v-8.59h2.559v1.174h0.037 c0.356-0.675,1.227-1.387,2.526-1.387c2.703,0,3.203,1.779,3.203,4.092V18.338z"></path></svg></a></li>
<li id="menu-item-47231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47231"><a href="https://www.youtube.com/channel/UC_9B-HjCwFD2-VjWys6c59g"><span class="screen-reader-text">Youtube</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->

	</amp-sidebar>
	<amp-sidebar id="desktop-sidebar" layout="nodisplay" side="left" class="desktop-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>
	</amp-sidebar>

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	
	<header id="masthead" class="site-header hide-header-search" data-amp-bind-class="searchVisible ? 'show-header-search site-header ' : 'hide-header-search site-header'">

									<div class="top-header-contain desktop-only">
					<div class="wrapper">
						
						<div id="secondary-nav-contain">
													</div>

													<div id="social-nav-contain">
															</div>
						
											</div><!-- .wrapper -->
				</div><!-- .top-header-contain -->
			
			<div class="middle-header-contain">
				<div class="wrapper">
					
					
					
					<div class="site-branding">

	
		<a href="https://localprofile.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="606" height="268" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?fit=606%2C268&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Local Profile logo" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?w=606&amp;ssl=1 606w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?resize=300%2C133&amp;ssl=1 300w" sizes="(max-width: 606px) 100vw, 606px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzI2OCcgd2lkdGg9JzYwNicgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img width="606" height="268" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?fit=606%2C268&amp;ssl=1" class="custom-logo" alt="Local Profile logo" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?w=606&amp;ssl=1 606w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?resize=300%2C133&amp;ssl=1 300w" sizes="(max-width: 606px) 100vw, 606px"></noscript></amp-img></a>
	<div class="site-identity">
											<p class="site-title"><a href="https://localprofile.com/" rel="home">Local Profile</a></p>
					
						<p class="site-description">
					Connecting Collin County				</p>
			</div><!-- .site-identity -->

</div><!-- .site-branding -->

					
						<div class="nav-wrapper desktop-only">
							<div id="site-navigation">
															</div><!-- #site-navigation -->

													</div><!-- .nav-wrapper -->

					

					<div class="nav-wrapper desktop-only">
						<div id="tertiary-nav-contain">
													</div><!-- #tertiary-nav-contain -->

						
<div class="header-search-contain">
	<button id="search-toggle" on="tap:AMP.setState( { searchVisible: !searchVisible } ), search-form-2.focus" aria-controls="search-menu" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		<span class="screen-reader-text" data-amp-bind-text="searchVisible ? 'Close Search' : 'Open Search'">
			Open Search		</span>
		<span class="search-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
		<span class="close-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
	</button>
	<div id="header-search" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		
<form role="search" method="get" class="search-form" action="https://localprofile.com/" target="_top">
	<label for="search-form-3">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-3" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	</div><!-- #header-search -->
</div><!-- .header-search-contain -->
					</div><!-- .nav-wrapper -->

					
					
											<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
							<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z"></path></svg>							<span>Menu</span>
						</button>
					
				</div><!-- .wrapper -->
			</div><!-- .middle-header-contain -->


					
			</header><!-- #masthead -->

	
	<section class="newspack-broadstreet-header amp-wp-543be6b" data-amp-original-style="text-align:center; padding: 25px;"><amp-ad type="broadstreetads" width="1055" height="150" data-network="6972" data-zone="89044" data-keywords="not_home_page,not_landing_page,is_article_page,things-to-do,to-do-this-weekend-collin-sept-30-2021,post" layout="responsive" data-amp-original-style="max-width: 1055px; margin: 0 auto;" class="amp-wp-b6a38e4 i-amphtml-layout-responsive i-amphtml-layout-size-defined" id="i-amp-1" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:14.2180%;"></i-amphtml-sizer></amp-ad></section>
	
	<div id="content" class="site-content">

	<section id="primary" class="content-area category-things-to-do tag-to-do tag-things-to-do tag-things-to-do-this-weekend">
		<main id="main" class="site-main">

			
	<div class="featured-image-behind">
		
			<figure class="post-thumbnail">

				<amp-img width="980" height="674" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?fit=980%2C674&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="autumn at the arboretum is a perfect thing to do this weekend to celebrate the coming of october!" object-fit="cover" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?w=980&amp;ssl=1 980w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=300%2C206&amp;ssl=1 300w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=768%2C528&amp;ssl=1 768w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=400%2C275&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=706%2C486&amp;ssl=1 706w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=150%2C103&amp;ssl=1 150w" sizes="(max-width: 980px) 100vw, 980px" title="6 Fun Things To Do This Weekend In Collin County! (09/30) 1" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzY3NCcgd2lkdGg9Jzk4MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img width="980" height="674" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?fit=980%2C674&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image" alt="autumn at the arboretum is a perfect thing to do this weekend to celebrate the coming of october!" loading="lazy" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?w=980&amp;ssl=1 980w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=300%2C206&amp;ssl=1 300w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=768%2C528&amp;ssl=1 768w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=400%2C275&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=706%2C486&amp;ssl=1 706w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=150%2C103&amp;ssl=1 150w" sizes="(max-width: 980px) 100vw, 980px" title="6 Fun Things To Do This Weekend In Collin County! (09/30) 1"></noscript></amp-img>
			</figure><!-- .post-thumbnail -->

				<div class="wrapper">
			<header class="entry-header">
				
	<span class="cat-links"><span class="screen-reader-text">Posted in</span><a href="https://localprofile.com/category/things-to-do/" rel="category tag">Things To Do</a></span>			<h1 class="entry-title ">
			6 fun things to do this weekend in Collin County! (09/30)		</h1>
		
	<div class="entry-subhead">
									<div class="entry-meta">
					<span class="author-avatar"><amp-img alt="avatar of jordan jarrett" src="https://secure.gravatar.com/avatar/93271734e931516925dc26f37f369e5f?s=96&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/93271734e931516925dc26f37f369e5f?s=192&amp;d=mm&amp;r=g 2x" class="avatar avatar-96 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="96" width="96" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Jzk2JyB3aWR0aD0nOTYnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img alt="avatar of jordan jarrett" src="https://secure.gravatar.com/avatar/93271734e931516925dc26f37f369e5f?s=96&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/93271734e931516925dc26f37f369e5f?s=192&amp;d=mm&amp;r=g 2x" class="avatar avatar-96 photo" height="96" width="96" loading="lazy"></noscript></amp-img></span><span class="byline"><span>by</span> <span class="author vcard"><a class="url fn n" href="https://localprofile.com/author/jordan/">Jordan Jarrett</a></span></span><span class="posted-on"><time class="entry-date published" datetime="2021-09-30T04:59:00-05:00">September 30, 2021</time><time class="updated" datetime="2021-09-29T16:58:05-05:00">September 29, 2021</time></span>				</div><!-- .meta-info -->
							<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><amp-social-share type="facebook" height="32px" width="32px" aria-label="Click to share on Facebook" title="Click to share on Facebook" data-param-app_id="249643311490" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="twitter" height="32px" width="32px" aria-label="Click to share on Twitter" title="Click to share on Twitter" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="linkedin" height="32px" width="32px" aria-label="Click to share on LinkedIn" title="Click to share on LinkedIn" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="pocket" height="32px" width="32px" aria-label="Click to share on Pocket" title="Click to share on Pocket" data-share-endpoint="https://getpocket.com/save/?url=https%3A%2F%2Flocalprofile.com%2F2021%2F09%2F30%2Fto-do-this-weekend-collin-sept-30-2021%2F&amp;title=6%20fun%20things%20to%20do%20this%20weekend%20in%20Collin%20County%21%20%2809%2F30%29" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="whatsapp" height="32px" width="32px" aria-label="Click to share on WhatsApp" title="Click to share on WhatsApp" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share><button class="amp-social-share print" on="tap:AMP.print">Print</button></div></div></div>	</div>
			</header>
		</div><!-- .wrapper -->
	</div><!-- .featured-image-behind -->

	

				<div class="main-content">

					

<article id="post-48198" class="post-48198 post type-post status-publish format-standard has-post-thumbnail hentry category-things-to-do tag-to-do tag-things-to-do tag-things-to-do-this-weekend entry">
	<div class="entry-content">

		
		
<p>Fall is truly beginning! Celebrate with some autumnal favorites, or listen to some live music or go to an art exhibit. There are plenty of family-friendly activities to do this weekend for you to participate in celebration of the season!</p>

<figure class="wp-block-image alignwide size-large"><amp-img width="780" height="520" src="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=780%2C520&amp;ssl=1" alt="catch an oktoberfest while you can in frisco this october!" class="wp-image-48191 amp-wp-enforced-sizes i-amphtml-layout-responsive i-amphtml-layout-size-defined" srcset="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=1024%2C683&amp;ssl=1 1024w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=1536%2C1024&amp;ssl=1 1536w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=1200%2C800&amp;ssl=1 1200w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=1568%2C1045&amp;ssl=1 1568w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=400%2C267&amp;ssl=1 400w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=706%2C471&amp;ssl=1 706w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=150%2C100&amp;ssl=1 150w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?w=1800&amp;ssl=1 1800w" sizes="(max-width: 780px) 100vw, 780px" title="6 Fun Things To Do This Weekend In Collin County! (09/30) 2" layout="responsive" disable-inline-width="" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:66.6667%;"></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="520" src="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=780%2C520&amp;ssl=1" alt="catch an oktoberfest while you can in frisco this october!" class="wp-image-48191" srcset="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=1024%2C683&amp;ssl=1 1024w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=1536%2C1024&amp;ssl=1 1536w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=1200%2C800&amp;ssl=1 1200w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=1568%2C1045&amp;ssl=1 1568w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=400%2C267&amp;ssl=1 400w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=706%2C471&amp;ssl=1 706w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?resize=150%2C100&amp;ssl=1 150w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/09/frisco-oktoberfest.jpeg?w=1800&amp;ssl=1 1800w" sizes="(max-width: 780px) 100vw, 780px" title="6 Fun Things To Do This Weekend In Collin County! (09/30) 2"></noscript></amp-img><figcaption>Catch an Oktoberfest while you can in Frisco this October!</figcaption></figure>

<h2>Frisco Oktoberfest</h2>

<p><em>Saturday, October 2 at 11 a.m. to Sunday, October 3 at 5 p.m.</em></p>

<p>Celebrate Oktoberfest with authentic German festivities at Frisco Square this weekend! There will be two stages with music and dancing, several beers on tap, contests, and more. Don’t miss out on the fun! Get your tickets now at <a href="https://www.eventbrite.com/e/frisco-oktoberfest-tickets-162603654909?aff=ebdssbcitybrowse" target="_blank" rel="noopener">https://www.eventbrite.com/e/frisco-oktoberfest-tickets</a>. </p>

<p><em>Frisco Square | 8843 Coleman Blvd., Frisco</em></p>

<figure class="wp-block-image alignwide size-large"><amp-img width="780" height="440" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=780%2C440&amp;ssl=1" alt="who doesn't love a pumpkin patch when october rolls around?" class="wp-image-48202 amp-wp-enforced-sizes i-amphtml-layout-responsive i-amphtml-layout-size-defined" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=1024%2C577&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=768%2C433&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=1536%2C865&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=1200%2C676&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=1568%2C883&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=400%2C225&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=706%2C398&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=150%2C85&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?w=1640&amp;ssl=1 1640w" sizes="(max-width: 780px) 100vw, 780px" title="6 Fun Things To Do This Weekend In Collin County! (09/30) 3" layout="responsive" disable-inline-width="" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:56.4103%;"></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="440" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=780%2C440&amp;ssl=1" alt="who doesn't love a pumpkin patch when october rolls around?" class="wp-image-48202" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=1024%2C577&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=768%2C433&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=1536%2C865&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=1200%2C676&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=1568%2C883&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=400%2C225&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=706%2C398&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?resize=150%2C85&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/pumpkin-patch.jpeg?w=1640&amp;ssl=1 1640w" sizes="(max-width: 780px) 100vw, 780px" title="6 Fun Things To Do This Weekend In Collin County! (09/30) 3"></noscript></amp-img><figcaption>Who doesn’t love a pumpkin patch when October rolls around?</figcaption></figure>

<h2>5G Farm’s Pumpkin Patch</h2>

<p><em>Available all weekend</em></p>

<p>Take a look at 5G Farm’s extensive collection of pumpkins or enjoy the hayride, bounce houses, corn maze, and selfie stations. There will be great barbecue and local vendors for you to purchase food from. </p>

<p><em>5G Farm TX | 6601 Co Rd. 166, McKinney</em></p>

<p><em>(Check out more<a href="https://localprofile.com/2021/09/20/best-pumpkin-patches/" data-type="URL" data-id="https://localprofile.com/2021/09/20/best-pumpkin-patches/"> local pumpkin patches</a>!)</em></p>

<figure class="wp-block-image alignwide size-large"><amp-img width="780" height="437" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/concerts-by-the-creek.jpeg?resize=780%2C437&amp;ssl=1" alt="concerts by the creek is the perfect thing to do this weekend with the music-lover in your life." class="wp-image-46842 amp-wp-enforced-sizes i-amphtml-layout-responsive i-amphtml-layout-size-defined" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/concerts-by-the-creek.jpeg?resize=1024%2C574&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/concerts-by-the-creek.jpeg?resize=300%2C168&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/concerts-by-the-creek.jpeg?resize=768%2C430&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/concerts-by-the-creek.jpeg?resize=400%2C224&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/concerts-by-the-creek.jpeg?resize=150%2C84&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/concerts-by-the-creek.jpeg?resize=706%2C396&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/concerts-by-the-creek.jpeg?w=1119&amp;ssl=1 1119w" sizes="(max-width: 780px) 100vw, 780px" title="6 Fun Things To Do This Weekend In Collin County! (09/30) 4" layout="responsive" disable-inline-width="" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:56.0256%;"></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="437" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/concerts-by-the-creek.jpeg?resize=780%2C437&amp;ssl=1" alt="concerts by the creek is the perfect thing to do this weekend with the music-lover in your life." class="wp-image-46842" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/concerts-by-the-creek.jpeg?resize=1024%2C574&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/concerts-by-the-creek.jpeg?resize=300%2C168&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/concerts-by-the-creek.jpeg?resize=768%2C430&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/concerts-by-the-creek.jpeg?resize=400%2C224&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/concerts-by-the-creek.jpeg?resize=150%2C84&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/concerts-by-the-creek.jpeg?resize=706%2C396&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/concerts-by-the-creek.jpeg?w=1119&amp;ssl=1 1119w" sizes="(max-width: 780px) 100vw, 780px" title="6 Fun Things To Do This Weekend In Collin County! (09/30) 4"></noscript></amp-img><figcaption>Concerts by the Creek is the perfect thing to do this weekend with the music-lover in your life.</figcaption></figure>

<h2>Concerts by the Creek</h2>

<p><em>Saturday, October 2 from 7 p.m. to 9 p.m.</em></p>

<p>Listen to a free neighborhood concert at Watters Creek. Each Saturday, a new local band will perform for all to listen. This weekend, check out Havana NRG!</p>

<p><em>Watters Creek | 970 Garden Park Dr., Allen</em></p>

<figure class="wp-block-image alignwide size-full"><amp-img width="780" height="536" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=780%2C536&amp;ssl=1" alt="autumn at the arboretum is a perfect thing to do this weekend to celebrate the coming of october!" class="wp-image-48203 amp-wp-enforced-sizes i-amphtml-layout-responsive i-amphtml-layout-size-defined" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?w=980&amp;ssl=1 980w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=300%2C206&amp;ssl=1 300w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=768%2C528&amp;ssl=1 768w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=400%2C275&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=706%2C486&amp;ssl=1 706w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=150%2C103&amp;ssl=1 150w" sizes="(max-width: 780px) 100vw, 780px" title="6 Fun Things To Do This Weekend In Collin County! (09/30) 5" layout="responsive" disable-inline-width="" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:68.7179%;"></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="536" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=780%2C536&amp;ssl=1" alt="autumn at the arboretum is a perfect thing to do this weekend to celebrate the coming of october!" class="wp-image-48203" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?w=980&amp;ssl=1 980w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=300%2C206&amp;ssl=1 300w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=768%2C528&amp;ssl=1 768w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=400%2C275&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=706%2C486&amp;ssl=1 706w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/autumn-at-the-arboretum.jpeg?resize=150%2C103&amp;ssl=1 150w" sizes="(max-width: 780px) 100vw, 780px" title="6 Fun Things To Do This Weekend In Collin County! (09/30) 5"></noscript></amp-img><figcaption>Autumn at the Arboretum is a perfect thing to do this weekend to celebrate the coming of October!</figcaption></figure>

<h2>Autumn at the Arboretum</h2>

<p><em>Available all weekend</em></p>
<aside>					<amp-analytics class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed">
			<script type="application/json">
				{"requests":{"event":"https:\/\/localprofile.com\/wp-content\/plugins\/newspack-popups\/includes\/..\/api\/campaigns\/index.php"},"triggers":{"trackPageview":{"on":"visible","request":"event","visibilitySpec":{"selector":"#c9a5","visiblePercentageMin":90,"totalTimeMin":500,"continuousTimeMin":200},"extraUrlParams":{"popup_id":"id_29097","cid":"CLIENT_ID(newspack-cid)"}},"formSubmitSuccess":{"on":"amp-form-submit-success","request":"event","selector":"#c9a5 .wp-block-jetpack-mailchimp form","extraUrlParams":{"popup_id":"id_29097","cid":"CLIENT_ID(newspack-cid)","mailing_list_status":"subscribed","email":"${formFields[email]}"}}}}			</script>
		</amp-analytics>
					<amp-layout amp-access="popups.id_29097" amp-access-hide class="newspack-popup  newspack-inline-popup     amp-wp-430ac8e i-amphtml-layout-container" role="button" tabindex="0" id="c9a5" data-amp-original-style="background-color:#EEEEEE;color:#000" i-amphtml-layout="container">
								
<div class="wp-block-group newspack-pattern subscribe__style-1"><div class="wp-block-group__inner-container">
<div class="wp-block-media-text has-media-on-the-right is-stacked-on-mobile is-vertically-aligned-center is-image-fill has-white-color has-text-color has-background amp-wp-4acd9eb" data-amp-original-style="background-color:#263373;grid-template-columns:auto 68%"><figure class="wp-block-media-text__media amp-wp-f684c78" data-amp-original-style="background-image:url(https://i0.wp.com/localprofile.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-12-at-8.42.36-PM-1.png?fit=960%2C933&amp;ssl=1);background-position:54% 0%"><amp-img src="https://i0.wp.com/localprofile.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-12-at-8.42.36-PM-1.png?fit=960%2C933&amp;ssl=1" alt="screen shot 2020 05 12 at 8.42.36 pm 1" class="wp-image-28004 size-full amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" title="6 Fun Things To Do This Weekend In Collin County! (09/30) 6" width="960" height="933" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzkzMycgd2lkdGg9Jzk2MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img src="https://i0.wp.com/localprofile.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-12-at-8.42.36-PM-1.png?fit=960%2C933&amp;ssl=1" alt="screen shot 2020 05 12 at 8.42.36 pm 1" class="wp-image-28004 size-full" title="6 Fun Things To Do This Weekend In Collin County! (09/30) 6" width="960" height="933"></noscript></amp-img></figure><div class="wp-block-media-text__content">
<h2 id="h-have-you-subscribed-to-our-free-weekly-newsletter">Have you subscribed to our free weekly newsletter? </h2>



<h2 id="h-it-s-awesome">It’s awesome.</h2>


<amp-layout id="nd92" class="i-amphtml-layout-container" i-amphtml-layout="container">
	<div class="wp-block-jetpack-mailchimp" data-blog-id="177389529">
		<form aria-describedby="wp-block-jetpack-mailchimp_consent-text" action-xhr="https://public-api.wordpress.com/rest/v1.1/sites/177389529/email_follow/amp/subscribe/" method="post" id="mailchimp_form" target="_top" on="submit-success:AMP.setState( { mailing_list_status: 'subscribed', mailing_list_email: event.response.email } )">
			<p>
				<input aria-label="Enter your email" placeholder="Enter your email" required title="Enter your email" type="email" name="email">
			</p>
									
<div class="wp-block-jetpack-button wp-block-button" style=""><button class="wp-block-button__link has-text-color has-background has-white-background-color amp-wp-4be9315" data-id-attr="mailchimp-button-block-4" id="mailchimp-button-block-4" type="submit" data-amp-original-style="color: #ff5959;">SIGN UP</button></div>
			<p id="wp-block-jetpack-mailchimp_consent-text">
				Stay up-to-date with all the latest local news and events, delivered directly to your inbox, every Monday. <strong>Subscribe now.</strong>			</p>

			
				<div submit-success>
					<template type="amp-mustache">
						<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_success wp-block-jetpack-mailchimp__is-amp">
							Success! You're on the list.						</div>
					</template>
				</div>
				<div submit-error>
					<template type="amp-mustache">
						<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_error wp-block-jetpack-mailchimp__is-amp">
							Whoops! There was an error and we couldn't process your subscription. Please reload the page and try again.						</div>
					</template>
				</div>
				<div submitting>
					<template type="amp-mustache">
						<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_processing wp-block-jetpack-mailchimp__is-amp" role="status">
							Processing…						</div>
					</template>
				</div>

			
		</form>
			</div>
	</amp-layout></div></div>



<div aria-hidden="true" class="wp-block-spacer amp-wp-687c3be" data-amp-original-style="height:20px"></div>
</div></div>
												<form class="popup-not-interested-form c9a51 popup-action-form c9a5 align-center" method="POST" action-xhr="https://localprofile.com/wp-content/plugins/newspack-popups/includes/../api/campaigns/index.php" target="_top">
							<input name="popup_id" type="hidden" value="id_29097">
		<input name="cid" type="hidden" value="CLIENT_ID(newspack-cid)" data-amp-replace="CLIENT_ID">
		<input name="mailing_list_status" type="hidden" data-amp-bind-value="mailing_list_status">
		<input name="is_newsletter_popup" type="hidden" value="">
						<input name="suppress_forever" type="hidden" value="1">
				<button on="tap:c9a5.hide" aria-label="" data-amp-original-style="background-color:#EEEEEE;color:#000" class="amp-wp-430ac8e">I'm not interested</button>
			</form>
									</amp-layout>
		</aside>

<p>Celebrate autumn at the Southwest’s favorite fall festival! There will be over 90,000 pumpkins, gourds, squash, and more all across the garden. The nationally acclaimed Pumpkin Village will have 20-foot-tall pumpkin houses, insect topiaries, and a maze. Don’t miss out on Collin County’s favorite autumn activity! </p>

<p><em>The Dallas Arboretum | 8535 Garland Rd., Dallas</em></p>

<figure class="wp-block-image alignwide size-full"><amp-img width="500" height="681" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/MakeRoomforColor.jpeg?resize=500%2C681&amp;ssl=1" alt="this local artist's exhibit is an inspiring thing to do this weekend." class="wp-image-46844 amp-wp-enforced-sizes i-amphtml-layout-responsive i-amphtml-layout-size-defined" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/MakeRoomforColor.jpeg?w=500&amp;ssl=1 500w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/MakeRoomforColor.jpeg?resize=220%2C300&amp;ssl=1 220w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/MakeRoomforColor.jpeg?resize=400%2C545&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/MakeRoomforColor.jpeg?resize=150%2C204&amp;ssl=1 150w" sizes="(max-width: 500px) 100vw, 500px" title="6 Fun Things To Do This Weekend In Collin County! (09/30) 7" layout="responsive" disable-inline-width="" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:136.2000%;"></i-amphtml-sizer><noscript><img loading="lazy" width="500" height="681" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/MakeRoomforColor.jpeg?resize=500%2C681&amp;ssl=1" alt="this local artist's exhibit is an inspiring thing to do this weekend." class="wp-image-46844" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/MakeRoomforColor.jpeg?w=500&amp;ssl=1 500w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/MakeRoomforColor.jpeg?resize=220%2C300&amp;ssl=1 220w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/MakeRoomforColor.jpeg?resize=400%2C545&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/09/MakeRoomforColor.jpeg?resize=150%2C204&amp;ssl=1 150w" sizes="(max-width: 500px) 100vw, 500px" title="6 Fun Things To Do This Weekend In Collin County! (09/30) 7"></noscript></amp-img><figcaption>This local artist’s exhibit is an inspiring thing to do this weekend.</figcaption></figure>

<h2>Opening of <em>Make Room for Color</em></h2>

<p><em>Available all weekend</em></p>

<p>Join Kelly Steller Hrad in the opening of her solo exhibition, <em>Make Room for Color</em>. Her paintings use acrylic, oil, and more to express her thoughts with color, layers, and vividness. Take a look at her captivating work at the ArtCentre of Plano!</p>

<p><em>ArtCentre of Plano | 902 E. 16th St., Plano</em></p>

<figure class="wp-block-image alignwide size-large"><amp-img width="780" height="439" src="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=780%2C439&amp;ssl=1" alt="immersive van gogh is a beautiful thing to do this weekend!" class="wp-image-46487 amp-wp-enforced-sizes i-amphtml-layout-responsive i-amphtml-layout-size-defined" srcset="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=1024%2C576&amp;ssl=1 1024w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=1536%2C864&amp;ssl=1 1536w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=1568%2C882&amp;ssl=1 1568w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=400%2C225&amp;ssl=1 400w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=150%2C84&amp;ssl=1 150w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=706%2C397&amp;ssl=1 706w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?w=1660&amp;ssl=1 1660w" sizes="(max-width: 780px) 100vw, 780px" title="6 Fun Things To Do This Weekend In Collin County! (09/30) 8" layout="responsive" disable-inline-width="" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:56.2821%;"></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="439" src="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=780%2C439&amp;ssl=1" alt="immersive van gogh is a beautiful thing to do this weekend!" class="wp-image-46487" srcset="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=1024%2C576&amp;ssl=1 1024w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=1536%2C864&amp;ssl=1 1536w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=1200%2C675&amp;ssl=1 1200w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=1568%2C882&amp;ssl=1 1568w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=400%2C225&amp;ssl=1 400w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=150%2C84&amp;ssl=1 150w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?resize=706%2C397&amp;ssl=1 706w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/08/immersive-van-gogh-1.jpeg?w=1660&amp;ssl=1 1660w" sizes="(max-width: 780px) 100vw, 780px" title="6 Fun Things To Do This Weekend In Collin County! (09/30) 8"></noscript></amp-img><figcaption>Immersive Van Gogh is a beautiful thing to do this weekend!</figcaption></figure>

<h2>Immersive Van Gogh</h2>

<p><em>Available all weekend</em></p>

<p>Visit this mindblowing immersive experience where you’ll be surrounded by 500,000 cubic feet of projections displaying Van Gogh’s work. For more information and tickets, visit <a href="https://www.dallasvangogh.com/about/" target="_blank" rel="noopener">www.dallasvangogh.com/about</a>. </p>

<p><em>Lighthouse Dallas | 507 S. Harwood St., Dallas</em></p>

<h3 class="has-text-align-center">More Fun Things To Do This Weekend</h3>

<p>If you want even more ideas for fund things to do this weekend, here’s a list of even more great options which are available every weekend for the forseeable future.</p>

<p>For young kids, there’s the <a href="https://localprofile.com/2021/08/25/paw-patrol-experience-camp-dallas/">PAW Patrol experience at CAMP in Dallas</a> and the <a href="https://localprofile.com/2021/07/20/sci-tech-discovery-frisco-museum/">Sci-Tech Discovery Center in Frisco</a>. Also check out our<a href="https://localprofile.com/best-playgrounds/"> ultimate guide to the best playgrounds in and around Collin County</a> – that list will keep you and your kids entertained for the rest of the year! You may also want to dive into one last splash before the end of summer, <a href="https://localprofile.com/2021/09/07/splash-pads-after-labor-day/">there are over 10 local splash pads that are still open!</a></p>

<p>Meanwhile <a href="https://localprofile.com/2021/06/30/jurassic-world-exhibition-grandscape/">Jurassic World at Grandscape in The Colony</a> is fun for all the family, as is a visit to the <a href="https://localprofile.com/2021/08/09/5-must-dos-fort-worth-stockyards/">Fort Worth Stockyards</a>. But if you’re looking for adults-only fun, we recommend checking out the newest addition to The Shops at Legacy – <a href="https://localprofile.com/2021/08/20/bottle-rockets-bar-in-plano/">Bottle Rockets, a “grown-up playground” with arcade games and much more.</a></p>

<nav class="jp-relatedposts-i2" data-layout="grid"><h3 class="jp-relatedposts-headline"><em>Related</em></h3><div class="jp-related-posts-i2__row" data-post-count="3"><ul id="related-posts-item-6155c1a385883" aria-labelledby="related-posts-item-6155c1a385883-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-6155c1a385883-label" href="https://localprofile.com/2021/09/23/to-do-this-weekend-collin-sept-23-2021/">6 fun things to do this weekend in Collin County! (09/23)</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://localprofile.com/2021/09/23/to-do-this-weekend-collin-sept-23-2021/"><amp-img src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/arboretum.jpeg?fit=1200%2C900&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt="Autumn at the Arboretum is the perfect thing to do this weekend now that it actually feels like fall!" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzIwMCcgd2lkdGg9JzM1MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/arboretum.jpeg?fit=1200%2C900&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt="Autumn at the Arboretum is the perfect thing to do this weekend now that it actually feels like fall!"></noscript></amp-img></a></li></ul><ul id="related-posts-item-6155c1a3858b4" aria-labelledby="related-posts-item-6155c1a3858b4-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-6155c1a3858b4-label" href="https://localprofile.com/2021/08/31/10-family-september-events-2021/">10 best family-friendly September events in 2021</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://localprofile.com/2021/08/31/10-family-september-events-2021/"><amp-img src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/08/sft-18_btcom_media_1080x720_fairatsunset.jpg?fit=1080%2C720&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt="The State Fair of Texas is one of these September events that the whole family will love!" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzIwMCcgd2lkdGg9JzM1MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/08/sft-18_btcom_media_1080x720_fairatsunset.jpg?fit=1080%2C720&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt="The State Fair of Texas is one of these September events that the whole family will love!"></noscript></amp-img></a></li></ul><ul id="related-posts-item-6155c1a3858d3" aria-labelledby="related-posts-item-6155c1a3858d3-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-6155c1a3858d3-label" href="https://localprofile.com/2021/08/23/6-best-fall-festivals-in-north-texas/">We can’t wait for these 6 local fall festivals!</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://localprofile.com/2021/08/23/6-best-fall-festivals-in-north-texas/"><amp-img src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/08/autumn-at-the-arboretum.jpeg?fit=800%2C500&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt="&quot;Autumn at the Arboretum&quot; is one of Dallas' most beloved fall festivals! | Image courtesy of the Dallas Arboretum website" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzIwMCcgd2lkdGg9JzM1MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/08/autumn-at-the-arboretum.jpeg?fit=800%2C500&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt="&quot;Autumn at the Arboretum&quot; is one of Dallas' most beloved fall festivals! | Image courtesy of the Dallas Arboretum website"></noscript></amp-img></a></li></ul></div></nav><section id="bs_zones-6" class="below-content widget bs_zones"><div><amp-ad type="broadstreetads" width="728" height="120" data-network="6972" data-zone="89884" data-keywords="not_home_page,not_landing_page,is_article_page,things-to-do,to-do-this-weekend-collin-sept-30-2021,post" data-place="" layout="responsive" data-amp-original-style="max-width: 728px; margin: 0 auto;" class="amp-wp-df48a09 i-amphtml-layout-responsive i-amphtml-layout-size-defined" id="i-amp-2" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:16.4835%;"></i-amphtml-sizer></amp-ad></div></section><section id="bs_zones-14" class="below-content widget bs_zones"><div><amp-ad type="broadstreetads" width="800" height="600" data-network="6972" data-zone="89667" data-keywords="not_home_page,not_landing_page,is_article_page,things-to-do,to-do-this-weekend-collin-sept-30-2021,post" data-place="" layout="responsive" data-amp-original-style="max-width: 800px; margin: 0 auto;" class="amp-wp-eb46d9d i-amphtml-layout-responsive i-amphtml-layout-size-defined" id="i-amp-3" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:75.0000%;"></i-amphtml-sizer></amp-ad></div></section>	</div><!-- .entry-content -->

	<footer class="entry-footer">
		<span class="tags-links"><span>Tagged: </span><a href="https://localprofile.com/tag/to-do/" rel="tag">to do</a><span class="sep">, </span><a href="https://localprofile.com/tag/things-to-do/" rel="tag">Things to do</a><span class="sep">, </span><a href="https://localprofile.com/tag/things-to-do-this-weekend/" rel="tag">things to do this weekend</a></span>	</footer><!-- .entry-footer -->

	
<div class="author-bio">

	<div class="author-bio-text">
		<div class="author-bio-header">
			<amp-img alt="avatar of jordan jarrett" src="https://secure.gravatar.com/avatar/93271734e931516925dc26f37f369e5f?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/93271734e931516925dc26f37f369e5f?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="80" width="80" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzgwJyB3aWR0aD0nODAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img alt="avatar of jordan jarrett" src="https://secure.gravatar.com/avatar/93271734e931516925dc26f37f369e5f?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/93271734e931516925dc26f37f369e5f?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo" height="80" width="80" loading="lazy"></noscript></amp-img>
			<div>
				<h2 class="accent-header">
					Jordan Jarrett				</h2>

							</div>
		</div><!-- .author-bio-header -->

					<p>
				Jordan is the digital manager at Local Profile. She creates digital, print and social content. Her passion is profiling people and their experiences, connecting community through authentic narrative.				<a class="author-link" href="https://localprofile.com/author/jordan/" rel="author">
				More by Jordan Jarrett				</a>
			</p>
		
		
	</div><!-- .author-bio-text -->
</div><!-- .author-bio -->

</article><!-- #post-${ID} -->
				</div><!-- .main-content -->

			
<aside id="secondary" class="widget-area">
	<section id="bs_zones-2" class="widget bs_zones"><div><amp-ad type="broadstreetads" width="300" height="250" data-network="6972" data-zone="89045" data-keywords="not_home_page,not_landing_page,is_article_page,things-to-do,to-do-this-weekend-collin-sept-30-2021,post" data-place="" layout="responsive" data-amp-original-style="max-width: 300px; margin: 0 auto;" class="amp-wp-69f1c1a i-amphtml-layout-responsive i-amphtml-layout-size-defined" id="i-amp-4" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:83.3333%;"></i-amphtml-sizer></amp-ad></div></section><section id="mc4wp_form_widget-2" class="widget widget_mc4wp_form_widget"><h2 class="widget-title accent-header"><span>Newsletter</span></h2><!-- Mailchimp for WordPress v4.8.6 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-28045" action-xhr="https://localprofile.com/wp-json/mc4wp/v1/form" method="post" data-id="28045" data-name="Newsletter Sign-Up" target="_top"><div class="mc4wp-form-fields"><p>
	<label>Have you subscribed to our free weekly newsletter? <br><br>It’s awesome.<br><br>
		<input type="email" name="EMAIL" placeholder="Your email here." required>
</label>
</p>

<p>
	<input type="submit" value="Sign up" data-amp-original-style="background-color:#ff5959;" class="amp-wp-be8153e">
</p>		<div submitting>
			<template type="amp-mustache">
				Submitting...			</template>
		</div>
		<div submit-success>
			<template type="amp-mustache">
				Thank you, your sign-up request was successful! Please check your email inbox to confirm.			</template>
		</div>
		<div submit-error>
			<template type="amp-mustache">
				{{message}}
			</template>
		</div>
		</div><label data-amp-original-style="display: none !important;" class="amp-wp-3e2e7c3">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off"></label><input type="hidden" name="_mc4wp_timestamp" value="1633010083"><input type="hidden" name="_mc4wp_form_id" value="28045"><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1"><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin --></section><section id="bs_zones-3" class="widget bs_zones"><div><amp-ad type="broadstreetads" width="300" height="250" data-network="6972" data-zone="89046" data-keywords="not_home_page,not_landing_page,is_article_page,things-to-do,to-do-this-weekend-collin-sept-30-2021,post" data-place="" layout="responsive" data-amp-original-style="max-width: 300px; margin: 0 auto;" class="amp-wp-69f1c1a i-amphtml-layout-responsive i-amphtml-layout-size-defined" id="i-amp-5" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:83.3333%;"></i-amphtml-sizer></amp-ad></div></section>
		<section id="recent-posts-4" class="widget widget_recent_entries">
		<h2 class="widget-title accent-header"><span>Recent News</span></h2>
		<ul>
											<li>
					<a href="https://localprofile.com/2021/09/30/october-to-do-10-2021/">October To Do: 10 best events &amp; things to do (10/2021)</a>
											<span class="post-date">September 30, 2021</span>
									</li>
											<li>
					<a href="https://localprofile.com/2021/09/30/to-do-this-weekend-collin-sept-30-2021/" aria-current="page">6 fun things to do this weekend in Collin County! (09/30)</a>
											<span class="post-date">September 30, 2021</span>
									</li>
											<li>
					<a href="https://localprofile.com/2021/09/30/haunted-houses-collin/">Here are 4 scary haunted houses to check out if you’re searching for spooks</a>
											<span class="post-date">September 30, 2021</span>
									</li>
											<li>
					<a href="https://localprofile.com/2021/09/29/loop-ping-pong-kitchen-bar/">Loop Ping Pong Kitchen and Bar is opening in Frisco</a>
											<span class="post-date">September 29, 2021</span>
									</li>
											<li>
					<a href="https://localprofile.com/2021/09/27/the-friends-experience-in-plano/">“The One Where I Fangirl Out” – The FRIENDS Experience is coming to Plano!</a>
											<span class="post-date">September 27, 2021</span>
									</li>
					</ul>

		</section><section id="bs_zones-4" class="widget bs_zones"><div><amp-ad type="broadstreetads" width="300" height="250" data-network="6972" data-zone="89047" data-keywords="not_home_page,not_landing_page,is_article_page,things-to-do,to-do-this-weekend-collin-sept-30-2021,post" data-place="" layout="responsive" data-amp-original-style="max-width: 300px; margin: 0 auto;" class="amp-wp-69f1c1a i-amphtml-layout-responsive i-amphtml-layout-size-defined" id="i-amp-6" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:83.3333%;"></i-amphtml-sizer></amp-ad></div></section><section id="bs_zones-8" class="widget bs_zones"><div><amp-ad type="broadstreetads" width="320" height="600" data-network="6972" data-zone="89637" data-keywords="not_home_page,not_landing_page,is_article_page,things-to-do,to-do-this-weekend-collin-sept-30-2021,post" data-place="" layout="responsive" data-amp-original-style="max-width: 320px; margin: 0 auto;" class="amp-wp-1154b98 i-amphtml-layout-responsive i-amphtml-layout-size-defined" id="i-amp-7" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:187.5000%;"></i-amphtml-sizer></amp-ad></div></section><section id="bs_zones-15" class="widget bs_zones"><div><amp-ad type="broadstreetads" width="300" height="600" data-network="6972" data-zone="90132" data-keywords="not_home_page,not_landing_page,is_article_page,things-to-do,to-do-this-weekend-collin-sept-30-2021,post" data-place="" layout="responsive" data-amp-original-style="max-width: 300px; margin: 0 auto;" class="amp-wp-69f1c1a i-amphtml-layout-responsive i-amphtml-layout-size-defined" id="i-amp-8" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:200.0000%;"></i-amphtml-sizer></amp-ad></div></section><section id="jetpack-search-filters-2" class="widget jetpack-filters widget_search">			<div id="jetpack-search-filters-2-wrapper">
		<div class="jetpack-search-form">
<form role="search" method="get" class="search-form" action="https://localprofile.com/" target="_top">
	<label for="search-form-5">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-5" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
<input type="hidden" name="orderby" value="relevance_desc"><input type="hidden" name="order" value="DESC"></form>
</div>					<div class="jetpack-search-sort-wrapper">
				<label>
					Sort by					<select class="jetpack-search-sort">
													<option value="relevance|DESC">
								Relevance							</option>
													<option value="date|DESC">
								Newest first							</option>
													<option value="date|ASC">
								Oldest first							</option>
											</select>
				</label>
			</div>
					
			</div></section></aside><!-- #secondary -->

		</main><!-- #main -->
	</section><!-- #primary -->


	
	<section class="newspack-broadstreet-footer amp-wp-543be6b" data-amp-original-style="text-align:center; padding: 25px;"><amp-ad type="broadstreetads" width="1056" height="151" data-network="6972" data-zone="89160" data-keywords="not_home_page,not_landing_page,is_article_page,things-to-do,to-do-this-weekend-collin-sept-30-2021,post" layout="responsive" data-amp-original-style="max-width: 1056px; margin: 0 auto;" class="amp-wp-4ed706e i-amphtml-layout-responsive i-amphtml-layout-size-defined" id="i-amp-9" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:14.2992%;"></i-amphtml-sizer></amp-ad></section>
	</div><!-- #content -->

	<footer id="colophon" class="site-footer">

					<div class="footer-branding">
		<div class="wrapper">
							<a class="footer-logo-link" href="https://localprofile.com/" rel="home">
					<amp-img width="400" height="176" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?fit=400%2C176&amp;ssl=1" class="footer-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?w=400&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?resize=300%2C132&amp;ssl=1 300w" sizes="(max-width: 400px) 100vw, 400px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzE3Nicgd2lkdGg9JzQwMCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img width="400" height="176" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?fit=400%2C176&amp;ssl=1" class="footer-logo" alt="" loading="lazy" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?w=400&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?resize=300%2C132&amp;ssl=1 300w" sizes="(max-width: 400px) 100vw, 400px"></noscript></amp-img>				</a>
				<nav class="social-navigation" aria-label="Social Links Menu">
		<ul id="menu-social-menu-1" class="social-links-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30800"><a href="https://www.facebook.com/LocalProfile"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30802"><a href="https://www.instagram.com/localprofile_cc/"><span class="screen-reader-text">Instagram</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47230"><a href="https://twitter.com/localprofile_cc?lang=en"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30804"><a href="https://www.linkedin.com/company/localprofile"><span class="screen-reader-text">LinkedIn</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M19.7,3H4.3C3.582,3,3,3.582,3,4.3v15.4C3,20.418,3.582,21,4.3,21h15.4c0.718,0,1.3-0.582,1.3-1.3V4.3 C21,3.582,20.418,3,19.7,3z M8.339,18.338H5.667v-8.59h2.672V18.338z M7.004,8.574c-0.857,0-1.549-0.694-1.549-1.548 c0-0.855,0.691-1.548,1.549-1.548c0.854,0,1.547,0.694,1.547,1.548C8.551,7.881,7.858,8.574,7.004,8.574z M18.339,18.338h-2.669 v-4.177c0-0.996-0.017-2.278-1.387-2.278c-1.389,0-1.601,1.086-1.601,2.206v4.249h-2.667v-8.59h2.559v1.174h0.037 c0.356-0.675,1.227-1.387,2.526-1.387c2.703,0,3.203,1.779,3.203,4.092V18.338z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47231"><a href="https://www.youtube.com/channel/UC_9B-HjCwFD2-VjWys6c59g"><span class="screen-reader-text">Youtube</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->
		</div><!-- .wrapper -->
	</div><!-- .footer-branding -->
		
	<aside class="widget-area footer-widgets" role="complementary" aria-label="Footer">
		<div class="wrapper">
			<section id="text-5" class="widget widget_text"><h2 class="widget-title">BROWSE LATEST ISSUE</h2>			<div class="textwidget"><p><a href="https://www.qgdigitalpublishing.com/publication/?i=718889"><amp-img class="wp-image-47238 size-medium alignleft amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/SEPT-OCT21_Cover4.jpg?resize=225%2C300&amp;ssl=1" alt="" width="225" height="300" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzMwMCcgd2lkdGg9JzIyNScgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img loading="lazy" class="wp-image-47238 size-medium alignleft" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/09/SEPT-OCT21_Cover4.jpg?resize=225%2C300&amp;ssl=1" alt="" width="225" height="300"></noscript></amp-img></a></p>
<p> </p>
<p> </p>
</div>
		</section><section id="text-4" class="widget widget_text"><h2 class="widget-title">SECTIONS</h2>			<div class="textwidget"><p><a href="https://localprofile.com?footernav">Home</a><br>
<a href="https://localprofile.com/category/latest/">Latest</a><br>
<a href="https://localprofile.com/category/covid-19/">COVID-19</a><br>
<a href="https://localprofile.com/category/arts-and-culture/">Arts + Culture</a><br>
<a href="https://localprofile.com/category/business/">Business</a><br>
<a href="https://localprofile.com/category/community/">Community</a><br>
<a href="https://localprofile.com/category/food-and-drink/">Food + Drink</a><br>
<a href="https://localprofile.com/category/health/">Health</a><br>
<a href="https://localprofile.com/category/lifestyle">Lifestyle</a><br>
<a href="https://localprofile.com/category/things-to-do/">Things To Do</a><br>
<a href="https://localprofile.com/category/top-listings">Top Listings</a><br>
<a href="https://localprofile.com/category/women-in-business/">Women In Business</a></p>
</div>
		</section><section id="mc4wp_form_widget-3" class="widget widget_mc4wp_form_widget"><h2 class="widget-title">NEWSLETTER</h2><!-- Mailchimp for WordPress v4.8.6 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-2" class="mc4wp-form mc4wp-form-28045" action-xhr="https://localprofile.com/wp-json/mc4wp/v1/form" method="post" data-id="28045" data-name="Newsletter Sign-Up" target="_top"><div class="mc4wp-form-fields"><p>
	<label>Have you subscribed to our free weekly newsletter? <br><br>It’s awesome.<br><br>
		<input type="email" name="EMAIL" placeholder="Your email here." required>
</label>
</p>

<p>
	<input type="submit" value="Sign up" data-amp-original-style="background-color:#ff5959;" class="amp-wp-be8153e">
</p>		<div submitting>
			<template type="amp-mustache">
				Submitting...			</template>
		</div>
		<div submit-success>
			<template type="amp-mustache">
				Thank you, your sign-up request was successful! Please check your email inbox to confirm.			</template>
		</div>
		<div submit-error>
			<template type="amp-mustache">
				{{message}}
			</template>
		</div>
		</div><label data-amp-original-style="display: none !important;" class="amp-wp-3e2e7c3">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off"></label><input type="hidden" name="_mc4wp_timestamp" value="1633010083"><input type="hidden" name="_mc4wp_form_id" value="28045"><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-2"><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin --></section><section id="text-6" class="widget widget_text"><h2 class="widget-title">CONTACT US</h2>			<div class="textwidget"><p>1413 Gables Court<br>
Plano, Texas 75075<br>
(972) 769-7272<br>
<span class="email-address">connect@localprofile.com</span></p>
</div>
		</section>		</div><!-- .wrapper -->
	</aside><!-- .widget-area -->


		<div class="site-info">

			
			<div class="wrapper site-info-contain">
													<span class="copyright">© 2021 Community Profile, LLC, 2021.</span>
				
				<a href="https://newspack.pub/" class="imprint">
					Proudly powered by Newspack by Automattic				</a>

							</div><!-- .wrapper -->
		</div><!-- .site-info -->
	</footer><!-- #colophon -->

</div><!-- #page -->



<!-- Twitter universal website tag code -->

<!-- End Twitter universal website tag code -->




			<amp-analytics type="gtag" config='https://localprofile.com/wp-content/plugins/newspack-popups/includes/../api/segmentation/index.php?client_id=CLIENT_ID(newspack-cid)&amp;post_id=48198&amp;custom_dimensions=[{"role":"category","option":{"value":"category","label":"Category"},"gaID":"ga:dimension1"}]&amp;custom_dimensions_existing_values={"dimension1":"things-to-do"}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"></amp-analytics>
		
<!-- font handler -->
    		<amp-install-serviceworker src="https://localprofile.com/wp.serviceworker" data-iframe-src="https://localprofile.com/?amp_install_service_worker_iframe=1" layout="nodisplay" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		</amp-install-serviceworker>
		
<!-- Google Analytics AMP snippet added by Site Kit -->
<amp-analytics type="gtag" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"optoutElementId":"__gaOptOutExtension","vars":{"gtag_id":"UA-19203311-1","config":{"UA-19203311-1":{"groups":"default","linker":[],"send_page_view":false,"dimension1":"things-to-do"}}}}</script></amp-analytics>
<!-- End Google Analytics AMP snippet added by Site Kit -->

<!-- Google Tag Manager AMP snippet added by Site Kit -->
<amp-analytics config="https://www.googletagmanager.com/amp.json?id=GTM-5VJ7RHF" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"optoutElementId":"__gaOptOutExtension"}</script></amp-analytics>
<!-- End Google Tag Manager AMP snippet added by Site Kit -->
<amp-analytics id="parsely" type="parsely" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"vars":{"apikey":"localprofile.com"}}</script></amp-analytics>	
	





















			<amp-analytics class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed">
				<script type="application/json">
					{"linkers":{"enabled":true,"ref_newspack_cid":{"ids":{"cid":"CLIENT_ID(newspack-cid)"}}},"cookies":{"enabled":true,"newspack-cid":{"value":"LINKER_PARAM(ref_newspack_cid, cid)"}}}				</script>
			</amp-analytics>
						<amp-analytics type="gtag" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed">
					<script type="application/json">
						{"optoutElementId":"__gaOptOutExtension","vars":{"gtag_id":"UA-19203311-1","config":{"UA-19203311-1":{"groups":"default","linker":{"domains":["localprofile.com"]},"send_page_view":false}}},"triggers":{"n2c3":{"request":"event","on":"click","vars":{"event_name":"social share","event_category":"NTG social","event_label":"facebook"},"selector":"amp-social-share[type=\"facebook\"]"},"n2c6":{"request":"event","on":"click","vars":{"event_name":"social share","event_category":"NTG social","event_label":"twitter"},"selector":"amp-social-share[type=\"twitter\"]"},"n2c7":{"request":"event","on":"click","vars":{"event_name":"social share","event_category":"NTG social","event_label":"whatsapp"},"selector":"amp-social-share[type=\"whatsapp\"]"},"n2c8":{"request":"event","on":"click","vars":{"event_name":"social share","event_category":"NTG social","event_label":"linkedin"},"selector":"amp-social-share[type=\"linkedin\"]"},"n2ea":{"request":"event","on":"scroll","vars":{"event_name":"25%","event_category":"NTG article milestone","non_interaction":true,"value":25,"event_label":"6 fun things to do this weekend in Collin County! (09\/30)"},"event_value":25,"scrollSpec":{"verticalBoundaries":[25]}},"n39e":{"request":"event","on":"scroll","vars":{"event_name":"50%","event_category":"NTG article milestone","non_interaction":true,"value":50,"event_label":"6 fun things to do this weekend in Collin County! (09\/30)"},"event_value":50,"scrollSpec":{"verticalBoundaries":[50]}},"n3f0":{"request":"event","on":"scroll","vars":{"event_name":"100%","event_category":"NTG article milestone","non_interaction":true,"value":100,"event_label":"6 fun things to do this weekend in Collin County! (09\/30)"},"event_value":100,"scrollSpec":{"verticalBoundaries":[100]}},"c482":{"request":"event","on":"ini-load","vars":{"event_name":"Load","event_category":"Newspack Announcement","non_interaction":true,"event_label":"Center: Newsletter sign-up pop-up (47540)"},"selector":"#ce68"},"c488":{"request":"event","on":"visible","vars":{"event_name":"Seen","event_category":"Newspack Announcement","non_interaction":true,"event_label":"Center: Newsletter sign-up pop-up (47540)"},"selector":"#ce68","visibilitySpec":{"totalTimeMin":500}},"c48b":{"request":"event","on":"amp-form-submit-success","vars":{"event_name":"Form Submission","event_category":"Newspack Announcement","event_label":"Center: Newsletter sign-up pop-up (47540)"},"selector":"#ce68 form:not(.ce68)"}}}					</script>
				</amp-analytics>
							<amp-analytics type="gtag" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed">
					<script type="application/json">
						{"optoutElementId":"__gaOptOutExtension","vars":{"gtag_id":"UA-19203311-1","config":{"UA-19203311-1":{"groups":"default","linker":{"domains":["localprofile.com"]},"send_page_view":false}}},"triggers":{"c48e":{"request":"event","on":"amp-form-submit-success","vars":{"event_name":"Dismissal","event_category":"Newspack Announcement","non_interaction":true,"event_label":"Center: Newsletter sign-up pop-up (47540)"},"selector":".ce680"},"c490":{"request":"event","on":"amp-form-submit-success","vars":{"event_name":"Permanent Dismissal","event_category":"Newspack Announcement","non_interaction":true,"event_label":"Center: Newsletter sign-up pop-up (47540)"},"selector":".ce681"},"ca44":{"request":"event","on":"ini-load","vars":{"event_name":"Load","event_category":"Newspack Announcement","non_interaction":true,"event_label":"Inline: Newsletter (29097)"},"selector":"#c9a5"},"ca48":{"request":"event","on":"visible","vars":{"event_name":"Seen","event_category":"Newspack Announcement","non_interaction":true,"event_label":"Inline: Newsletter (29097)"},"selector":"#c9a5","visibilitySpec":{"totalTimeMin":500}},"ca4a":{"request":"event","on":"amp-form-submit-success","vars":{"event_name":"Form Submission","event_category":"Newspack Announcement","event_label":"Inline: Newsletter (29097)"},"selector":"#c9a5 form:not(.c9a5)"},"ca4c":{"request":"event","on":"amp-form-submit-success","vars":{"event_name":"Permanent Dismissal","event_category":"Newspack Announcement","non_interaction":true,"event_label":"Inline: Newsletter (29097)"},"selector":".c9a51"},"n3de":{"request":"event","on":"amp-form-submit-success","vars":{"event_name":"newsletter signup","event_category":"NTG newsletter","event_label":"success"},"selector":"#n3d9 form","visibilitySpec":{"totalTimeMin":500}},"n3e2":{"request":"event","on":"visible","vars":{"event_name":"newsletter modal impression 2","event_category":"NTG newsletter","non_interaction":true,"event_label":"6 fun things to do this weekend in Collin County! (09\/30)"},"selector":"#n3d9","visibilitySpec":{"totalTimeMin":500}},"nd96":{"request":"event","on":"amp-form-submit-success","vars":{"event_name":"newsletter signup","event_category":"NTG newsletter","event_label":"success"},"selector":"#nd92 form","visibilitySpec":{"totalTimeMin":500}},"nd98":{"request":"event","on":"visible","vars":{"event_name":"newsletter modal impression 1","event_category":"NTG newsletter","non_interaction":true,"event_label":"6 fun things to do this weekend in Collin County! (09\/30)"},"selector":"#nd92","visibilitySpec":{"totalTimeMin":500}}}}					</script>
				</amp-analytics>
				<amp-pixel src="https://pixel.wp.com/g.gif?v=ext&amp;j=1%3A10.1&amp;blog=177389529&amp;post=48198&amp;tz=-5&amp;srv=localprofile.com&amp;host=localprofile.com&amp;rand=RANDOM&amp;ref=DOCUMENT_REFERRER" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"></amp-pixel>
	

</body></html>
<!--
	generated 84 seconds ago
	generated in 1.322 seconds
	served from batcache in 0.004 seconds
	expires in 216 seconds
-->
