<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#" amp="" i-amphtml-layout="" i-amphtml-no-boilerplate="" transformed="self;v=1">
<head><meta charset="UTF-8"><style amp-runtime="" i-amphtml-version="012107240354000">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</style><meta name="viewport" content="width=device-width,initial-scale=1"><meta name="p:domain_verify" content="515924c6254f019e959b78c32d9231b2"><meta name="yandex-verification" content="72c7b8b2ca382a85"><meta name="description" content="Texas’ ninth most populous city can be found nestled between the rolling grasslands and prairies and the booming megacity of Dallas, right on the northern"><meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large"><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="Things To Do In Plano, Texas This Weekend - Local Profile"><meta property="og:description" content="Texas’ ninth most populous city can be found nestled between the rolling grasslands and prairies and the booming megacity of Dallas, right on the northern"><meta property="og:url" content="https://localprofile.com/things-to-do-in-plano-texas-this-weekend/"><meta property="og:site_name" content="Local Profile"><meta property="article:publisher" content="https://www.facebook.com/LocalProfile"><meta property="og:updated_time" content="2021-08-10T15:27:53-05:00"><meta property="og:image" content="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg"><meta property="og:image:secure_url" content="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg"><meta property="og:image:width" content="1836"><meta property="og:image:height" content="1296"><meta property="og:image:alt" content="Things to do in Plano, Texas this weekend"><meta property="og:image:type" content="image/jpeg"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:title" content="Things To Do In Plano, Texas This Weekend - Local Profile"><meta name="twitter:description" content="Texas’ ninth most populous city can be found nestled between the rolling grasslands and prairies and the booming megacity of Dallas, right on the northern"><meta name="twitter:site" content="@localprofile_cc"><meta name="twitter:creator" content="@localprofile_cc"><meta name="twitter:image" content="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg"><meta name="generator" content="Site Kit by Google 1.38.0"><meta name="theme-color" content="#fff"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="mobile-web-app-capable" content="yes"><meta name="apple-touch-fullscreen" content="YES"><meta name="apple-mobile-web-app-title" content="Local Profile"><meta name="application-name" content="Local Profile"><meta name="generator" content="AMP Plugin v2.0.11; mode=standard"><meta name="msapplication-TileImage" content="https://i1.wp.com/localprofile.com/wp-content/uploads/2019/02/cropped-android-chrome-512x512.png?fit=270%2C270&amp;ssl=1"><title>Things To Do In Plano, Texas This Weekend - Local Profile</title><link rel="preconnect" href="https://cdn.ampproject.org"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin=""><link rel="dns-prefetch" href="//cdn.broadstreetads.com"><link rel="dns-prefetch" href="//stats.wp.com"><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="dns-prefetch" href="//s.w.org"><link rel="dns-prefetch" href="//i0.wp.com"><link rel="dns-prefetch" href="//i1.wp.com"><link rel="dns-prefetch" href="//i2.wp.com"><link rel="dns-prefetch" href="//c0.wp.com"><link rel="preload" as="script" href="https://cdn.ampproject.org/v0.js"><script type="text/javascript" src="https://cdn.ampproject.org/v0.js" id="amp-runtime-js" async></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-access-0.1.js" id="amp-access-js" async custom-element="amp-access"></script><script src="https://cdn.ampproject.org/v0/amp-ad-0.1.js" async="" custom-element="amp-ad"></script><script src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js" async="" custom-element="amp-analytics"></script><script src="https://cdn.ampproject.org/v0/amp-base-carousel-0.1.js" async="" custom-element="amp-base-carousel"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-bind-0.1.js" id="amp-bind-js" async custom-element="amp-bind"></script><script src="https://cdn.ampproject.org/v0/amp-form-0.1.js" async="" custom-element="amp-form"></script><script src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.js" async="" custom-element="amp-install-serviceworker"></script><script src="https://cdn.ampproject.org/v0/amp-mustache-0.2.js" async="" custom-template="amp-mustache"></script><script src="https://cdn.ampproject.org/v0/amp-selector-0.1.js" async="" custom-element="amp-selector"></script><script src="https://cdn.ampproject.org/v0/amp-sidebar-0.1.js" async="" custom-element="amp-sidebar"></script><link rel="icon" href="https://localprofile.com/wp-content/uploads/2019/02/cropped-android-chrome-512x512-100x100.png" sizes="32x32"><link rel="icon" href="https://i1.wp.com/localprofile.com/wp-content/uploads/2019/02/cropped-android-chrome-512x512.png?fit=192%2C192&amp;ssl=1" sizes="192x192"><link crossorigin="anonymous" rel="stylesheet" id="newspack-sacha-fonts-css" href="https://fonts.googleapis.com/css?family=IBM+Plex+Serif%3A400%2C400i%2C700%2C700i&amp;subset=latin%2Clatin-ext&amp;display=swap" type="text/css" media="all"><link crossorigin="anonymous" rel="stylesheet" id="newspack-font-import-css" href="https://fonts.googleapis.com/css2?family=Montserrat:ital,wght@0,400;0,700;1,300;1,700&amp;family=Playfair+Display:ital@0;1&amp;display=swap" type="text/css" media="all"><style amp-custom="">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</style><link rel="profile" href="https://gmpg.org/xfn/11"><!-- Jetpack Site Verification Tags --><!-- Search Engine Optimization by Rank Math PRO - https://s.rankmath.com/home --><link rel="canonical" href="https://localprofile.com/things-to-do-in-plano-texas-this-weekend/"><script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":"Place","@id":"https://localprofile.com/#place","geo":{"@type":"GeoCoordinates","latitude":"33.0178635","longitude":"-96.7552263"},"hasMap":"https://www.google.com/maps/search/?api=1&amp;query=33.0178635,-96.7552263","address":{"@type":"PostalAddress","streetAddress":"1413 Gables Ct","addressLocality":"Plano","addressRegion":"Texas","postalCode":"75075","addressCountry":"United States"}},{"@type":["NewsMediaOrganization","Organization"],"@id":"https://localprofile.com/#organization","name":"Local Profile","url":"https://localprofile.com","email":"connect@localprofile.com","address":{"@type":"PostalAddress","streetAddress":"1413 Gables Ct","addressLocality":"Plano","addressRegion":"Texas","postalCode":"75075","addressCountry":"United States"},"logo":{"@type":"ImageObject","@id":"https://localprofile.com/#logo","url":"https://localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png","caption":"Local Profile","inLanguage":"en-US","width":"606","height":"268"},"contactPoint":[{"@type":"ContactPoint","telephone":"+1-972-769-7272","contactType":"sales"}],"location":{"@id":"https://localprofile.com/#place"}},{"@type":"WebSite","@id":"https://localprofile.com/#website","url":"https://localprofile.com","name":"Local Profile","publisher":{"@id":"https://localprofile.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n-1024x723.jpg","url":"https://localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n-1024x723.jpg","width":"200","height":"200","inLanguage":"en-US"},{"@type":"BreadcrumbList","@id":"https://localprofile.com/things-to-do-in-plano-texas-this-weekend/#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://localprofile.com/things-to-do-in-plano-texas-this-weekend/","name":"Things to do in Plano, Texas this weekend"}}]},{"@type":"Person","@id":"https://localprofile.com/author/marketburst/","name":"Kevin Market","url":"https://localprofile.com/author/marketburst/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/c8539a84abe42123482aecee839cb29e?s=96&amp;d=mm&amp;r=g","url":"https://secure.gravatar.com/avatar/c8539a84abe42123482aecee839cb29e?s=96&amp;d=mm&amp;r=g","caption":"Kevin Market","inLanguage":"en-US"},"worksFor":{"@id":"https://localprofile.com/#organization"}},{"@type":"WebPage","@id":"https://localprofile.com/things-to-do-in-plano-texas-this-weekend/#webpage","url":"https://localprofile.com/things-to-do-in-plano-texas-this-weekend/","name":"Things To Do In Plano, Texas This Weekend - Local Profile","datePublished":"2021-08-10T15:25:18-05:00","dateModified":"2021-08-10T15:27:53-05:00","author":{"@id":"https://localprofile.com/author/marketburst/"},"isPartOf":{"@id":"https://localprofile.com/#website"},"primaryImageOfPage":{"@id":"https://localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n-1024x723.jpg"},"inLanguage":"en-US","breadcrumb":{"@id":"https://localprofile.com/things-to-do-in-plano-texas-this-weekend/#breadcrumb"}},{"@type":"NewsArticle","headline":"Things To Do In Plano, Texas This Weekend - Local Profile","datePublished":"2021-08-10T15:25:18-05:00","dateModified":"2021-08-10T15:27:53-05:00","author":{"@type":"Person","name":"Kevin Market"},"publisher":{"@id":"https://localprofile.com/#organization"},"description":"Texas\u2019 ninth most populous city can be found nestled between the rolling grasslands and prairies and the booming megacity of Dallas, right on the northern","copyrightYear":"2021","copyrightHolder":{"@id":"https://localprofile.com/#organization"},"name":"Things To Do In Plano, Texas This Weekend - Local Profile","@id":"https://localprofile.com/things-to-do-in-plano-texas-this-weekend/#richSnippet","isPartOf":{"@id":"https://localprofile.com/things-to-do-in-plano-texas-this-weekend/#webpage"},"image":{"@id":"https://localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n-1024x723.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://localprofile.com/things-to-do-in-plano-texas-this-weekend/#webpage"}}]}</script><!-- /Rank Math WordPress SEO plugin --><link rel="alternate" type="application/rss+xml" title="Local Profile » Feed" href="https://localprofile.com/feed/"><link rel="alternate" type="application/rss+xml" title="Local Profile » Comments Feed" href="https://localprofile.com/comments/feed/"><link rel="https://api.w.org/" href="https://localprofile.com/wp-json/"><link rel="alternate" type="application/json" href="https://localprofile.com/wp-json/wp/v2/pages/45327"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://localprofile.com/xmlrpc.php?rsd"><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://localprofile.com/wp-includes/wlwmanifest.xml"><link rel="shortlink" href="https://localprofile.com/?p=45327"><!-- Custom Logo: hide header text --><link rel="alternate" type="application/json+oembed" href="https://localprofile.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flocalprofile.com%2Fthings-to-do-in-plano-texas-this-weekend%2F"><link rel="alternate" type="text/xml+oembed" href="https://localprofile.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flocalprofile.com%2Fthings-to-do-in-plano-texas-this-weekend%2F&amp;format=xml"><!-- 
<script async data-cfasync="false" src="https://www.googletagmanager.com/gtag/js?id=UA-19203311-1" type="text/javascript"></script>
<script type="text/javascript" data-cfasync="false">
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments)};
  gtag('js', new Date());

  gtag('config', 'UA-19203311-1');
</script>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1012961/PPv2_001_Square_Home', [300, 250], 'div-gpt-ad-1505679060349-0').addService(googletag.pubads());
    googletag.defineSlot('/1012961/PPv2_001_Square_Home', [300, 250], 'div-gpt-ad-1513948600828-0').addService(googletag.pubads());
    googletag.defineSlot('/1012961/PPv2_001_Square_Home', [300, 250], 'div-gpt-ad-1513948600828-1').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
--><script id="amp-access" type="application/json">
			{"namespace":"popups","authorization":"https:\/\/localprofile.com\/wp-content\/plugins\/newspack-popups\/includes\/..\/api\/campaigns\/index.php?cid=CLIENT_ID(newspack-cid)&ref=DOCUMENT_REFERRER&popups=[{\"id\":\"id_29097\",\"f\":\"daily\",\"utm\":null,\"s\":\"\",\"n\":false,\"d\":false,\"t\":\"i\"}]&settings={\"suppress_newsletter_campaigns\":\"1\",\"suppress_all_newsletter_campaigns_if_one_dismissed\":\"1\",\"suppress_donation_campaigns_if_donor\":false,\"newspack_popups_non_interative_mode\":false,\"newspack_popups_donor_landing_page\":\"\",\"all_segments\":{\"5faef319b4aea\":{\"min_posts\":0,\"max_posts\":0,\"is_subscribed\":false,\"is_donor\":true,\"is_not_subscribed\":false,\"is_not_donor\":false,\"priority\":0}},\"newspack_popups_active_campaign_group\":false}&visit={\"post_id\":\"45327\",\"categories\":\"\",\"is_post\":false}","noPingback":true}		</script><link rel="manifest" href="https://localprofile.com/wp-json/wp/v2/web-app-manifest"><link rel="apple-touch-startup-image" href="https://i1.wp.com/localprofile.com/wp-content/uploads/2019/02/cropped-android-chrome-512x512.png?fit=192%2C192&amp;ssl=1"><!-- BEGIN Parse.ly 2.5.0 --><script type="application/ld+json">
{"@context":"http:\/\/schema.org","@type":"WebPage","headline":"Things to do in Plano, Texas this weekend","url":"http:\/\/localprofile.com\/things-to-do-in-plano-texas-this-weekend\/"}
</script><!-- END Parse.ly --><!--noscript--><!--/noscript--><link rel="apple-touch-icon" href="https://i1.wp.com/localprofile.com/wp-content/uploads/2019/02/cropped-android-chrome-512x512.png?fit=180%2C180&amp;ssl=1"></head>

<body class="page-template page-template-single-wide page-template-single-wide-php page page-id-45327 wp-custom-logo wp-embed-responsive theme-newspack-theme woocommerce-no-js singular hide-homepage-title hide-page-title hide-site-tagline h-nsub h-db h-ll h-sh has-sidebar">
<amp-ad type="broadstreetads" width="1440" height="360" data-network="6972" data-zone="89042" data-keywords="not_home_page,not_landing_page,is_article_page,things-to-do-in-plano-texas-this-weekend,page" layout="responsive" data-amp-original-style="max-width: 1440px; margin: 0 auto;" class="amp-wp-1941ee4 i-amphtml-layout-responsive i-amphtml-layout-size-defined" id="i-amp-0" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:25.0000%;"></i-amphtml-sizer></amp-ad>	<amp-sidebar id="mobile-sidebar" layout="nodisplay" side="right" class="mobile-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>

		
<form role="search" method="get" class="search-form" action="https://localprofile.com/" target="_top">
	<label for="search-form-1">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-1" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	<nav class="main-navigation nav1 dd-menu" aria-label="Top Menu" toolbar-target="site-navigation" toolbar="(min-width: 767px)">
		<ul id="menu-primary-menu-2" class="main-menu"><li id="menu-item-33070" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33070"><a href="https://localprofile.com/category/local-news/">NEWS</a></li>
<li id="menu-item-33069" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33069"><a href="https://localprofile.com/coronavirus/">COVID-19</a></li>
<li id="menu-item-33074" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33074"><a href="https://localprofile.com/category/business/">BUSINESS</a></li>
<li id="menu-item-33071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33071"><a href="https://localprofile.com/category/food/">FOOD</a></li>
<li id="menu-item-33075" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33075"><a href="https://localprofile.com/category/leisure/">LEISURE</a></li>
<li id="menu-item-33933" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33933"><a href="#" aria-haspopup="true" aria-expanded="false">MORE</a><button class="submenu-expand" tabindex="-1" role="presentation"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-33073" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33073"><a href="https://localprofile.com/category/arts/">ARTS + CULTURE</a></li>
	<li id="menu-item-33076" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33076"><a href="https://localprofile.com/category/longform/">LONGFORM</a></li>
	<li id="menu-item-33077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33077"><a href="https://localprofile.com/category/unfiltered/">UNFILTERED</a></li>
</ul>
</li>
</ul>	</nav>
	<nav class="secondary-menu nav2 dd-menu" aria-label="Secondary Menu" toolbar-target="secondary-nav-contain" toolbar="(min-width: 767px)">
		<ul id="menu-top-menu" class="secondary-menu"><li id="menu-item-34148" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34148"><a href="https://localprofile.com/magazine/">Magazine</a></li>
<li id="menu-item-33928" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33928"><a href="https://localprofile.com/newsletters/">Newsletter</a></li>
<li id="menu-item-33926" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33926"><a href="https://localprofile.com/advertise/">Advertise</a></li>
</ul>	</nav>
	<nav class="social-navigation" aria-label="Social Links Menu" toolbar="(min-width: 767px)" toolbar-target="social-nav-contain">
		<ul id="menu-social-menu" class="social-links-menu"><li id="menu-item-30800" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30800"><a href="https://www.facebook.com/LocalProfile"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path></svg></a></li>
<li id="menu-item-30801" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30801"><a href="https://twitter.com/localprofile_cc"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li id="menu-item-30802" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30802"><a href="https://www.instagram.com/localprofile_cc/"><span class="screen-reader-text">Instagram</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path></svg></a></li>
<li id="menu-item-30803" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30803"><a href="https://www.youtube.com/channel/UC_9B-HjCwFD2-VjWys6c59g"><span class="screen-reader-text">YouTube</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
<li id="menu-item-30804" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30804"><a href="https://www.linkedin.com/company/localprofile"><span class="screen-reader-text">LinkedIn</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M19.7,3H4.3C3.582,3,3,3.582,3,4.3v15.4C3,20.418,3.582,21,4.3,21h15.4c0.718,0,1.3-0.582,1.3-1.3V4.3 C21,3.582,20.418,3,19.7,3z M8.339,18.338H5.667v-8.59h2.672V18.338z M7.004,8.574c-0.857,0-1.549-0.694-1.549-1.548 c0-0.855,0.691-1.548,1.549-1.548c0.854,0,1.547,0.694,1.547,1.548C8.551,7.881,7.858,8.574,7.004,8.574z M18.339,18.338h-2.669 v-4.177c0-0.996-0.017-2.278-1.387-2.278c-1.389,0-1.601,1.086-1.601,2.206v4.249h-2.667v-8.59h2.559v1.174h0.037 c0.356-0.675,1.227-1.387,2.526-1.387c2.703,0,3.203,1.779,3.203,4.092V18.338z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->

	</amp-sidebar>
	<amp-sidebar id="desktop-sidebar" layout="nodisplay" side="left" class="desktop-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>
	</amp-sidebar>

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header hide-header-search" data-amp-bind-class="searchVisible ? 'show-header-search site-header ' : 'hide-header-search site-header'">

									<div class="top-header-contain desktop-only">
					<div class="wrapper">
						
						<div id="secondary-nav-contain">
													</div>

													<div id="social-nav-contain">
															</div>
						
											</div><!-- .wrapper -->
				</div><!-- .top-header-contain -->
			
			<div class="middle-header-contain">
				<div class="wrapper">
					
					
					
					<div class="site-branding">

	
		<a href="https://localprofile.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="606" height="268" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?fit=606%2C268&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Local Profile logo" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?w=606&amp;ssl=1 606w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?resize=300%2C133&amp;ssl=1 300w" sizes="(max-width: 606px) 100vw, 606px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzI2OCcgd2lkdGg9JzYwNicgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img width="606" height="268" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?fit=606%2C268&amp;ssl=1" class="custom-logo" alt="Local Profile logo" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?w=606&amp;ssl=1 606w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?resize=300%2C133&amp;ssl=1 300w" sizes="(max-width: 606px) 100vw, 606px"></noscript></amp-img></a>
	<div class="site-identity">
											<p class="site-title"><a href="https://localprofile.com/" rel="home">Local Profile</a></p>
					
						<p class="site-description">
					Connecting Collin County				</p>
			</div><!-- .site-identity -->

</div><!-- .site-branding -->

					
						<div class="nav-wrapper desktop-only">
							<div id="site-navigation">
															</div><!-- #site-navigation -->

													</div><!-- .nav-wrapper -->

					

					<div class="nav-wrapper desktop-only">
						<div id="tertiary-nav-contain">
													</div><!-- #tertiary-nav-contain -->

						
<div class="header-search-contain">
	<button id="search-toggle" on="tap:AMP.setState( { searchVisible: !searchVisible } ), search-form-2.focus" aria-controls="search-menu" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		<span class="screen-reader-text" data-amp-bind-text="searchVisible ? 'Close Search' : 'Open Search'">
			Open Search		</span>
		<span class="search-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
		<span class="close-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
	</button>
	<div id="header-search" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		
<form role="search" method="get" class="search-form" action="https://localprofile.com/" target="_top">
	<label for="search-form-2">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-2" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	</div><!-- #header-search -->
</div><!-- .header-search-contain -->
					</div><!-- .nav-wrapper -->

					
					
											<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
							<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z"></path></svg>							<span>Menu</span>
						</button>
					
				</div><!-- .wrapper -->
			</div><!-- .middle-header-contain -->


					
	</header><!-- #masthead -->

	
	
	<div id="content" class="site-content">

	<section id="primary" class="content-area ">
		<main id="main" class="site-main">

								<header class="entry-header">
						
			
					</header>
				
				<div class="main-content">

					
<article id="post-45327" class="post-45327 page type-page status-publish hentry entry">
	<div class="entry-content">
		
<h1 class="has-text-align-center">Things to do in Plano, Texas this weekend</h1>



<h4 class="has-text-align-center">Texas’ ninth most populous city can be found nestled between the rolling grasslands and prairies and the booming megacity of Dallas, right on the northern fringes of the</h4>



<div class="wp-block-columns">
<div class="wp-block-column amp-wp-86a7827" data-amp-original-style="flex-basis:66.66%"><div class="wp-block-newspack-blocks-carousel wp-block-newspack-blocks-carousel__autoplay-playing" id="wp-block-newspack-carousel__1" data-current-post-id="42741" data-slides-per-view="1" data-slide-count="3" data-aspect-ratio="0.75"><button aria-label="Pause Slideshow" class="amp-carousel-button-pause amp-carousel-button" on="tap:wp-block-newspack-carousel__amp-carousel__1.toggleAutoplay(toggleOn=false),wp-block-newspack-carousel__1.toggleClass(class=wp-block-newspack-blocks-carousel__autoplay-playing,force=false)"></button><button aria-label="Play Slideshow" class="amp-carousel-button-play amp-carousel-button" on="tap:wp-block-newspack-carousel__amp-carousel__1.toggleAutoplay(toggleOn=true),wp-block-newspack-carousel__1.toggleClass(class=wp-block-newspack-blocks-carousel__autoplay-playing,force=true)"></button><amp-base-carousel class="wp-block-newspack-carousel__amp-carousel i-amphtml-layout-responsive i-amphtml-layout-size-defined" width="1" height="0.75" layout="responsive" snap="true" data-next-button-aria-label="Next Slide" data-prev-button-aria-label="Previous Slide" auto-advance="true" auto-advance-interval="5000" id="wp-block-newspack-carousel__amp-carousel__1" on="slideChange:wp-block-newspack-carousel__amp-pagination__1.toggle(index=event.index, value=true)" advance-count="1" visible-count="(min-width: 600px) 1, 1" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:75.0000%;"></i-amphtml-sizer>
			<article data-post-id="43435" class="post-has-image amp-carousel-slide tag-4th-of-july tag-4th-of-july-fireworks tag-addison tag-addison-to-do tag-fireworks-north-texas tag-frisco tag-frisco-to-do tag-mckinney tag-mckinney-to-do tag-north-texas tag-plano tag-plano-to-do tag-the-colony tag-the-colony-to-do category-leisure type-post post">
				<figure class="post-thumbnail">
										<a href="https://localprofile.com/2021/06/25/best-fireworks-shows-north-texas/" rel="bookmark">
																		<amp-img width="1024" height="680" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?fit=1024%2C680&amp;ssl=1" class="image-fit-cover wp-post-image amp-wp-enforced-sizes i-amphtml-layout-fill i-amphtml-layout-size-defined" alt="it's 4th of july! that means there are plenty of fun things to do this weekend." object-fit="cover" layout="fill" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?w=2560&amp;ssl=1 2560w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=300%2C199&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=1024%2C680&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=768%2C510&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=1536%2C1020&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=2048%2C1360&amp;ssl=1 2048w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=1200%2C797&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=1568%2C1041&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=400%2C266&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=706%2C469&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?w=2400&amp;ssl=1 2400w" sizes="(max-width: 1024px) 100vw, 1024px" title="Best 4Th Of July Fireworks Shows In North Texas 1" disable-inline-width="" i-amphtml-layout="fill"><noscript><img width="1024" height="680" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?fit=1024%2C680&amp;ssl=1" class="image-fit-cover wp-post-image" alt="it's 4th of july! that means there are plenty of fun things to do this weekend." loading="lazy" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?w=2560&amp;ssl=1 2560w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=300%2C199&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=1024%2C680&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=768%2C510&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=1536%2C1020&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=2048%2C1360&amp;ssl=1 2048w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=1200%2C797&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=1568%2C1041&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=400%2C266&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?resize=706%2C469&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_345217805-scaled.jpg?w=2400&amp;ssl=1 2400w" sizes="(max-width: 1024px) 100vw, 1024px" title="Best 4Th Of July Fireworks Shows In North Texas 1"></noscript></amp-img>																</a>
									</figure>

									<div class="entry-wrapper">
						
						<h3 class="entry-title"><a href="https://localprofile.com/2021/06/25/best-fireworks-shows-north-texas/" rel="bookmark">Best 4th of July Fireworks Shows in North Texas</a></h3>
						<div class="entry-meta">
							<a href="https://localprofile.com/author/baileylewis/"><amp-img alt="avatar of bailey lewis" src="https://secure.gravatar.com/avatar/b056643b8cd568e6c082df0ab7ba973b?s=48&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/b056643b8cd568e6c082df0ab7ba973b?s=96&amp;d=mm&amp;r=g 2x" class="avatar avatar-48 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="48" width="48" title="Things To Do In Plano, Texas This Weekend 10" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzQ4JyB3aWR0aD0nNDgnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img loading="lazy" alt="avatar of bailey lewis" src="https://secure.gravatar.com/avatar/b056643b8cd568e6c082df0ab7ba973b?s=48&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/b056643b8cd568e6c082df0ab7ba973b?s=96&amp;d=mm&amp;r=g 2x" class="avatar avatar-48 photo" height="48" width="48" title="Things To Do In Plano, Texas This Weekend 10"></noscript></amp-img></a>									<span class="byline">
										by <span class="author vcard"><a class="url fn n" href="https://localprofile.com/author/baileylewis/">Bailey Lewis</a></span>									</span><!-- .author-name -->
									<time class="entry-date published" datetime="2021-06-25T17:03:27-05:00">June 25, 2021</time>						</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
							</article>
			
			<article data-post-id="43279" class="post-has-image amp-carousel-slide tag-allen-to-do tag-frisco-to-do tag-mckinney-to-do tag-plano-to-do tag-richardson-to-do tag-the-colony-to-do category-events category-leisure type-post post">
				<figure class="post-thumbnail">
										<a href="https://localprofile.com/2021/06/25/things-to-do-this-weekend-in-collin-county-6-25/" rel="bookmark">
																		<amp-img width="1024" height="683" src="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?fit=1024%2C683&amp;ssl=1" class="image-fit-cover wp-post-image amp-wp-enforced-sizes i-amphtml-layout-fill i-amphtml-layout-size-defined" alt="shutterstock 1151969561 scaled" object-fit="cover" layout="fill" srcset="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?w=2560&amp;ssl=1 2560w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=768%2C513&amp;ssl=1 768w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=1536%2C1025&amp;ssl=1 1536w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=2048%2C1367&amp;ssl=1 2048w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=1200%2C801&amp;ssl=1 1200w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=1568%2C1047&amp;ssl=1 1568w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=400%2C267&amp;ssl=1 400w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=706%2C471&amp;ssl=1 706w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?w=2400&amp;ssl=1 2400w" sizes="(max-width: 1024px) 100vw, 1024px" title="Things To Do This Weekend In Collin County (6/25) 2" disable-inline-width="" i-amphtml-layout="fill"><noscript><img width="1024" height="683" src="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?fit=1024%2C683&amp;ssl=1" class="image-fit-cover wp-post-image" alt="shutterstock 1151969561 scaled" loading="lazy" srcset="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?w=2560&amp;ssl=1 2560w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=768%2C513&amp;ssl=1 768w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=1536%2C1025&amp;ssl=1 1536w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=2048%2C1367&amp;ssl=1 2048w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=1200%2C801&amp;ssl=1 1200w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=1568%2C1047&amp;ssl=1 1568w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=400%2C267&amp;ssl=1 400w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?resize=706%2C471&amp;ssl=1 706w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_1151969561-scaled.jpg?w=2400&amp;ssl=1 2400w" sizes="(max-width: 1024px) 100vw, 1024px" title="Things To Do This Weekend In Collin County (6/25) 2"></noscript></amp-img>																</a>
									</figure>

									<div class="entry-wrapper">
						
						<h3 class="entry-title"><a href="https://localprofile.com/2021/06/25/things-to-do-this-weekend-in-collin-county-6-25/" rel="bookmark">Things to Do This Weekend in Collin County (6/25)</a></h3>
						<div class="entry-meta">
							<a href="https://localprofile.com/author/aanya/"><amp-img alt="avatar of aanya pramanik" src="https://secure.gravatar.com/avatar/a1079f79f40651a0ca2e6fe2b74daa8e?s=48&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/a1079f79f40651a0ca2e6fe2b74daa8e?s=96&amp;d=mm&amp;r=g 2x" class="avatar avatar-48 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="48" width="48" title="Things To Do In Plano, Texas This Weekend 11" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzQ4JyB3aWR0aD0nNDgnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img loading="lazy" alt="avatar of aanya pramanik" src="https://secure.gravatar.com/avatar/a1079f79f40651a0ca2e6fe2b74daa8e?s=48&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/a1079f79f40651a0ca2e6fe2b74daa8e?s=96&amp;d=mm&amp;r=g 2x" class="avatar avatar-48 photo" height="48" width="48" title="Things To Do In Plano, Texas This Weekend 11"></noscript></amp-img></a>									<span class="byline">
										by <span class="author vcard"><a class="url fn n" href="https://localprofile.com/author/aanya/">Aanya Pramanik</a></span>									</span><!-- .author-name -->
									<time class="entry-date published" datetime="2021-06-25T04:00:00-05:00">June 25, 2021</time>						</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
							</article>
			
			<article data-post-id="42741" class="post-has-image amp-carousel-slide tag-frisco-to-do tag-heroes tag-mckinney-to-do tag-plano-to-do tag-richardson-to-do category-leisure type-post post">
				<figure class="post-thumbnail">
										<a href="https://localprofile.com/2021/06/22/doggy-time-collin-county-dog-parks/" rel="bookmark">
																		<amp-img width="1024" height="683" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?fit=1024%2C683&amp;ssl=1" class="image-fit-cover wp-post-image amp-wp-enforced-sizes i-amphtml-layout-fill i-amphtml-layout-size-defined" alt="collin county dog parks" object-fit="cover" layout="fill" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?w=2560&amp;ssl=1 2560w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=2048%2C1365&amp;ssl=1 2048w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=1568%2C1045&amp;ssl=1 1568w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=400%2C267&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=706%2C471&amp;ssl=1 706w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?w=2400&amp;ssl=1 2400w" sizes="(max-width: 1024px) 100vw, 1024px" title="Looking For Quality Doggy Time? Check Out These Collin County Dog Parks 3" disable-inline-width="" i-amphtml-layout="fill"><noscript><img width="1024" height="683" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?fit=1024%2C683&amp;ssl=1" class="image-fit-cover wp-post-image" alt="collin county dog parks" loading="lazy" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?w=2560&amp;ssl=1 2560w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=2048%2C1365&amp;ssl=1 2048w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=1568%2C1045&amp;ssl=1 1568w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=400%2C267&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?resize=706%2C471&amp;ssl=1 706w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/06/shutterstock_241214137-scaled.jpg?w=2400&amp;ssl=1 2400w" sizes="(max-width: 1024px) 100vw, 1024px" title="Looking For Quality Doggy Time? Check Out These Collin County Dog Parks 3"></noscript></amp-img>																</a>
									</figure>

									<div class="entry-wrapper">
						
						<h3 class="entry-title"><a href="https://localprofile.com/2021/06/22/doggy-time-collin-county-dog-parks/" rel="bookmark">Looking for Quality Doggy Time? Check Out These Collin County Dog Parks</a></h3>
						<div class="entry-meta">
							<a href="https://localprofile.com/author/baileylewis/"><amp-img alt="avatar of bailey lewis" src="https://secure.gravatar.com/avatar/b056643b8cd568e6c082df0ab7ba973b?s=48&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/b056643b8cd568e6c082df0ab7ba973b?s=96&amp;d=mm&amp;r=g 2x" class="avatar avatar-48 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="48" width="48" title="Things To Do In Plano, Texas This Weekend 10" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzQ4JyB3aWR0aD0nNDgnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img loading="lazy" alt="avatar of bailey lewis" src="https://secure.gravatar.com/avatar/b056643b8cd568e6c082df0ab7ba973b?s=48&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/b056643b8cd568e6c082df0ab7ba973b?s=96&amp;d=mm&amp;r=g 2x" class="avatar avatar-48 photo" height="48" width="48" title="Things To Do In Plano, Texas This Weekend 10"></noscript></amp-img></a>									<span class="byline">
										by <span class="author vcard"><a class="url fn n" href="https://localprofile.com/author/baileylewis/">Bailey Lewis</a></span>									</span><!-- .author-name -->
									<time class="entry-date published" datetime="2021-06-22T04:15:00-05:00">June 22, 2021</time>						</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
							</article>
			</amp-base-carousel><amp-selector id="wp-block-newspack-carousel__amp-pagination__1" class="swiper-pagination-bullets amp-pagination i-amphtml-layout-container" on="select:wp-block-newspack-carousel__amp-carousel__1.goToSlide(index=event.targetOption)" layout="container" i-amphtml-layout="container"><button option="0" class="swiper-pagination-bullet" aria-label="Go to slide 1" selected></button><button option="1" class="swiper-pagination-bullet" aria-label="Go to slide 2"></button><button option="2" class="swiper-pagination-bullet" aria-label="Go to slide 3"></button></amp-selector></div></div>



<div class="wp-block-column amp-wp-4d8e209" data-amp-original-style="flex-basis:33.33%">				<div class="wp-block-newspack-blocks-homepage-articles is-style-borders wpnbha ts-3 is-style-borders" style="">
			<div data-posts data-current-post-id="45327">
								
	<article data-post-id="42827" class="tag-allen-to-do tag-dallas-to-do tag-fort-worth-to-do tag-grapevine-to-do tag-mckinney-to-do tag-plano-to-do category-events type-post post-has-image">
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://localprofile.com/2021/06/17/things-to-do-this-juneteenth-fathers-day-weekend-in-collin-county/" rel="bookmark">Things to Do this Juneteenth, Father’s Day Weekend in Collin County</a></h2>										<div class="entry-meta">
												<span class="byline">
								by <span class="author vcard"><a class="url fn n" href="https://localprofile.com/author/aanya/">Aanya Pramanik</a></span>							</span><!-- .author-name -->
							<time class="entry-date published" datetime="2021-06-17T04:15:00-05:00">June 17, 2021</time><time class="updated" datetime="2021-06-17T07:59:20-05:00">June 17, 2021</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

		
	<article data-post-id="42317" class="tag-plano tag-plano-aquatic-center tag-plano-pools tag-plano-to-do tag-tom-muehlenbeck-recreation-center category-leisure type-post post-has-image">
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://localprofile.com/2021/06/15/6-plano-pools-to-help-you-beat-the-summer-heat/" rel="bookmark">6 Plano Pools to Help You Beat the Summer Heat</a></h2>										<div class="entry-meta">
												<span class="byline">
								by <span class="author vcard"><a class="url fn n" href="https://localprofile.com/author/baileylewis/">Bailey Lewis</a></span>							</span><!-- .author-name -->
							<time class="entry-date published" datetime="2021-06-15T04:15:00-05:00">June 15, 2021</time><time class="updated" datetime="2021-06-16T12:16:23-05:00">June 16, 2021</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

		
	<article data-post-id="42717" class="tag-legacy-west-plano tag-plano tag-plano-news tag-plano-to-do tag-tiffany-and-co category-business type-post post-has-image">
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://localprofile.com/2021/06/14/tiffany-co-opens-friday-at-planos-legacy-west/" rel="bookmark">Tiffany &amp; Co. Opens Thursday at Plano’s Legacy West</a></h2>										<div class="entry-meta">
												<span class="byline">
								by <span class="author vcard"><a class="url fn n" href="https://localprofile.com/author/baileylewis/">Bailey Lewis</a></span>							</span><!-- .author-name -->
							<time class="entry-date published" datetime="2021-06-14T04:00:00-05:00">June 14, 2021</time><time class="updated" datetime="2021-06-15T15:15:39-05:00">June 15, 2021</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

		
	<article data-post-id="42661" class="tag-allen-to-do tag-collin-county-to-do tag-frisco-to-do tag-mckinney-to-do tag-plano-to-do category-events type-post post-has-image">
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://localprofile.com/2021/06/10/things-to-do-this-weekend-in-collin-county-6-12/" rel="bookmark">Things to Do This Weekend in Collin County (6/12)</a></h2>										<div class="entry-meta">
												<span class="byline">
								by <span class="author vcard"><a class="url fn n" href="https://localprofile.com/author/aanya/">Aanya Pramanik</a></span>							</span><!-- .author-name -->
							<time class="entry-date published" datetime="2021-06-10T04:15:00-05:00">June 10, 2021</time><time class="updated" datetime="2021-06-21T15:16:00-05:00">June 21, 2021</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

		
	<article data-post-id="42422" class="tag-addison-to-do tag-allen-to-do tag-frisco-to-do tag-mckinney-to-do tag-plano-to-do tag-things-to-do category-events type-post post-has-image">
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://localprofile.com/2021/06/04/things-to-do-this-weekend-in-collin-county-7/" rel="bookmark">Things to Do This Weekend in Collin County (6/4)</a></h2>										<div class="entry-meta">
												<span class="byline">
								by <span class="author vcard"><a class="url fn n" href="https://localprofile.com/author/aanya/">Aanya Pramanik</a></span>							</span><!-- .author-name -->
							<time class="entry-date published" datetime="2021-06-04T04:30:00-05:00">June 4, 2021</time><time class="updated" datetime="2021-06-07T09:38:34-05:00">June 7, 2021</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

					</div>
			
		</div>
				</div>
</div>


<p><!-- <center>[broadstreet zone="89059"]</center> --></p>



<hr class="wp-block-separator is-style-wide">



<h2 class="has-text-align-center">Best restaurants in Plano, Texas</h2>



<h4 class="has-text-align-center">Texas’ ninth most populous city can be found nestled between the rolling grasslands and prairies and the booming megacity of Dallas, right on the northern fringes of the</h4>


				<div class="wp-block-newspack-blocks-homepage-articles is-style-default wpnbha is-grid columns-3 show-image image-aligntop ts-2 is-3 is-landscape is-style-default" style="">
			<div data-posts data-current-post-id="45327">
								
	<article data-post-id="41596" class="tag-heroes tag-plano tag-plano-restaurant tag-salad-and-go category-food type-post post-has-image">
					<figure class="post-thumbnail">
								<a href="https://localprofile.com/2021/05/10/salad-and-go-brings-healthy-food-to-the-drive-thru/" rel="bookmark">
									<amp-img width="1200" height="900" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/05/Salad-and-Go-2-scaled.jpg?resize=1200%2C900&amp;ssl=1" class="attachment-newspack-article-block-landscape-large size-newspack-article-block-landscape-large wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="salad and go" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/05/Salad-and-Go-2-scaled.jpg?resize=1200%2C900&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/05/Salad-and-Go-2-scaled.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/05/Salad-and-Go-2-scaled.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/05/Salad-and-Go-2-scaled.jpg?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/05/Salad-and-Go-2-scaled.jpg?zoom=2&amp;resize=1200%2C900&amp;ssl=1 2400w" sizes="(max-width: 1200px) 100vw, 1200px" title="Salad And Go Brings Healthy Food To The Drive-Thru 4" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzkwMCcgd2lkdGg9JzEyMDAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img width="1200" height="900" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/05/Salad-and-Go-2-scaled.jpg?resize=1200%2C900&amp;ssl=1" class="attachment-newspack-article-block-landscape-large size-newspack-article-block-landscape-large wp-post-image" alt="salad and go" loading="lazy" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/05/Salad-and-Go-2-scaled.jpg?resize=1200%2C900&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/05/Salad-and-Go-2-scaled.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/05/Salad-and-Go-2-scaled.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/05/Salad-and-Go-2-scaled.jpg?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/05/Salad-and-Go-2-scaled.jpg?zoom=2&amp;resize=1200%2C900&amp;ssl=1 2400w" sizes="(max-width: 1200px) 100vw, 1200px" title="Salad And Go Brings Healthy Food To The Drive-Thru 4"></noscript></amp-img>								</a>
				
							</figure><!-- .featured-image -->
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://localprofile.com/2021/05/10/salad-and-go-brings-healthy-food-to-the-drive-thru/" rel="bookmark">Salad and Go Brings Healthy Food to The Drive-Thru</a></h2>										<div class="entry-meta">
					<time class="entry-date published" datetime="2021-05-10T04:00:00-05:00">May 10, 2021</time><time class="updated" datetime="2021-06-24T15:26:30-05:00">June 24, 2021</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

		
	<article data-post-id="41428" class="tag-darna-euro-mediterranean-market tag-legacy-west-plano tag-plano tag-plano-restaurant tag-plano-to-do category-food type-post post-has-image">
					<figure class="post-thumbnail">
								<a href="https://localprofile.com/2021/05/03/darna-euro-mediterranean-market-eatery-coming-to-legacy-west-in-october-2021/" rel="bookmark">
									<amp-img width="400" height="300" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/Darna-Rendering.jpeg?resize=400%2C300&amp;ssl=1" class="attachment-newspack-article-block-landscape-small size-newspack-article-block-landscape-small wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="darna mediterranean" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/Darna-Rendering.jpeg?resize=400%2C300&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/Darna-Rendering.jpeg?resize=200%2C150&amp;ssl=1 200w" sizes="(max-width: 400px) 100vw, 400px" title="Darna Euro-Mediterranean Market, Eatery Coming To Legacy West In October 2021 5" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzMwMCcgd2lkdGg9JzQwMCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img width="400" height="300" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/Darna-Rendering.jpeg?resize=400%2C300&amp;ssl=1" class="attachment-newspack-article-block-landscape-small size-newspack-article-block-landscape-small wp-post-image" alt="darna mediterranean" loading="lazy" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/Darna-Rendering.jpeg?resize=400%2C300&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/Darna-Rendering.jpeg?resize=200%2C150&amp;ssl=1 200w" sizes="(max-width: 400px) 100vw, 400px" title="Darna Euro-Mediterranean Market, Eatery Coming To Legacy West In October 2021 5"></noscript></amp-img>								</a>
				
							</figure><!-- .featured-image -->
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://localprofile.com/2021/05/03/darna-euro-mediterranean-market-eatery-coming-to-legacy-west-in-october-2021/" rel="bookmark">Darna Euro-Mediterranean Market, Eatery Coming to Legacy West in October 2021</a></h2>										<div class="entry-meta">
					<time class="entry-date published" datetime="2021-05-03T04:32:00-05:00">May 3, 2021</time><time class="updated" datetime="2021-04-30T14:29:25-05:00">April 30, 2021</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

		
	<article data-post-id="40781" class="tag-food tag-food-drink tag-heroes tag-plano tag-plano-food tag-plano-restaurants category-food type-post post-has-image">
					<figure class="post-thumbnail">
								<a href="https://localprofile.com/2021/04/12/the-best-cheap-eats-in-plano-7-great-meals-under-20/" rel="bookmark">
									<amp-img width="1200" height="900" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=1200%2C900&amp;ssl=1" class="attachment-newspack-article-block-landscape-large size-newspack-article-block-landscape-large wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="plano cheap eats" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=1200%2C900&amp;ssl=1 1200w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=800%2C600&amp;ssl=1 800w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=400%2C300&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=200%2C150&amp;ssl=1 200w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?zoom=2&amp;resize=1200%2C900&amp;ssl=1 2400w" sizes="(max-width: 1200px) 100vw, 1200px" title="The Best Cheap Eats In Plano: 7 Great Meals Under $20 6" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzkwMCcgd2lkdGg9JzEyMDAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img width="1200" height="900" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=1200%2C900&amp;ssl=1" class="attachment-newspack-article-block-landscape-large size-newspack-article-block-landscape-large wp-post-image" alt="plano cheap eats" loading="lazy" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=1200%2C900&amp;ssl=1 1200w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=800%2C600&amp;ssl=1 800w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=400%2C300&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=200%2C150&amp;ssl=1 200w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?zoom=2&amp;resize=1200%2C900&amp;ssl=1 2400w" sizes="(max-width: 1200px) 100vw, 1200px" title="The Best Cheap Eats In Plano: 7 Great Meals Under $20 6"></noscript></amp-img>								</a>
				
							</figure><!-- .featured-image -->
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://localprofile.com/2021/04/12/the-best-cheap-eats-in-plano-7-great-meals-under-20/" rel="bookmark">The Best Cheap Eats in Plano: 7 Great Meals Under $20</a></h2>										<div class="entry-meta">
					<time class="entry-date published" datetime="2021-04-12T04:30:00-05:00">April 12, 2021</time><time class="updated" datetime="2021-04-12T09:07:51-05:00">April 12, 2021</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

		
	<article data-post-id="40665" class="tag-best-patios tag-food-and-drink tag-plano tag-plano-food tag-plano-restuarants category-food type-post post-has-image">
					<figure class="post-thumbnail">
								<a href="https://localprofile.com/2021/04/02/5-best-patios-in-plano-to-enjoy-food-drink-and-good-weather/" rel="bookmark">
									<amp-img width="1200" height="900" src="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=1200%2C900&amp;ssl=1" class="attachment-newspack-article-block-landscape-large size-newspack-article-block-landscape-large wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="plano patio" srcset="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?w=1672&amp;ssl=1 1672w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=300%2C225&amp;ssl=1 300w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=1024%2C768&amp;ssl=1 1024w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=768%2C576&amp;ssl=1 768w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=1536%2C1152&amp;ssl=1 1536w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=1200%2C900&amp;ssl=1 1200w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=800%2C600&amp;ssl=1 800w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=400%2C300&amp;ssl=1 400w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=200%2C150&amp;ssl=1 200w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=1568%2C1176&amp;ssl=1 1568w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=706%2C530&amp;ssl=1 706w" sizes="(max-width: 1200px) 100vw, 1200px" title="7 Best Patios In Plano For Good Food, Drinks, And Weather 7" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzkwMCcgd2lkdGg9JzEyMDAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img width="1200" height="900" src="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=1200%2C900&amp;ssl=1" class="attachment-newspack-article-block-landscape-large size-newspack-article-block-landscape-large wp-post-image" alt="plano patio" loading="lazy" srcset="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?w=1672&amp;ssl=1 1672w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=300%2C225&amp;ssl=1 300w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=1024%2C768&amp;ssl=1 1024w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=768%2C576&amp;ssl=1 768w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=1536%2C1152&amp;ssl=1 1536w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=1200%2C900&amp;ssl=1 1200w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=800%2C600&amp;ssl=1 800w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=400%2C300&amp;ssl=1 400w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=200%2C150&amp;ssl=1 200w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=1568%2C1176&amp;ssl=1 1568w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/04/9E1FB85C-35D7-4705-A46A-0311544FA028.jpg?resize=706%2C530&amp;ssl=1 706w" sizes="(max-width: 1200px) 100vw, 1200px" title="7 Best Patios In Plano For Good Food, Drinks, And Weather 7"></noscript></amp-img>								</a>
				
							</figure><!-- .featured-image -->
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://localprofile.com/2021/04/02/5-best-patios-in-plano-to-enjoy-food-drink-and-good-weather/" rel="bookmark">7 Best Patios in Plano For Good Food, Drinks, and Weather</a></h2>										<div class="entry-meta">
					<time class="entry-date published" datetime="2021-04-02T04:45:00-05:00">April 2, 2021</time><time class="updated" datetime="2021-06-23T15:49:37-05:00">June 23, 2021</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

		
	<article data-post-id="39103" class="tag-food tag-food-drink tag-plano-food tag-plano-restaurants category-food type-post post-has-image">
					<figure class="post-thumbnail">
								<a href="https://localprofile.com/2021/02/24/the-unassuming-secrets-of-uncle-zhous-fried-dumplings-and-ncy-noodles-in-plano/" rel="bookmark">
									<amp-img width="1200" height="900" src="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/02/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=1200%2C900&amp;ssl=1" class="attachment-newspack-article-block-landscape-large size-newspack-article-block-landscape-large wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="uncle zhou dial oil noodles chinese food near me" srcset="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/02/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=1200%2C900&amp;ssl=1 1200w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/02/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=800%2C600&amp;ssl=1 800w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/02/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=400%2C300&amp;ssl=1 400w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/02/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=200%2C150&amp;ssl=1 200w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/02/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?zoom=2&amp;resize=1200%2C900&amp;ssl=1 2400w" sizes="(max-width: 1200px) 100vw, 1200px" title="The Unassuming Secrets Of Uncle Zhou'S Fried Dumplings And Nyc Noodles In Plano 8" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzkwMCcgd2lkdGg9JzEyMDAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img width="1200" height="900" src="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/02/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=1200%2C900&amp;ssl=1" class="attachment-newspack-article-block-landscape-large size-newspack-article-block-landscape-large wp-post-image" alt="uncle zhou dial oil noodles chinese food near me" loading="lazy" srcset="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/02/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=1200%2C900&amp;ssl=1 1200w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/02/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=800%2C600&amp;ssl=1 800w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/02/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=400%2C300&amp;ssl=1 400w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/02/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?resize=200%2C150&amp;ssl=1 200w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/02/2021_JAN_LOCALPROFILE_UNCLEZHOUS_SMARIE-5-scaled.jpg?zoom=2&amp;resize=1200%2C900&amp;ssl=1 2400w" sizes="(max-width: 1200px) 100vw, 1200px" title="The Unassuming Secrets Of Uncle Zhou'S Fried Dumplings And Nyc Noodles In Plano 8"></noscript></amp-img>								</a>
				
							</figure><!-- .featured-image -->
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://localprofile.com/2021/02/24/the-unassuming-secrets-of-uncle-zhous-fried-dumplings-and-ncy-noodles-in-plano/" rel="bookmark">The Unassuming Secrets of Uncle Zhou’s Fried Dumplings and NYC Noodles in Plano</a></h2>										<div class="entry-meta">
					<time class="entry-date published" datetime="2021-02-24T04:30:00-06:00">February 24, 2021</time><time class="updated" datetime="2021-06-05T12:42:06-05:00">June 5, 2021</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

		
	<article data-post-id="37506" class="tag-food-drink tag-plano-food tag-plano-news tag-plano-restuarants category-food type-post post-has-image">
					<figure class="post-thumbnail">
								<a href="https://localprofile.com/2020/12/14/hot-chicks-opens-in-plano-on-dec-14-heres-what-to-order/" rel="bookmark">
									<amp-img width="1200" height="900" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2020/12/Hot_Chicks_0019-E-scaled.jpg?resize=1200%2C900&amp;ssl=1" class="attachment-newspack-article-block-landscape-large size-newspack-article-block-landscape-large wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="hot chicks sandwich" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2020/12/Hot_Chicks_0019-E-scaled.jpg?resize=1200%2C900&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2020/12/Hot_Chicks_0019-E-scaled.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/localprofile.com/wp-content/uploads/2020/12/Hot_Chicks_0019-E-scaled.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2020/12/Hot_Chicks_0019-E-scaled.jpg?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2020/12/Hot_Chicks_0019-E-scaled.jpg?zoom=2&amp;resize=1200%2C900&amp;ssl=1 2400w" sizes="(max-width: 1200px) 100vw, 1200px" title="Hot Chicks Opens In Plano. Here’s What To Order. 9" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzkwMCcgd2lkdGg9JzEyMDAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img width="1200" height="900" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2020/12/Hot_Chicks_0019-E-scaled.jpg?resize=1200%2C900&amp;ssl=1" class="attachment-newspack-article-block-landscape-large size-newspack-article-block-landscape-large wp-post-image" alt="hot chicks sandwich" loading="lazy" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2020/12/Hot_Chicks_0019-E-scaled.jpg?resize=1200%2C900&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2020/12/Hot_Chicks_0019-E-scaled.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/localprofile.com/wp-content/uploads/2020/12/Hot_Chicks_0019-E-scaled.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2020/12/Hot_Chicks_0019-E-scaled.jpg?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2020/12/Hot_Chicks_0019-E-scaled.jpg?zoom=2&amp;resize=1200%2C900&amp;ssl=1 2400w" sizes="(max-width: 1200px) 100vw, 1200px" title="Hot Chicks Opens In Plano. Here’s What To Order. 9"></noscript></amp-img>								</a>
				
							</figure><!-- .featured-image -->
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://localprofile.com/2020/12/14/hot-chicks-opens-in-plano-on-dec-14-heres-what-to-order/" rel="bookmark">Hot Chicks Opens in Plano. Here’s What to Order.</a></h2>										<div class="entry-meta">
					<time class="entry-date published" datetime="2020-12-14T04:00:00-06:00">December 14, 2020</time><time class="updated" datetime="2021-06-05T09:22:12-05:00">June 5, 2021</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

					</div>
			
		</div>
				


<hr class="wp-block-separator is-style-wide">


<p><!-- <center>[broadstreet zone="89059"]</center> --></p>



<h2 class="has-text-align-center">20 Best things to do in Plano, Texas</h2>



<div class="wp-block-columns">
<div class="wp-block-column amp-wp-4d8e209" data-amp-original-style="flex-basis:33.33%">
<p class="has-light-gray-background-color has-background">Texas’ ninth most populous city can be found nestled between the rolling grasslands and prairies and the booming megacity of Dallas, right on the northern fringes of the Lone Star State.<br><br>Home to more than 250 000 people, the city is far from small, and continues to attract settlers who prefer something of a slower pace of life than is offered in D Town However, that doesn’t mean there’s nothing to do here Far from it! <br><br>Plano boasts everything from mouth watering Texan smokehouses and BBQ joints to fascinating heritage museums that reveal secrets of the railroad and agricultural stories of this section of the south <br><br>Add to that a clutch of beautiful parks, a multicultural medley of eateries that tout crusty Italian pizzas and craft beers alike, some great art house cinemas, walking trails and top quality shopping, and it’s easy to see how Plano, the little sister of Dallas, is worth the visit! Here are the best things to do in Plano</p>
</div>



<div class="wp-block-column amp-wp-86a7827" data-amp-original-style="flex-basis:66.66%">
<h4>1. Discover the history of Texan agriculture at the Heritage Farmstead Museum</h4>



<div class="wp-block-image"><figure class="aligncenter size-large"><amp-img width="1024" height="723" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=1024%2C723&amp;ssl=1" alt="158831071 10158947152329174 4974333669373417411 n" class="wp-image-45324 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=1024%2C723&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=300%2C212&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=768%2C542&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=1536%2C1084&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=1200%2C847&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=1568%2C1107&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=400%2C282&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=150%2C106&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=706%2C498&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?w=1836&amp;ssl=1 1836w" sizes="(max-width: 1024px) 100vw, 1024px" title="Things To Do In Plano, Texas This Weekend 13" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzcyMycgd2lkdGg9JzEwMjQnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img loading="lazy" width="1024" height="723" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=1024%2C723&amp;ssl=1" alt="158831071 10158947152329174 4974333669373417411 n" class="wp-image-45324" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=1024%2C723&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=300%2C212&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=768%2C542&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=1536%2C1084&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=1200%2C847&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=1568%2C1107&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=400%2C282&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=150%2C106&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?resize=706%2C498&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/158831071_10158947152329174_4974333669373417411_n.jpg?w=1836&amp;ssl=1 1836w" sizes="(max-width: 1024px) 100vw, 1024px" title="Things To Do In Plano, Texas This Weekend 13"></noscript></amp-img></figure></div>



<p>The Ammie Wilson House at the Heritage Farmstead Museum The ancestral home of the Farrell clan is now one of the most enthralling museums in all of Plano. </p>



<p>Billed as a living museum for its dedication to preserving every minutia of the day to day lives of its former early 20th century inhabitants, the site reveals the ins and outs of sheep and wheat farming on the backcountry prairies of Texas during the period from 1890 to 1930</p>



<h4>2. Enjoy bona fide Italian pizza pies at the Urban Crust</h4>



<div class="wp-block-image"><figure class="aligncenter size-large"><amp-img width="1024" height="731" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD-.jpg?resize=1024%2C731&amp;ssl=1" alt="shrimp watermelon arugula salad" class="wp-image-45274 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=1024%2C731&amp;ssl=1 1024w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=300%2C214&amp;ssl=1 300w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=768%2C549&amp;ssl=1 768w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=1536%2C1097&amp;ssl=1 1536w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=2048%2C1463&amp;ssl=1 2048w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=1200%2C857&amp;ssl=1 1200w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=1568%2C1120&amp;ssl=1 1568w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=400%2C286&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=150%2C107&amp;ssl=1 150w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=706%2C504&amp;ssl=1 706w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?w=2400&amp;ssl=1 2400w" sizes="(max-width: 1024px) 100vw, 1024px" title="Things To Do In Plano, Texas This Weekend 14" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzczMScgd2lkdGg9JzEwMjQnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img loading="lazy" width="1024" height="731" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD-.jpg?resize=1024%2C731&amp;ssl=1" alt="shrimp watermelon arugula salad" class="wp-image-45274" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=1024%2C731&amp;ssl=1 1024w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=300%2C214&amp;ssl=1 300w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=768%2C549&amp;ssl=1 768w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=1536%2C1097&amp;ssl=1 1536w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=2048%2C1463&amp;ssl=1 2048w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=1200%2C857&amp;ssl=1 1200w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=1568%2C1120&amp;ssl=1 1568w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=400%2C286&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=150%2C107&amp;ssl=1 150w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?resize=706%2C504&amp;ssl=1 706w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/07/SHRIMP-WATERMELON-ARUGULA-SALAD--scaled.jpg?w=2400&amp;ssl=1 2400w" sizes="(max-width: 1024px) 100vw, 1024px" title="Things To Do In Plano, Texas This Weekend 14"></noscript></amp-img></figure></div>



<p>Headed by pizza maestro and Sardinian born Chef Salvatore, it’s hardly surprising that this inner city Italian joint is home to some of the most authentic Mediterranean cooking in all of Plano. </p>



<p>The menu of mains ranges from mouth watering platters of real Tuscan cold cuts to truffle topped carpaccios , Caesar salads and the conspicuously Texan influenced Cowboy ribeye.</p>



<h4>3. Get the adrenaline pumping at the Go Ape Zip Line &amp; Treetop</h4>



<div class="wp-block-image"><figure class="aligncenter size-large"><amp-img width="1024" height="683" src="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443.jpg?resize=1024%2C683&amp;ssl=1" alt="shutterstock 733361443" class="wp-image-45255 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=2048%2C1365&amp;ssl=1 2048w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=1568%2C1045&amp;ssl=1 1568w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=400%2C267&amp;ssl=1 400w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=150%2C100&amp;ssl=1 150w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=706%2C471&amp;ssl=1 706w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?w=2400&amp;ssl=1 2400w" sizes="(max-width: 1024px) 100vw, 1024px" title="Things To Do In Plano, Texas This Weekend 15" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzY4Mycgd2lkdGg9JzEwMjQnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img loading="lazy" width="1024" height="683" src="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443.jpg?resize=1024%2C683&amp;ssl=1" alt="shutterstock 733361443" class="wp-image-45255" srcset="https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=2048%2C1365&amp;ssl=1 2048w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=1568%2C1045&amp;ssl=1 1568w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=400%2C267&amp;ssl=1 400w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=150%2C100&amp;ssl=1 150w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?resize=706%2C471&amp;ssl=1 706w, https://i1.wp.com/localprofile.com/wp-content/uploads/2021/07/shutterstock_733361443-scaled.jpg?w=2400&amp;ssl=1 2400w" sizes="(max-width: 1024px) 100vw, 1024px" title="Things To Do In Plano, Texas This Weekend 15"></noscript></amp-img></figure></div>



<p>Set high over the canopies of the Oak Point Park and Nature Preserve on the northern fringes of Plano city, this high energy action park makes the most of the North Texan wilderness. </p>



<p>Visitors can challenge themselves by scaling the series of swinging Tarzan vines, tenuous rope ladders, the soaring series of no less than five ziplines, and other adrenaline inducing attractions with equally adrenaline inducing names</p>
</div>
</div>
	</div><!-- .entry-content -->

	</article><!-- #post-45327 -->
				</div>

			
		</main><!-- #main -->
	</section><!-- #primary -->


	
	</div><!-- #content -->

	<footer id="colophon" class="site-footer">

					<div class="footer-branding">
		<div class="wrapper">
							<a class="footer-logo-link" href="https://localprofile.com/" rel="home">
					<amp-img width="400" height="176" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?fit=400%2C176&amp;ssl=1" class="footer-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?w=400&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?resize=300%2C132&amp;ssl=1 300w" sizes="(max-width: 400px) 100vw, 400px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzE3Nicgd2lkdGg9JzQwMCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img width="400" height="176" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?fit=400%2C176&amp;ssl=1" class="footer-logo" alt="" loading="lazy" srcset="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?w=400&amp;ssl=1 400w, https://i2.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?resize=300%2C132&amp;ssl=1 300w" sizes="(max-width: 400px) 100vw, 400px"></noscript></amp-img>				</a>
				<nav class="social-navigation" aria-label="Social Links Menu">
		<ul id="menu-social-menu-1" class="social-links-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30800"><a href="https://www.facebook.com/LocalProfile"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30801"><a href="https://twitter.com/localprofile_cc"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30802"><a href="https://www.instagram.com/localprofile_cc/"><span class="screen-reader-text">Instagram</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30803"><a href="https://www.youtube.com/channel/UC_9B-HjCwFD2-VjWys6c59g"><span class="screen-reader-text">YouTube</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30804"><a href="https://www.linkedin.com/company/localprofile"><span class="screen-reader-text">LinkedIn</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M19.7,3H4.3C3.582,3,3,3.582,3,4.3v15.4C3,20.418,3.582,21,4.3,21h15.4c0.718,0,1.3-0.582,1.3-1.3V4.3 C21,3.582,20.418,3,19.7,3z M8.339,18.338H5.667v-8.59h2.672V18.338z M7.004,8.574c-0.857,0-1.549-0.694-1.549-1.548 c0-0.855,0.691-1.548,1.549-1.548c0.854,0,1.547,0.694,1.547,1.548C8.551,7.881,7.858,8.574,7.004,8.574z M18.339,18.338h-2.669 v-4.177c0-0.996-0.017-2.278-1.387-2.278c-1.389,0-1.601,1.086-1.601,2.206v4.249h-2.667v-8.59h2.559v1.174h0.037 c0.356-0.675,1.227-1.387,2.526-1.387c2.703,0,3.203,1.779,3.203,4.092V18.338z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->
		</div><!-- .wrapper -->
	</div><!-- .footer-branding -->
		
	<aside class="widget-area footer-widgets" role="complementary" aria-label="Footer">
		<div class="wrapper">
			<section id="mc4wp_form_widget-3" class="widget widget_mc4wp_form_widget"><h2 class="widget-title">NEWSLETTER</h2><!-- Mailchimp for WordPress v4.8.6 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-28045" action-xhr="https://localprofile.com/wp-json/mc4wp/v1/form" method="post" data-id="28045" data-name="Newsletter Sign-Up" target="_top"><div class="mc4wp-form-fields"><p>
	<label>Have you subscribed to our free weekly newsletter? <br><br>It’s awesome.<br><br>
		<input type="email" name="EMAIL" placeholder="Your email here." required>
</label>
</p>

<p>
	<input type="submit" value="Sign up" data-amp-original-style="background-color:#ff5959;" class="amp-wp-be8153e">
</p>		<div submitting>
			<template type="amp-mustache">
				Submitting...			</template>
		</div>
		<div submit-success>
			<template type="amp-mustache">
				Thank you, your sign-up request was successful! Please check your email inbox to confirm.			</template>
		</div>
		<div submit-error>
			<template type="amp-mustache">
				{{message}}
			</template>
		</div>
		</div><label data-amp-original-style="display: none !important;" class="amp-wp-3e2e7c3">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off"></label><input type="hidden" name="_mc4wp_timestamp" value="1628627891"><input type="hidden" name="_mc4wp_form_id" value="28045"><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1"><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin --></section><section id="text-4" class="widget widget_text"><h2 class="widget-title">SECTIONS</h2>			<div class="textwidget"><p><a href="https://localprofile.com?footernav">Home</a><br>
<a href="https://localprofile.com/category/local-news?footernav">News</a><br>
<a href="https://localprofile.com/category/arts?footernav">Arts + Culture</a><br>
<a href="https://localprofile.com/category/business?footernav">Business</a><br>
<a href="https://localprofile.com/category/food?footernav">Food</a><br>
<a href="https://localprofile.com/category/health?footernav">Health</a><br>
<a href="https://localprofile.com/category/leisure?footernav">Leisure</a><br>
<a href="https://localprofile.com/category/longform?footernav">Longform</a><br>
<a href="https://localprofile.com/category/nonprofit?footernav">Nonprofit</a><br>
<a href="https://localprofile.com/category/unfiltered?footernav">Unfiltered</a></p>
</div>
		</section><section id="text-6" class="widget widget_text"><h2 class="widget-title">CONTACT US</h2>			<div class="textwidget"><p>1413 Gables Court<br>
Plano, Texas 75075<br>
(972) 769-7272<br>
<span class="email-address">connect@localprofile.com</span></p>
</div>
		</section><section id="text-5" class="widget widget_text"><h2 class="widget-title">BROWSE LATEST ISSUE</h2>			<div class="textwidget"><p><a title="Local Profile July/August Edition" href="https://www.qgdigitalpublishing.com/publication/?i=711743" target="_blank" rel="noopener"><amp-img class="alignnone wp-image-43933 size-medium amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/2021_July_August.jpg?resize=223%2C300&amp;ssl=1" alt="Local Profile Cover " width="223" height="300" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzMwMCcgd2lkdGg9JzIyMycgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img loading="lazy" class="alignnone wp-image-43933 size-medium" src="https://i2.wp.com/localprofile.com/wp-content/uploads/2021/04/2021_July_August.jpg?resize=223%2C300&amp;ssl=1" alt="Local Profile Cover " width="223" height="300"></noscript></amp-img></a></p>
<p> </p>
<p> </p>
</div>
		</section>		</div><!-- .wrapper -->
	</aside><!-- .widget-area -->


		<div class="site-info">

			
			<div class="wrapper site-info-contain">
													<span class="copyright">© 2021 Community Profile, LLC, 2021.</span>
				
				<a href="https://newspack.pub/" class="imprint">
					Proudly powered by Newspack by Automattic				</a>

							</div><!-- .wrapper -->
		</div><!-- .site-info -->
	</footer><!-- #colophon -->

</div><!-- #page -->



<!-- Twitter universal website tag code -->

<!-- End Twitter universal website tag code -->




	<amp-state id="newspackHomepagePosts" class="i-amphtml-layout-container" i-amphtml-layout="container">
		<script type="application/json">
			{
				"exclude_ids": [ 43435, 43279, 42741, 42827, 42317, 42717, 42661, 42422, 41596, 41428, 40781, 40665, 39103, 37506, 45327 ]
			}
		</script>
	</amp-state>
				<amp-analytics type="gtag" config='https://localprofile.com/wp-content/plugins/newspack-popups/includes/../api/segmentation/index.php?client_id=CLIENT_ID(newspack-cid)&amp;post_id=45327&amp;custom_dimensions=[{"role":"category","option":{"value":"category","label":"Category"},"gaID":"ga:dimension1"}]&amp;custom_dimensions_existing_values=[]' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"></amp-analytics>
		
<!-- font handler -->
    		<amp-install-serviceworker src="https://localprofile.com/wp.serviceworker" data-iframe-src="https://localprofile.com/?amp_install_service_worker_iframe=1" layout="nodisplay" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		</amp-install-serviceworker>
		<amp-analytics type="gtag" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"optoutElementId":"__gaOptOutExtension","vars":{"gtag_id":"UA-19203311-1","config":{"UA-19203311-1":{"groups":"default","linker":[],"send_page_view":false}}}}</script></amp-analytics>
<!-- Google Tag Manager added by Site Kit -->
<amp-analytics config="https://www.googletagmanager.com/amp.json?id=GTM-5VJ7RHF" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"optoutElementId":"__gaOptOutExtension"}</script></amp-analytics>
<!-- End Google Tag Manager -->
<amp-analytics id="parsely" type="parsely" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"vars":{"apikey":"localprofile.com"}}</script></amp-analytics>	
	





















			<amp-analytics class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed">
				<script type="application/json">
					{"linkers":{"enabled":true,"ref_newspack_cid":{"ids":{"cid":"CLIENT_ID(newspack-cid)"}}},"cookies":{"enabled":true,"newspack-cid":{"value":"LINKER_PARAM(ref_newspack_cid, cid)"}}}				</script>
			</amp-analytics>
						<amp-analytics type="gtag" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed">
					<script type="application/json">
						{"optoutElementId":"__gaOptOutExtension","vars":{"gtag_id":"UA-19203311-1","config":{"UA-19203311-1":{"groups":"default","linker":{"domains":["localprofile.com"]},"send_page_view":false}}},"triggers":{"neb8":{"request":"event","on":"click","vars":{"event_name":"social share","event_category":"NTG social","event_label":"facebook"},"selector":"amp-social-share[type=\"facebook\"]"},"nebb":{"request":"event","on":"click","vars":{"event_name":"social share","event_category":"NTG social","event_label":"twitter"},"selector":"amp-social-share[type=\"twitter\"]"},"nebc":{"request":"event","on":"click","vars":{"event_name":"social share","event_category":"NTG social","event_label":"whatsapp"},"selector":"amp-social-share[type=\"whatsapp\"]"},"nebd":{"request":"event","on":"click","vars":{"event_name":"social share","event_category":"NTG social","event_label":"linkedin"},"selector":"amp-social-share[type=\"linkedin\"]"},"ned4":{"request":"event","on":"scroll","vars":{"event_name":"25%","event_category":"NTG article milestone","non_interaction":true,"value":25,"event_label":"Things to do in Plano, Texas this weekend"},"event_value":25,"scrollSpec":{"verticalBoundaries":[25]}},"nf67":{"request":"event","on":"scroll","vars":{"event_name":"50%","event_category":"NTG article milestone","non_interaction":true,"value":50,"event_label":"Things to do in Plano, Texas this weekend"},"event_value":50,"scrollSpec":{"verticalBoundaries":[50]}},"nfa3":{"request":"event","on":"scroll","vars":{"event_name":"100%","event_category":"NTG article milestone","non_interaction":true,"value":100,"event_label":"Things to do in Plano, Texas this weekend"},"event_value":100,"scrollSpec":{"verticalBoundaries":[100]}}}}					</script>
				</amp-analytics>
				<amp-pixel src="https://pixel.wp.com/g.gif?v=ext&amp;j=1%3A10.0&amp;blog=177389529&amp;post=45327&amp;tz=-5&amp;srv=localprofile.com&amp;host=localprofile.com&amp;rand=RANDOM&amp;ref=DOCUMENT_REFERRER" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"></amp-pixel>
	

</body></html>
<!--
	generated in 1.424 seconds
	178800 bytes batcached for 300 seconds
-->
