<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#" amp="" transformed="self;v=1" i-amphtml-layout="" i-amphtml-no-boilerplate="" i-amphtml-binding>
<head><meta charset="UTF-8"><meta name="viewport" content="width=device-width"><link rel="preconnect" href="https://cdn.ampproject.org"><style amp-runtime="" i-amphtml-version="012203281422000">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</style><meta name="p:domain_verify" content="515924c6254f019e959b78c32d9231b2"><meta name="yandex-verification" content="72c7b8b2ca382a85"><meta name="description" content="Spring keeps on rolling this weekend in Dallas and Collin County. Here are the ten best things to do for the weekend of April 23 and 24, 2022."><meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large"><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="10 Best Things To Do This Weekend In Dallas &amp; Collin County"><meta property="og:description" content="Spring keeps on rolling this weekend in Dallas and Collin County. Here are the ten best things to do for the weekend of April 23 and 24, 2022."><meta property="og:url" content="https://localprofile.com/2022/04/20/10-best-things-weekend-dallas-collin/"><meta property="og:site_name" content="Local Profile"><meta property="article:publisher" content="https://www.facebook.com/LocalProfile"><meta property="article:section" content="Arts + Culture"><meta property="og:updated_time" content="2022-04-20T13:56:49-05:00"><meta property="og:image" content="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg"><meta property="og:image:secure_url" content="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg"><meta property="og:image:width" content="780"><meta property="og:image:height" content="507"><meta property="og:image:alt" content="Pictured is a teddy bear next to a basket and tea set."><meta property="og:image:type" content="image/jpeg"><meta property="article:published_time" content="2022-04-20T13:56:45-05:00"><meta property="article:modified_time" content="2022-04-20T13:56:49-05:00"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:title" content="10 Best Things To Do This Weekend In Dallas &amp; Collin County"><meta name="twitter:description" content="Spring keeps on rolling this weekend in Dallas and Collin County. Here are the ten best things to do for the weekend of April 23 and 24, 2022."><meta name="twitter:site" content="@localprofile_cc"><meta name="twitter:creator" content="@localprofile_cc"><meta name="twitter:image" content="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg"><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="Virginia Mingorance"><meta name="twitter:label2" content="Time to read"><meta name="twitter:data2" content="5 minutes"><meta property="ia:markup_url" content="https://localprofile.com/2022/04/20/10-best-things-weekend-dallas-collin/?ia_markup=1"><meta name="generator" content="Site Kit by Google 1.72.0"><meta name="theme-color" content="#fff"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="mobile-web-app-capable" content="yes"><meta name="apple-touch-fullscreen" content="YES"><meta name="apple-mobile-web-app-title" content="Local Profile"><meta name="application-name" content="Local Profile"><meta name="generator" content="AMP Plugin v2.2.4; mode=standard"><meta name="msapplication-TileImage" content="https://i0.wp.com/localprofile.com/wp-content/uploads/2019/02/cropped-android-chrome-512x512.png?fit=270%2C270&amp;ssl=1"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin=""><link rel="dns-prefetch" href="//cdn.broadstreetads.com"><link rel="dns-prefetch" href="//cdn.parsely.com"><link rel="dns-prefetch" href="//stats.wp.com"><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="dns-prefetch" href="//i0.wp.com"><link rel="dns-prefetch" href="//c0.wp.com"><link rel="preload" href="https://localprofile.com/wp-content/plugins/woocommerce/assets/fonts/star.woff" as="font" crossorigin=""><link rel="preload" href="https://localprofile.com/wp-content/plugins/woocommerce/assets/fonts/WooCommerce.woff" as="font" crossorigin=""><link rel="preload" href="https://localprofile.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.eot?5d3b4da4f6c2460dd842dbf9e0992ea6#iefix" as="font" crossorigin=""><link rel="preconnect" href="https://fonts.gstatic.com" crossorigin=""><link rel="dns-prefetch" href="https://fonts.gstatic.com"><script type="module" src="https://cdn.ampproject.org/v0.mjs" id="amp-runtime-js" async crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0.js" crossorigin="anonymous"></script><script type="module" src="https://cdn.ampproject.org/v0/amp-access-0.1.mjs" id="amp-access-js" async custom-element="amp-access" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-access-0.1.js" crossorigin="anonymous" custom-element="amp-access"></script><script src="https://cdn.ampproject.org/v0/amp-ad-0.1.mjs" async="" custom-element="amp-ad" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-ad-0.1.js" crossorigin="anonymous" custom-element="amp-ad"></script><script src="https://cdn.ampproject.org/v0/amp-analytics-0.1.mjs" async="" custom-element="amp-analytics" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js" crossorigin="anonymous" custom-element="amp-analytics"></script><script type="module" src="https://cdn.ampproject.org/v0/amp-animation-0.1.mjs" id="amp-animation-js" async custom-element="amp-animation" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-animation-0.1.js" crossorigin="anonymous" custom-element="amp-animation"></script><script type="module" src="https://cdn.ampproject.org/v0/amp-bind-0.1.mjs" id="amp-bind-js" async custom-element="amp-bind" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-bind-0.1.js" crossorigin="anonymous" custom-element="amp-bind"></script><script src="https://cdn.ampproject.org/v0/amp-form-0.1.mjs" async="" custom-element="amp-form" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-form-0.1.js" crossorigin="anonymous" custom-element="amp-form"></script><script src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.mjs" async="" custom-element="amp-install-serviceworker" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.js" crossorigin="anonymous" custom-element="amp-install-serviceworker"></script><script src="https://cdn.ampproject.org/v0/amp-lightbox-gallery-0.1.mjs" async="" custom-element="amp-lightbox-gallery" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-lightbox-gallery-0.1.js" crossorigin="anonymous" custom-element="amp-lightbox-gallery"></script><script src="https://cdn.ampproject.org/v0/amp-mustache-0.2.mjs" async="" custom-template="amp-mustache" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-mustache-0.2.js" crossorigin="anonymous" custom-template="amp-mustache"></script><script src="https://cdn.ampproject.org/v0/amp-sidebar-0.1.mjs" async="" custom-element="amp-sidebar" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-sidebar-0.1.js" crossorigin="anonymous" custom-element="amp-sidebar"></script><script src="https://cdn.ampproject.org/v0/amp-social-share-0.1.mjs" async="" custom-element="amp-social-share" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-social-share-0.1.js" crossorigin="anonymous" custom-element="amp-social-share"></script><link rel="icon" href="https://localprofile.com/wp-content/uploads/2019/02/cropped-android-chrome-512x512-100x100.png" sizes="32x32"><link rel="icon" href="https://i0.wp.com/localprofile.com/wp-content/uploads/2019/02/cropped-android-chrome-512x512.png?fit=192%2C192&amp;ssl=1" sizes="192x192"><link crossorigin="anonymous" rel="stylesheet" id="newspack-sacha-fonts-css" href="https://fonts.googleapis.com/css?family=IBM+Plex+Serif%3A400%2C400i%2C700%2C700i&amp;subset=latin%2Clatin-ext&amp;display=swap" type="text/css" media="all"><link crossorigin="anonymous" rel="stylesheet" id="newspack-font-import-css" href="https://fonts.googleapis.com/css2?family=Montserrat:ital,wght@0,400;0,700;1,300;1,700&amp;family=Playfair+Display:ital@0;1&amp;display=swap" type="text/css" media="all"><style amp-custom="">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</style><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="canonical" href="https://localprofile.com/2022/04/20/10-best-things-weekend-dallas-collin/"><script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":"Place","@id":"https://localprofile.com/#place","geo":{"@type":"GeoCoordinates","latitude":"33.0178635","longitude":"-96.7552263"},"hasMap":"https://www.google.com/maps/search/?api=1\u0026amp;query=33.0178635,-96.7552263","address":{"@type":"PostalAddress","streetAddress":"1413 Gables Ct","addressLocality":"Plano","addressRegion":"Texas","postalCode":"75075","addressCountry":"United States"}},{"@type":["NewsMediaOrganization","Organization"],"@id":"https://localprofile.com/#organization","name":"Local Profile","url":"https://localprofile.com","email":"connect@localprofile.com","address":{"@type":"PostalAddress","streetAddress":"1413 Gables Ct","addressLocality":"Plano","addressRegion":"Texas","postalCode":"75075","addressCountry":"United States"},"logo":{"@type":"ImageObject","@id":"https://localprofile.com/#logo","url":"https://localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png","caption":"Local Profile","inLanguage":"en-US","width":"606","height":"268"},"contactPoint":[{"@type":"ContactPoint","telephone":"+1-972-769-7272","contactType":"sales"}],"location":{"@id":"https://localprofile.com/#place"}},{"@type":"WebSite","@id":"https://localprofile.com/#website","url":"https://localprofile.com","name":"Local Profile","publisher":{"@id":"https://localprofile.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?fit=2560%2C1662\u0026amp;ssl=1","url":"https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?fit=2560%2C1662\u0026amp;ssl=1","width":"2560","height":"1662","caption":"Pictured is a teddy bear next to a basket and tea set.","inLanguage":"en-US"},{"@type":"BreadcrumbList","@id":"https://localprofile.com/2022/04/20/10-best-things-weekend-dallas-collin/#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://localprofile.com/2022/04/20/10-best-things-weekend-dallas-collin/","name":"The 10 Best Things To Do This Weekend In Dallas \u0026#038; Collin County"}}]},{"@type":"Person","@id":"https://localprofile.com/author/virginia/","name":"Virginia Mingorance","url":"https://localprofile.com/author/virginia/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/8963a96c24918269d3fb489a5f9fd049?s=96\u0026amp;d=mm\u0026amp;r=g","url":"https://secure.gravatar.com/avatar/8963a96c24918269d3fb489a5f9fd049?s=96\u0026amp;d=mm\u0026amp;r=g","caption":"Virginia Mingorance","inLanguage":"en-US"},"worksFor":{"@id":"https://localprofile.com/#organization"}},{"@type":"WebPage","@id":"https://localprofile.com/2022/04/20/10-best-things-weekend-dallas-collin/#webpage","url":"https://localprofile.com/2022/04/20/10-best-things-weekend-dallas-collin/","name":"10 Best Things To Do This Weekend In Dallas \u0026amp; Collin County","datePublished":"2022-04-20T13:56:45-05:00","dateModified":"2022-04-20T13:56:49-05:00","author":{"@id":"https://localprofile.com/author/virginia/"},"isPartOf":{"@id":"https://localprofile.com/#website"},"primaryImageOfPage":{"@id":"https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?fit=2560%2C1662\u0026amp;ssl=1"},"inLanguage":"en-US","breadcrumb":{"@id":"https://localprofile.com/2022/04/20/10-best-things-weekend-dallas-collin/#breadcrumb"},"mentions":[{"@type":"Thing","name":"Teddy Bear Picnic at Heritage Farmstead Museum","sameAs":"https://www.heritagefarmstead.org/event-list/apr-22-fun-on-the-farm-teddy-bear-picnic/"}]},{"@type":"NewsArticle","headline":"10 Best Things To Do This Weekend In Dallas \u0026amp; Collin County","keywords":"things to do,dallas,collin county,spring,beer,picnic,family","datePublished":"2022-04-20T13:56:45-05:00","dateModified":"2022-04-20T13:56:49-05:00","author":{"@id":"https://localprofile.com/author/virginia/"},"publisher":{"@id":"https://localprofile.com/#organization"},"description":"Spring keeps on rolling this weekend in Dallas and Collin County. Here are the ten best things to do for the weekend of April 23 and 24, 2022.","copyrightYear":"2022","copyrightHolder":{"@id":"https://localprofile.com/#organization"},"name":"10 Best Things To Do This Weekend In Dallas \u0026amp; Collin County","@id":"https://localprofile.com/2022/04/20/10-best-things-weekend-dallas-collin/#richSnippet","isPartOf":{"@id":"https://localprofile.com/2022/04/20/10-best-things-weekend-dallas-collin/#webpage"},"image":{"@id":"https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?fit=2560%2C1662\u0026amp;ssl=1"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://localprofile.com/2022/04/20/10-best-things-weekend-dallas-collin/#webpage"}}]}</script><link rel="alternate" type="application/rss+xml" title="Local Profile » Feed" href="https://localprofile.com/feed/"><link rel="alternate" type="application/rss+xml" title="Local Profile » Comments Feed" href="https://localprofile.com/comments/feed/"><link rel="alternate" type="application/rss+xml" title="Local Profile » Stories Feed" href="https://localprofile.com/web-stories/feed/"><link rel="https://api.w.org/" href="https://localprofile.com/wp-json/"><link rel="alternate" type="application/json" href="https://localprofile.com/wp-json/wp/v2/posts/53155"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://localprofile.com/xmlrpc.php?rsd"><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://localprofile.com/wp-includes/wlwmanifest.xml"><link rel="shortlink" href="https://localprofile.com/?p=53155"><link rel="alternate" type="application/json+oembed" href="https://localprofile.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flocalprofile.com%2F2022%2F04%2F20%2F10-best-things-weekend-dallas-collin%2F"><link rel="alternate" type="text/xml+oembed" href="https://localprofile.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flocalprofile.com%2F2022%2F04%2F20%2F10-best-things-weekend-dallas-collin%2F&amp;format=xml"><script id="amp-access" type="application/json">{"namespace":"popups","authorization":"https://localprofile.com/wp-content/plugins/newspack-popups/includes/../api/campaigns/index.php?cid=CLIENT_ID(newspack-cid)\u0026ref=DOCUMENT_REFERRER\u0026popups=[{\"id\":\"id_39633\",\"f\":\"daily\",\"utm\":null,\"s\":\"\",\"n\":false,\"d\":false,\"t\":\"o\"}]\u0026settings={\"active\":null,\"suppress_newsletter_campaigns\":true,\"suppress_all_newsletter_campaigns_if_one_dismissed\":false,\"suppress_donation_campaigns_if_donor\":false,\"newspack_popups_donor_landing_page\":\"\",\"newspack_popups_mc_donor_merge_field\":\"DONAT\",\"newspack_popups_non_interative_mode\":false,\"all_segments\":{\"5faef319b4aea\":{\"min_posts\":0,\"max_posts\":0,\"is_subscribed\":false,\"is_donor\":true,\"is_not_subscribed\":false,\"is_not_donor\":false,\"priority\":0}},\"newspack_popups_active_campaign_group\":false}\u0026visit={\"post_id\":\"53155\",\"categories\":\"95,1835,36218\",\"is_post\":true}","noPingback":true}</script><link rel="manifest" href="https://localprofile.com/wp-json/wp/v2/web-app-manifest"><link rel="apple-touch-startup-image" href="https://i0.wp.com/localprofile.com/wp-content/uploads/2019/02/cropped-android-chrome-512x512.png?fit=192%2C192&amp;ssl=1"><script type="application/ld+json">{"@context":"http://schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http://localprofile.com/2022/04/20/10-best-things-weekend-dallas-collin/"},"headline":"The 10 Best Things To Do This Weekend In Dallas \u0026#038; Collin County","url":"http://localprofile.com/2022/04/20/10-best-things-weekend-dallas-collin/","thumbnailUrl":"https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=150%2C150\u0026ssl=1","image":{"@type":"ImageObject","url":"https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=150%2C150\u0026ssl=1"},"dateCreated":"2022-04-20T18:56:45Z","datePublished":"2022-04-20T18:56:45Z","dateModified":"2022-04-20T18:56:49Z","articleSection":"Arts + Culture","author":[{"@type":"Person","name":"Virginia Mingorance"}],"creator":["Virginia Mingorance"],"publisher":{"@type":"Organization","name":"Local Profile","logo":"https://localprofile.com/wp-content/uploads/2020/06/lp-logo-color.png"},"keywords":[]}</script><link rel="apple-touch-icon" href="https://i0.wp.com/localprofile.com/wp-content/uploads/2019/02/cropped-android-chrome-512x512.png?fit=180%2C180&amp;ssl=1"><title>10 Best Things To Do This Weekend In Dallas &amp; Collin County</title></head>

<body class="post-template-default single single-post postid-53155 single-format-standard wp-custom-logo wp-embed-responsive theme-newspack-theme woocommerce-no-js singular hide-homepage-title hide-site-tagline h-nsub h-db h-ll h-sh has-sidebar cat-arts-and-culture cat-things-to-do cat-things-to-do-this-weekend-things-to-do has-featured-image single-featured-image-beside has-large-featured-image" data-amp-auto-lightbox-disable>
<svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-dark-grayscale"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0 0.49803921568627"></fefuncr><fefuncg type="table" tablevalues="0 0.49803921568627"></fefuncg><fefuncb type="table" tablevalues="0 0.49803921568627"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-grayscale"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0 1"></fefuncr><fefuncg type="table" tablevalues="0 1"></fefuncg><fefuncb type="table" tablevalues="0 1"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-purple-yellow"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0.54901960784314 0.98823529411765"></fefuncr><fefuncg type="table" tablevalues="0 1"></fefuncg><fefuncb type="table" tablevalues="0.71764705882353 0.25490196078431"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-blue-red"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0 1"></fefuncr><fefuncg type="table" tablevalues="0 0.27843137254902"></fefuncg><fefuncb type="table" tablevalues="0.5921568627451 0.27843137254902"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-midnight"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0 0"></fefuncr><fefuncg type="table" tablevalues="0 0.64705882352941"></fefuncg><fefuncb type="table" tablevalues="0 1"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-magenta-yellow"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0.78039215686275 1"></fefuncr><fefuncg type="table" tablevalues="0 0.94901960784314"></fefuncg><fefuncb type="table" tablevalues="0.35294117647059 0.47058823529412"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-purple-green"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0.65098039215686 0.40392156862745"></fefuncr><fefuncg type="table" tablevalues="0 1"></fefuncg><fefuncb type="table" tablevalues="0.44705882352941 0.4"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-blue-orange"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0.098039215686275 1"></fefuncr><fefuncg type="table" tablevalues="0 0.66274509803922"></fefuncg><fefuncb type="table" tablevalues="0.84705882352941 0.41960784313725"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><amp-ad type="broadstreetads" data-network="6972" data-zone="89042" data-keywords="not_home_page,not_landing_page,is_article_page,arts-and-culture,things-to-do,things-to-do-this-weekend-things-to-do,things-to-do,10-best-things-weekend-dallas-collin,post" layout="responsive" data-initurl="https://cdn.broadstreetads.com/init-2.min.js?v=1.43.8" width="1440" height="360" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer slot="i-amphtml-svc" style="display:block;padding-top:25%"></i-amphtml-sizer></amp-ad>		<amp-layout amp-access="popups.id_39633" amp-access-hide class="newspack-lightbox newspack-popup newspack-lightbox-placement-center newspack-lightbox-size-medium    i-amphtml-layout-container" role="button" tabindex="0" id="c7e1" i-amphtml-layout="container">
			<div class="newspack-popup-wrapper  amp-wp-85c1a93" data-popup-status="publish" data-amp-original-style="background-color:#FFFFFF;color:#000">
				<div class="newspack-popup">
										


<div class="wp-container-2 wp-block-group newspack-pattern subscribe__style-1"><div class="wp-block-group__inner-container">
<div class="wp-block-media-text has-media-on-the-right is-stacked-on-mobile is-vertically-aligned-center is-image-fill has-white-color has-text-color has-background amp-wp-16e6232" data-amp-original-style="background-color:#33bad7"><figure class="wp-block-media-text__media amp-wp-29e37e9" data-amp-original-style="background-image:url(https://localprofile.com/wp-content/uploads/2021/03/WeekendEditionPopUp_V1-640x1024.jpg);background-position:50% 50%"><amp-img src="https://localprofile.com/wp-content/uploads/2021/03/WeekendEditionPopUp_V1-640x1024.jpg" alt="" class="wp-image-50889 size-full amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" width="640" height="1024" layout="intrinsic" data-hero-candidate="" data-hero i-amphtml-ssr i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjEwMjQiIHdpZHRoPSI2NDAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><img class="i-amphtml-fill-content i-amphtml-replaced-content" decoding="async" alt="" src="https://localprofile.com/wp-content/uploads/2021/03/WeekendEditionPopUp_V1-640x1024.jpg"></amp-img></figure><div class="wp-block-media-text__content">
<h2 id="h-need-a-break">STAY UP-TO-DATE</h2>



<h2 id="h-win-one-of-seven-amazing-trips">Subscribe to our email updates.</h2>


<amp-layout id="nc85" class="i-amphtml-layout-container" i-amphtml-layout="container">
	<div class="wp-block-jetpack-mailchimp" data-blog-id="177389529">
		<form aria-describedby="wp-block-jetpack-mailchimp_consent-text" action-xhr="https://public-api.wordpress.com/rest/v1.1/sites/177389529/email_follow/amp/subscribe/" method="post" id="mailchimp_form" target="_top" on="submit-success:AMP.setState( { mailing_list_status: 'subscribed', mailing_list_email: event.response.email } )">
			<p>
				<input aria-label="Enter your email" placeholder="Enter your email" required title="Enter your email" type="email" name="email">
			</p>
									
<div class="wp-block-jetpack-button wp-block-button"><button class="wp-block-button__link" data-id-attr="mailchimp-button-block-1" id="mailchimp-button-block-1" type="submit">Subscribe Now!</button></div>
			<p id="wp-block-jetpack-mailchimp_consent-text">
				Subscribe to recieve <em>Local Profile</em> email updates every Monday and Thursday.  			</p>

			
				<div submit-success>
					<template type="amp-mustache">
						<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_success wp-block-jetpack-mailchimp__is-amp">
							Success! You're on the list.						</div>
					</template>
				</div>
				<div submit-error>
					<template type="amp-mustache">
						<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_error wp-block-jetpack-mailchimp__is-amp">
							Whoops! There was an error and we couldn't process your subscription. Please reload the page and try again.						</div>
					</template>
				</div>
				<div submitting>
					<template type="amp-mustache">
						<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_processing wp-block-jetpack-mailchimp__is-amp" role="status">
							Processing…						</div>
					</template>
				</div>

			
		</form>
			</div>
	</amp-layout>


<div class="wp-block-columns">
<div class="wp-block-column amp-wp-c414e53" data-amp-original-style="flex-basis:100%"></div>
</div>
</div></div>
</div></div>



<p></p>
								<form class="popup-not-interested-form c7e11 popup-action-form c7e1 align-center" method="POST" action-xhr="https://localprofile.com/wp-content/plugins/newspack-popups/includes/../api/campaigns/index.php" target="_top">
							<input name="popup_id" type="hidden" value="id_39633">
		<input name="cid" type="hidden" value="CLIENT_ID(newspack-cid)" data-amp-replace="CLIENT_ID">
		<input name="mailing_list_status" type="hidden" data-amp-bind-value="mailing_list_status" i-amphtml-binding>
		<input name="is_newsletter_popup" type="hidden" value="">
						<input name="suppress_forever" type="hidden" value="1">
				<button on="tap:c7e1.hide" aria-label="" data-amp-original-style="background-color:#FFFFFF;color:#000" class="amp-wp-85c1a93">I'm not interested</button>
			</form>
							<form class="popup-dismiss-form c7e10 popup-action-form c7e1 align-center" method="POST" action-xhr="https://localprofile.com/wp-content/plugins/newspack-popups/includes/../api/campaigns/index.php" target="_top">
								<input name="popup_id" type="hidden" value="id_39633">
		<input name="cid" type="hidden" value="CLIENT_ID(newspack-cid)" data-amp-replace="CLIENT_ID">
		<input name="mailing_list_status" type="hidden" data-amp-bind-value="mailing_list_status" i-amphtml-binding>
		<input name="is_newsletter_popup" type="hidden" value="">
								<button on="tap:c7e1.hide" class="newspack-lightbox__close amp-wp-85c1a93" aria-label="Close Pop-up" data-amp-original-style="background-color:#FFFFFF;color:#000">
							<svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewbox="0 0 24 24" role="img" aria-hidden="true" focusable="false"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12 19 6.41z" /></svg>
						</button>
					</form>
				</div>
			</div>
			<form class="popup-dismiss-form c7e10 popup-action-form c7e1" method="POST" action-xhr="https://localprofile.com/wp-content/plugins/newspack-popups/includes/../api/campaigns/index.php" target="_top">
						<input name="popup_id" type="hidden" value="id_39633">
		<input name="cid" type="hidden" value="CLIENT_ID(newspack-cid)" data-amp-replace="CLIENT_ID">
		<input name="mailing_list_status" type="hidden" data-amp-bind-value="mailing_list_status" i-amphtml-binding>
		<input name="is_newsletter_popup" type="hidden" value="">
						<button class="newspack-lightbox-shim amp-wp-cb2a876" on="tap:c7e1.hide" data-amp-original-style="opacity: 0.3;background-color:#000000;"></button>
			</form>
		</amp-layout>
				<amp-animation id="a_c7e1" layout="nodisplay" trigger="visibility" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
			<script type="application/json">{"duration":"125ms","fill":"both","iterations":"1","direction":"alternate","animations":[{"selector":"#c7e1","delay":"10500","keyframes":{"opacity":["0","1"],"visibility":["hidden","visible"]}},{"selector":"#c7e1","delay":"10000","keyframes":{"transform":["translateY(100vh)","translateY(0vh)"]}},{"selector":"#c7e1 .newspack-popup-wrapper","delay":"10625","keyframes":{"opacity":["0","1"]}}]}</script>
		</amp-animation>
				<amp-analytics class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed">
			<script type="application/json">{"requests":{"event":"https://localprofile.com/wp-content/plugins/newspack-popups/includes/../api/campaigns/index.php"},"triggers":{"trackPageview":{"on":"visible","request":"event","visibilitySpec":{"selector":"#c7e1","visiblePercentageMin":90,"totalTimeMin":500,"continuousTimeMin":200},"extraUrlParams":{"popup_id":"id_39633","cid":"CLIENT_ID(newspack-cid)"}},"formSubmitSuccess":{"on":"amp-form-submit-success","request":"event","selector":"#c7e1 .wp-block-jetpack-mailchimp form","extraUrlParams":{"popup_id":"id_39633","cid":"CLIENT_ID(newspack-cid)","mailing_list_status":"subscribed","email":"${formFields[email]}"}}}}</script>
		</amp-analytics>
					<amp-sidebar id="mobile-sidebar" layout="nodisplay" side="right" class="mobile-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z" /><path d="M0 0h24v24H0z" fill="none" /></svg>			Close		</button>

		
<form role="search" method="get" class="search-form" action="https://localprofile.com/" target="_top">
	<label for="search-form-3">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-3" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z" /><path d="M0 0h24v24H0z" fill="none" /></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	<nav class="main-navigation nav1 dd-menu" aria-label="Top Menu" toolbar-target="site-navigation" toolbar="(min-width: 767px)">
		<ul id="menu-primary-menu-2" class="main-menu"><li id="menu-item-47077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47077"><a href="https://localprofile.com/category/latest/">Latest</a></li>
<li id="menu-item-53149" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-53149"><a href="https://www.localprofile.com/news">News</a></li>
<li id="menu-item-47070" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47070"><a href="https://localprofile.com/category/food-and-drink/">Food + Drink</a></li>
<li id="menu-item-47071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47071"><a href="https://localprofile.com/category/business/">Business</a></li>
<li id="menu-item-47072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47072"><a href="https://localprofile.com/category/community/">Community</a></li>
<li id="menu-item-33933" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33933"><a href="#" aria-haspopup="true" aria-expanded="false">MORE</a><button class="submenu-expand" tabindex="-1" role="presentation"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z" /><path fill="none" d="M0 0h24v24H0V0z" /></svg></button>
<ul class="sub-menu">
	<li id="menu-item-47075" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-47075"><a href="https://localprofile.com/category/arts-and-culture/">Arts + Culture</a></li>
	<li id="menu-item-47089" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47089"><a href="https://localprofile.com/category/health/">Health</a></li>
	<li id="menu-item-47078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47078"><a href="https://localprofile.com/category/lifestyle/">Lifestyle</a></li>
	<li id="menu-item-47079" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-47079"><a href="https://localprofile.com/category/things-to-do/">Things To Do</a></li>
	<li id="menu-item-47080" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47080"><a href="https://localprofile.com/category/top-listings/">Top Listings</a></li>
	<li id="menu-item-47521" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47521"><a href="https://localprofile.com/category/business/women-in-business/">Women In Business</a></li>
</ul>
</li>
</ul>	</nav>
	<nav class="secondary-menu nav2 dd-menu" aria-label="Secondary Menu" toolbar-target="secondary-nav-contain" toolbar="(min-width: 767px)">
		<ul id="menu-top-menu" class="secondary-menu"><li id="menu-item-47557" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47557"><a href="https://localprofile.com/2019/02/26/local-plano-profile-becomes-local-profile-collin-county/">About</a></li>
<li id="menu-item-34148" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34148"><a href="https://localprofile.com/magazine/">Magazine</a></li>
<li id="menu-item-33928" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33928"><a href="https://localprofile.com/newsletters/">Sign up for our Email Newsletter</a></li>
<li id="menu-item-33926" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33926"><a href="https://localprofile.com/advertise/">Advertise</a></li>
</ul>	</nav>
	<nav class="social-navigation" aria-label="Social Links Menu" toolbar="(min-width: 767px)" toolbar-target="social-nav-contain">
		<ul id="menu-social-menu" class="social-links-menu"><li id="menu-item-30800" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30800"><a href="https://www.facebook.com/LocalProfile"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z" /></svg></a></li>
<li id="menu-item-30802" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30802"><a href="https://www.instagram.com/localprofile_cc/"><span class="screen-reader-text">Instagram</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z" /></svg></a></li>
<li id="menu-item-47230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47230"><a href="https://twitter.com/localprofile_cc?lang=en"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z" /></svg></a></li>
<li id="menu-item-30804" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30804"><a href="https://www.linkedin.com/company/localprofile"><span class="screen-reader-text">LinkedIn</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M19.7,3H4.3C3.582,3,3,3.582,3,4.3v15.4C3,20.418,3.582,21,4.3,21h15.4c0.718,0,1.3-0.582,1.3-1.3V4.3 C21,3.582,20.418,3,19.7,3z M8.339,18.338H5.667v-8.59h2.672V18.338z M7.004,8.574c-0.857,0-1.549-0.694-1.549-1.548 c0-0.855,0.691-1.548,1.549-1.548c0.854,0,1.547,0.694,1.547,1.548C8.551,7.881,7.858,8.574,7.004,8.574z M18.339,18.338h-2.669 v-4.177c0-0.996-0.017-2.278-1.387-2.278c-1.389,0-1.601,1.086-1.601,2.206v4.249h-2.667v-8.59h2.559v1.174h0.037 c0.356-0.675,1.227-1.387,2.526-1.387c2.703,0,3.203,1.779,3.203,4.092V18.338z" /></svg></a></li>
<li id="menu-item-47231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47231"><a href="https://www.youtube.com/channel/UC_9B-HjCwFD2-VjWys6c59g"><span class="screen-reader-text">Youtube</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z" /></svg></a></li>
</ul>	</nav>

	</amp-sidebar>
	<amp-sidebar id="desktop-sidebar" layout="nodisplay" side="left" class="desktop-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z" /><path d="M0 0h24v24H0z" fill="none" /></svg>			Close		</button>
	</amp-sidebar>

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	
	<header id="masthead" class="site-header hide-header-search" data-amp-bind-class="searchVisible ? 'show-header-search site-header ' : 'hide-header-search site-header'" i-amphtml-binding>

									<div class="top-header-contain desktop-only">
					<div class="wrapper">
						
						<div id="secondary-nav-contain">
													</div>

													<div id="social-nav-contain">
															</div>
						
											</div>
				</div>
			
			<div class="middle-header-contain">
				<div class="wrapper">
					
					
					
					<div class="site-branding">

	
		<a href="https://localprofile.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="606" height="268" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?fit=606%2C268&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Local Profile logo" data-hero-candidate="" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?w=606&amp;ssl=1 606w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?resize=300%2C133&amp;ssl=1 300w" sizes="(max-width: 606px) 100vw, 606px" layout="intrinsic" disable-inline-width="" data-hero i-amphtml-ssr i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjI2OCIgd2lkdGg9IjYwNiIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><img class="i-amphtml-fill-content i-amphtml-replaced-content" decoding="async" alt="Local Profile logo" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?fit=606%2C268&amp;ssl=1" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?w=606&amp;ssl=1 606w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/local-profile-logo-2021.png?resize=300%2C133&amp;ssl=1 300w" sizes="(max-width: 606px) 100vw, 606px"></amp-img></a>
	<div class="site-identity">
											<p class="site-title"><a href="https://localprofile.com/" rel="home">Local Profile</a></p>
					
						<p class="site-description">
					Connecting Collin County				</p>
			</div>

</div>

					
						<div class="nav-wrapper desktop-only">
							<div id="site-navigation">
															</div>

													</div>

					

					<div class="nav-wrapper desktop-only">
						<div id="tertiary-nav-contain">
													</div>

						
<div class="header-search-contain">
	<button id="search-toggle" on="tap:AMP.setState( { searchVisible: !searchVisible } ), search-form-2.focus" aria-controls="search-menu" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false" i-amphtml-binding>
		<span class="screen-reader-text" data-amp-bind-text="searchVisible ? 'Close Search' : 'Open Search'" i-amphtml-binding>
			Open Search		</span>
		<span class="search-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z" /><path d="M0 0h24v24H0z" fill="none" /></svg></span>
		<span class="close-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z" /><path d="M0 0h24v24H0z" fill="none" /></svg></span>
	</button>
	<div id="header-search" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false" i-amphtml-binding>
		
<form role="search" method="get" class="search-form" action="https://localprofile.com/" target="_top">
	<label for="search-form-4">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-4" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z" /><path d="M0 0h24v24H0z" fill="none" /></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	</div>
</div>
					</div>

					
					
											<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
							<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none" /><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z" /></svg>							<span>Menu</span>
						</button>
					
				</div>
			</div>


					
			</header>

	
	<section class="newspack-broadstreet-header amp-wp-543be6b" data-amp-original-style="text-align:center; padding: 25px;"><amp-ad type="broadstreetads" data-network="6972" data-zone="89044" data-keywords="not_home_page,not_landing_page,is_article_page,arts-and-culture,things-to-do,things-to-do-this-weekend-things-to-do,things-to-do,10-best-things-weekend-dallas-collin,post" layout="responsive" data-initurl="https://cdn.broadstreetads.com/init-2.min.js?v=1.43.8" width="1055" height="150" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer slot="i-amphtml-svc" style="display:block;padding-top:14.218%"></i-amphtml-sizer></amp-ad></section>
	
	<div id="content" class="site-content">

	<section id="primary" class="content-area category-arts-and-culture category-things-to-do category-things-to-do-this-weekend-things-to-do">
		<main id="main" class="site-main">

			
	<div class="featured-image-beside">
		<div class="wrapper">
			<header class="entry-header">
				
	<span class="cat-links"><span class="screen-reader-text">Posted in</span><a href="https://localprofile.com/category/arts-and-culture/" rel="category tag">Arts + Culture</a><span class="sep">, </span><a href="https://localprofile.com/category/things-to-do/" rel="category tag">Things To Do</a><span class="sep">, </span><a href="https://localprofile.com/category/things-to-do/things-to-do-this-weekend-things-to-do/" rel="category tag">Things to do this weekend</a></span>			<h1 class="entry-title ">
			The 10 Best Things To Do This Weekend In Dallas &amp; Collin County		</h1>
		
	<div class="entry-subhead">
									<div class="entry-meta">
					<span class="author-avatar"><amp-img alt="avatar of virginia mingorance" src="https://secure.gravatar.com/avatar/8963a96c24918269d3fb489a5f9fd049?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/8963a96c24918269d3fb489a5f9fd049?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="80" width="80" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjgwIiB3aWR0aD0iODAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img alt="avatar of virginia mingorance" src="https://secure.gravatar.com/avatar/8963a96c24918269d3fb489a5f9fd049?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/8963a96c24918269d3fb489a5f9fd049?s=160&amp;d=mm&amp;r=g 2x" height="80" width="80"></noscript></amp-img></span>
			<span class="byline">
				<span>by</span>
				<span class="author vcard"><a class="url fn n" href="https://localprofile.com/author/virginia/">Virginia Mingorance</a></span> 			</span>
		<span class="posted-on"><time class="entry-date published" datetime="2022-04-20T13:56:45-05:00">April 20, 2022</time><time class="updated" datetime="2022-04-20T13:56:49-05:00">April 20, 2022</time></span>				</div>
							<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><amp-social-share type="facebook" height="32px" width="32px" aria-label="Click to share on Facebook" title="Click to share on Facebook" data-param-app_id="249643311490" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="twitter" height="32px" width="32px" aria-label="Click to share on Twitter" title="Click to share on Twitter" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="linkedin" height="32px" width="32px" aria-label="Click to share on LinkedIn" title="Click to share on LinkedIn" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="pocket" height="32px" width="32px" aria-label="Click to share on Pocket" title="Click to share on Pocket" data-share-endpoint="https://getpocket.com/save/?url=https%3A%2F%2Flocalprofile.com%2F2022%2F04%2F20%2F10-best-things-weekend-dallas-collin%2F&amp;title=The%2010%20Best%20Things%20To%20Do%20This%20Weekend%20In%20Dallas%20%26%20Collin%20County" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="whatsapp" height="32px" width="32px" aria-label="Click to share on WhatsApp" title="Click to share on WhatsApp" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px" i-amphtml-layout="fixed"></amp-social-share><button class="amp-social-share print" on="tap:AMP.print">Print</button></div></div></div>	</div>
			</header>
		</div>

		
			<figure class="post-thumbnail">

				<amp-img width="1200" height="779" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?fit=1200%2C779&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="pictured is a teddy bear next to a basket and tea set." data-hero-candidate="" object-fit="cover" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?w=2560&amp;ssl=1 2560w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=300%2C195&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=1024%2C665&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=768%2C498&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=1536%2C997&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=2048%2C1329&amp;ssl=1 2048w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=1200%2C779&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=1568%2C1018&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=400%2C260&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=706%2C458&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=150%2C97&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 1200px) 100vw, 1200px" title="The 10 Best Things To Do This Weekend In Dallas &amp;Amp; Collin County 1" layout="intrinsic" disable-inline-width="" data-hero i-amphtml-ssr i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Ijc3OSIgd2lkdGg9IjEyMDAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><img class="i-amphtml-fill-content i-amphtml-replaced-content" decoding="async" alt="pictured is a teddy bear next to a basket and tea set." src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?fit=1200%2C779&amp;ssl=1" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?w=2560&amp;ssl=1 2560w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=300%2C195&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=1024%2C665&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=768%2C498&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=1536%2C997&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=2048%2C1329&amp;ssl=1 2048w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=1200%2C779&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=1568%2C1018&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=400%2C260&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=706%2C458&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?resize=150%2C97&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1130022698-scaled.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 1200px) 100vw, 1200px" title="The 10 Best Things To Do This Weekend In Dallas &amp;Amp; Collin County 1" style="object-fit:cover"></amp-img>
			</figure>

		
					<figcaption><span>Teddy bears make excellent picnic partners. Photo: Coatesy | Shutterstock </span></figcaption>
				</div>


				<div class="main-content">

					

<article id="post-53155" class="post-53155 post type-post status-publish format-standard has-post-thumbnail hentry category-arts-and-culture category-things-to-do category-things-to-do-this-weekend-things-to-do entry">
	<div class="entry-content">

		
		
<p> Looks like spring will keep the fun rollin’ this weekend in Collin County! From an awesome three-day festival at <a href="http://muensterchamber.com/" target="_blank" rel="noopener">Germanfest in Muenster</a> to the ultimate brunch party at <a href="https://www.kailegacywest.com/kai-chella" target="_blank" rel="noopener">KĀI-CHELLA</a> to the cutest possible picnic at <a href="https://www.heritagefarmstead.org/event-list/apr-22-fun-on-the-farm-teddy-bear-picnic/" target="_blank" rel="noopener">Heritage Farmstead Museum</a>, you’ll have to choose carefully which amazing activities will take over your weekend! </p>



<p>If you’re looking for the best things to do this weekend in Dallas, Collin County and beyond, look no further. Here’s the only list you need.</p>



<figure class="wp-block-image size-large"><amp-img width="780" height="520" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=780%2C520&amp;ssl=1" alt="a hand holds up a drink in front of a sign. " data-amp-lightbox="true" lightbox="true" class="wp-image-53198 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=1568%2C1045&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=400%2C267&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=706%2C471&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=150%2C100&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?w=2048&amp;ssl=1 2048w" sizes="(max-width: 780px) 100vw, 780px" title="The 10 Best Things To Do This Weekend In Dallas &amp;Amp; Collin County 5" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjUyMCIgd2lkdGg9Ijc4MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="520" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=780%2C520&amp;ssl=1" alt="a hand holds up a drink in front of a sign. " srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=1568%2C1045&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=400%2C267&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=706%2C471&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?resize=150%2C100&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/kaichella.jpg?w=2048&amp;ssl=1 2048w" sizes="(max-width: 780px) 100vw, 780px" title="The 10 Best Things To Do This Weekend In Dallas &amp;Amp; Collin County 5"></noscript></amp-img><figcaption>Image: KAI | Facebook</figcaption></figure>



<h2><a href="https://www.kailegacywest.com/kai-chella" target="_blank" rel="noopener">KĀI-CHELLA</a> <a href="https://www.kailegacywest.com/kai-chella" target="_blank" rel="noopener">at Legacy West</a></h2>



<p><strong>When: </strong><em>April 24, 2022</em><br><strong>Where:</strong> <em>Legacy West | 7301 Windrose Ave C200</em>, <em>Plano</em><br><em><a href="https://www.kailegacywest.com/kai-chella" target="_blank" rel="noopener">More info</a></em></p>



<p>Dayclub is back presenting the ultimate brunch party! Starting at noon you’ll be able to enjoy specialty cocktails, two DJ sets, live music and more! It’s the perfect way to end your Sunday.</p>



<h2><a href="https://www.eventbrite.com/e/captain-camille-at-legacy-hall-tickets-230360603767" target="_blank" rel="noopener">Captain and Camille at Legacy Hall</a></h2>



<p><em><strong>When</strong>:  April 23, 2022<br></em><strong><em>Where</em></strong>: <em>Legacy Hall Box Garden | 7800 Windrose Avenue, Plano</em><br><em><a href="https://www.eventbrite.com/e/captain-camille-at-legacy-hall-tickets-230360603767" target="_blank" rel="noreferrer noopener">Tickets here</a></em></p>



<p>All aboard Legacy Hall this weekend for the best ’70s yacht rock tunes! Enjoy an outdoor evening with your friends and come early for dinner and drinks from over 20 eateries and bars before the band takes the stage, playing the best hits from James Taylor, Fleetwood Mac, Cat Stevens, ABBA and Supertramp. Or reserve your balcony VIP lounge seat and enjoy dedicated cocktail service, relaxing seats and the best view of the stage.</p>



<figure class="wp-block-image size-large"><a href="http://muensterchamber.com/about/#" target="_blank" rel="noopener"><amp-img width="780" height="520" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840.jpg?resize=780%2C520&amp;ssl=1" alt="a woman holds a pretzel while a man holds a mug of beer. " class="wp-image-53212 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=2048%2C1365&amp;ssl=1 2048w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=1568%2C1045&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=400%2C267&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=706%2C471&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=150%2C100&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 780px) 100vw, 780px" title="The 10 Best Things To Do This Weekend In Dallas &amp;Amp; Collin County 6" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjUyMCIgd2lkdGg9Ijc4MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="520" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840.jpg?resize=780%2C520&amp;ssl=1" alt="a woman holds a pretzel while a man holds a mug of beer. " srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=2048%2C1365&amp;ssl=1 2048w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=1568%2C1045&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=400%2C267&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=706%2C471&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?resize=150%2C100&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/shutterstock_1494107840-scaled.jpg?w=2340&amp;ssl=1 2340w" sizes="(max-width: 780px) 100vw, 780px" title="The 10 Best Things To Do This Weekend In Dallas &amp;Amp; Collin County 6"></noscript></amp-img></a><figcaption>Photo: KarepaStock | Shutterstock</figcaption></figure>



<h2><a href="http://muensterchamber.com/about/" target="_blank" rel="noopener">Annual Germanfest in Muenster</a></h2>



<p><em><strong>When</strong>: April 22 to 23, 2022<br></em><strong><em>Where</em></strong>: <em>Heritage Park | 301 N Ash Street, Muenster</em><br><em><a href="http://muensterchamber.com/about/#" data-type="URL" data-id="http://muensterchamber.com/about/#" target="_blank" rel="noopener">More Info</a></em></p>



<p>The last full weekend of April is upon us folks, and y’all know what that means: It’s time for some German fun at the Annual Germanfest at Heritage Park in Muenster! Prepare yourselves for all the mouthwatering German sausage, scrumptious apple strudel, hearty cheeses and homemade bread, cakes and pies. There’ll also be room for some healthy cooking competition that includes rib and sausage cook-offs. But this event has more than culinary joy, fitness enthusiasts can exercise off those delicious eats in the 5k and 15k Germanfest Fun Run and Metric Century bike rally. Families can enjoy the magicians, mimes, clowns, storytellers, or the Karneval and Kinder Theatre. Hours of entertainment with a German flare! </p>



<h2>Rhymin’ n’ Stealin’, Beastie Boys Tribute at Legacy Hall</h2>



<p><em><strong>When</strong>:  April 22, 2022<br></em><strong><em>Where</em></strong>: <em>Legacy Hall Box Garden | 7800 Windrose Avenue</em>, <em>Plano</em><br><em><a href="https://www.eventbrite.com/e/beastie-boys-tribute-rhymin-n-stealin-at-legacy-hall-tickets-290943518897" target="_blank" rel="noreferrer noopener">Tickets</a></em></p>



<p>Back by popular demand, Rhymin’ N’ Stealin’ is bringing ’80s hip-hop and rap-rock to the Legacy Hall stage! What’s better than enjoying a fun show outdoors with some friends, good drinks and a fantastic view of the stage from the balcony VIP lounge at Legacy Hall Box Garden?</p>



<figure class="wp-block-image size-large"><a href="https://www.visitplano.com/event/anti-reckless-2022-auto-show/2022-04-23/" target="_blank" rel="noopener"><amp-img width="780" height="623" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?resize=780%2C623&amp;ssl=1" alt="pictured is a classic car at the auto show. " class="wp-image-53199 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?resize=1024%2C818&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?resize=300%2C240&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?resize=768%2C613&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?resize=1200%2C958&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?resize=400%2C319&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?resize=706%2C564&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?resize=150%2C120&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?w=1440&amp;ssl=1 1440w" sizes="(max-width: 780px) 100vw, 780px" title="The 10 Best Things To Do This Weekend In Dallas &amp;Amp; Collin County 7" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjYyMyIgd2lkdGg9Ijc4MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="623" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?resize=780%2C623&amp;ssl=1" alt="pictured is a classic car at the auto show. " srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?resize=1024%2C818&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?resize=300%2C240&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?resize=768%2C613&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?resize=1200%2C958&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?resize=400%2C319&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?resize=706%2C564&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?resize=150%2C120&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/rekless1.jpg?w=1440&amp;ssl=1 1440w" sizes="(max-width: 780px) 100vw, 780px" title="The 10 Best Things To Do This Weekend In Dallas &amp;Amp; Collin County 7"></noscript></amp-img></a><figcaption>Image: Anti Reckless | Facebook</figcaption></figure>



<h2><a href="https://www.visitplano.com/event/anti-reckless-2022-auto-show/2022-04-23/" target="_blank" rel="noopener">Anti Reckless Auto Show</a></h2>



<p><em><strong>When</strong>:  April 23, 2022<br></em><strong><em>Where</em></strong>: <em>The Shops at Willow Bend| 6360 Chapel Hill Blvd, Plano</em><br><em><a href="https://www.visitplano.com/event/anti-reckless-2022-auto-show/2022-04-23/" target="_blank" rel="noreferrer noopener">More Info</a></em></p>



<p>This weekend, show off your ride at the Anti Reckless Auto Show or be amazed by all the beautiful machines on display. After soaking up the automotive eye candy, grab a bite at one of Willow Bend’s many dining spots.</p>



<h2><a href="https://www.granitepark.com/event/live-music-rockstars-of-tomorrow/" target="_blank" rel="noopener">Rockstars of Tomorrow Concerts at Granite Park</a></h2>



<p><em><strong>When</strong>:  April 17, 2022<br></em><strong><em>Where</em></strong>: <em>The Boardwalk at Granite Park| 5800 State Highway 121, Plano</em><br><em><a href="https://www.granitepark.com/event/live-music-rockstars-of-tomorrow/" target="_blank" rel="noopener">More info</a></em></p>



<p>Rockstars of Tomorrow, a local Frisco music academy, will be kicking off this concert with the Band Core, an initiative in which teenagers perform for live audiences and learn the ropes of the music business. So don’t forget to rock out and cheer extra hard! Halfway through the concert, the adults of the Rockstar Pros will take the stage to provide the soundtrack for your evening stroll through the Boardwalk.</p>



<figure class="wp-block-image size-large"><a href="https://www.heritagefarmstead.org/event-list/apr-22-fun-on-the-farm-teddy-bear-picnic/" target="_blank" rel="noopener"><amp-img width="780" height="584" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=780%2C584&amp;ssl=1" alt="teddy bears enjoy a picnic together. " class="wp-image-53208 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=1024%2C767&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=300%2C225&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=768%2C575&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=706%2C529&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=150%2C112&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=600%2C450&amp;ssl=1 600w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?w=1200&amp;ssl=1 1200w" sizes="(max-width: 780px) 100vw, 780px" title="The 10 Best Things To Do This Weekend In Dallas &amp;Amp; Collin County 8" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjU4NCIgd2lkdGg9Ijc4MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="584" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=780%2C584&amp;ssl=1" alt="teddy bears enjoy a picnic together. " srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=1024%2C767&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=300%2C225&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=768%2C575&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=706%2C529&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=150%2C112&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?resize=600%2C450&amp;ssl=1 600w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/unnamed.jpg?w=1200&amp;ssl=1 1200w" sizes="(max-width: 780px) 100vw, 780px" title="The 10 Best Things To Do This Weekend In Dallas &amp;Amp; Collin County 8"></noscript></amp-img></a><figcaption>Heritage Farmstead Museum | Official Site</figcaption></figure>



<h2><a href="https://www.heritagefarmstead.org/event-list/apr-22-fun-on-the-farm-teddy-bear-picnic/" data-schema-attribute="mentions" target="_blank" rel="noopener">Teddy Bear Picnic at Heritage Farmstead Museum</a></h2>



<p><strong>When</strong>: April 22, 2022<br><strong><em>Where</em></strong>: <em>Heritage Farmstead Museum | 1900 West 15th Street, Plano</em><br><em><a href="https://www.heritagefarmstead.org/event-list/apr-22-fun-on-the-farm-teddy-bear-picnic/" target="_blank" rel="noreferrer noopener">Tickets here</a></em></p>



<p>This weekend, the Fun on The Farm program offers a Teddy Bear Picnic for children ages two-to-five years old to enjoy the weather, read a story, make a craft, meet the livestock, go on a wagon ride and have fun on the 4.5 acre farm—and, of course, show off their favorite teddy bear.</p>


				<div class="wp-block-newspack-blocks-homepage-articles  wpnbha show-image image-alignleft ts-3 is-3 is-landscape  has-text-align-left">
			<div data-posts data-current-post-id="53155">
									<h2 class="article-section-title">
						<span>Enjoy the weather with more outdoor activities!</span>
					</h2>
								
	<article data-post-id="52450" class="tag-allen-restaurants tag-best-patios-in-allen tag-best-patios-in-frisco tag-best-patios-in-mckinney tag-best-patios-in-plano tag-frisco-restaurants-2 tag-mckinney-restaurants tag-plano-restaurants category-food-and-drink type-post post-has-image">
					<figure class="post-thumbnail">
								<a href="https://localprofile.com/2022/03/28/best-patios-plano-frisco-allen-mckinney/" rel="bookmark">
									<amp-img width="1200" height="900" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/zin-zen-wine-bistro-mckinney-food-photography-0011-scaled.jpg?resize=1200%2C900&amp;ssl=1" class="attachment-newspack-article-block-landscape-large size-newspack-article-block-landscape-large wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="best patios, best patios in mckinney, mckinney, tx, texas, mckinney restaurants" data-hero-candidate="1" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/zin-zen-wine-bistro-mckinney-food-photography-0011-scaled.jpg?resize=1200%2C900&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/zin-zen-wine-bistro-mckinney-food-photography-0011-scaled.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/zin-zen-wine-bistro-mckinney-food-photography-0011-scaled.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/zin-zen-wine-bistro-mckinney-food-photography-0011-scaled.jpg?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/zin-zen-wine-bistro-mckinney-food-photography-0011-scaled.jpg?zoom=2&amp;resize=1200%2C900&amp;ssl=1 2400w" sizes="(max-width: 780px) 100vw, 780px" title="2022 Guide To Best Patios In Plano, Frisco, Allen &amp;Amp;Amp; Mckinney 2" layout="intrinsic" disable-inline-width="" data-hero i-amphtml-ssr i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjkwMCIgd2lkdGg9IjEyMDAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><img class="i-amphtml-fill-content i-amphtml-replaced-content" decoding="async" loading="lazy" alt="best patios, best patios in mckinney, mckinney, tx, texas, mckinney restaurants" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/zin-zen-wine-bistro-mckinney-food-photography-0011-scaled.jpg?resize=1200%2C900&amp;ssl=1" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/zin-zen-wine-bistro-mckinney-food-photography-0011-scaled.jpg?resize=1200%2C900&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/zin-zen-wine-bistro-mckinney-food-photography-0011-scaled.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/zin-zen-wine-bistro-mckinney-food-photography-0011-scaled.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/zin-zen-wine-bistro-mckinney-food-photography-0011-scaled.jpg?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/zin-zen-wine-bistro-mckinney-food-photography-0011-scaled.jpg?zoom=2&amp;resize=1200%2C900&amp;ssl=1 2400w" sizes="(max-width: 780px) 100vw, 780px" title="2022 Guide To Best Patios In Plano, Frisco, Allen &amp;Amp;Amp; Mckinney 2"></amp-img>								</a>
				
							</figure>
		
		<div class="entry-wrapper">
			<h3 class="entry-title"><a href="https://localprofile.com/2022/03/28/best-patios-plano-frisco-allen-mckinney/" rel="bookmark">2022 guide to best patios in Plano, Frisco, Allen &amp; McKinney</a></h3>						<p>If you’ve been frantically searching for “best patios near me”, these open-air eateries in Plano, Frisco, Allen and McKinney have just what you need to enhance your tableside experience. The term al fresco is Italian and loosely means “in the cool air.” In Texas, sometimes we have cool air, sometimes we don’t, but that doesn’t…</p>
				<a class="more-link" href="https://localprofile.com/2022/03/28/best-patios-plano-frisco-allen-mckinney/" rel="bookmark">
					Keep reading				</a>
						</div>
	</article>

		
	<article data-post-id="52802" class="category-things-to-do type-post post-has-image">
					<figure class="post-thumbnail">
								<a href="https://localprofile.com/2022/04/05/best-texas-bluebonnets-2022/" rel="bookmark">
									<amp-img width="1200" height="900" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=1200%2C900&amp;ssl=1" class="attachment-newspack-article-block-landscape-large size-newspack-article-block-landscape-large wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="bluebonnets 2022, best places to take bluebonnet photos, bluebonnet photos, bluebonnets, texas bluebonnets, bluebonnets in plano, bluebonnets in frisco, bluebonnets in mckinney, bluebonnets in richardson" data-hero-candidate="1" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?w=2016&amp;ssl=1 2016w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=300%2C225&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=1024%2C768&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=768%2C576&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=1536%2C1152&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=1200%2C900&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=1568%2C1176&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=706%2C530&amp;ssl=1 706w" sizes="(max-width: 780px) 100vw, 780px" title="Bluebonnets 2022 ... It'S Bloom Time! 10+ Best Places To See Texas Bluebonnets 3" layout="intrinsic" disable-inline-width="" data-hero i-amphtml-ssr i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjkwMCIgd2lkdGg9IjEyMDAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><img class="i-amphtml-fill-content i-amphtml-replaced-content" decoding="async" loading="lazy" alt="bluebonnets 2022, best places to take bluebonnet photos, bluebonnet photos, bluebonnets, texas bluebonnets, bluebonnets in plano, bluebonnets in frisco, bluebonnets in mckinney, bluebonnets in richardson" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=1200%2C900&amp;ssl=1" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?w=2016&amp;ssl=1 2016w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=300%2C225&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=1024%2C768&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=768%2C576&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=1536%2C1152&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=1200%2C900&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=1568%2C1176&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7761.jpg?resize=706%2C530&amp;ssl=1 706w" sizes="(max-width: 780px) 100vw, 780px" title="Bluebonnets 2022 ... It'S Bloom Time! 10+ Best Places To See Texas Bluebonnets 3"></amp-img>								</a>
				
							</figure>
		
		<div class="entry-wrapper">
			<h3 class="entry-title"><a href="https://localprofile.com/2022/04/05/best-texas-bluebonnets-2022/" rel="bookmark">Bluebonnets 2022 … It’s bloom time! 10+ best places to see Texas bluebonnets</a></h3>						<p>Texas bluebonnet season has arrived and since these beautiful blooms only flower for a few weeks per year if you want to enjoy “bluebonnets 2022”, you’re going to need to act fast. By the end of April, they’ll be all but gone. So, for that perfect bluebonnet photo, here’s our list of the 10+ best…</p>
				<a class="more-link" href="https://localprofile.com/2022/04/05/best-texas-bluebonnets-2022/" rel="bookmark">
					Keep reading				</a>
						</div>
	</article>

		
	<article data-post-id="40890" class="tag-bluebonnets tag-ennis tag-ennis-bluebonnet-festival tag-ennis-bluebonnet-trails tag-road-trip category-things-to-do type-post post-has-image">
					<figure class="post-thumbnail">
								<a href="https://localprofile.com/2021/04/13/ennis-bluebonnet-trails-road-trip-guide/" rel="bookmark">
									<amp-img width="1200" height="900" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=1200%2C900&amp;ssl=1" class="attachment-newspack-article-block-landscape-large size-newspack-article-block-landscape-large wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="ennis bluebonnet trails" data-hero-candidate="1" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?w=2016&amp;ssl=1 2016w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=300%2C225&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=1024%2C768&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=768%2C576&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=1536%2C1152&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=1200%2C900&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=1568%2C1176&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=706%2C530&amp;ssl=1 706w" sizes="(max-width: 780px) 100vw, 780px" title="Ennis Bluebonnet Trails: Road Trip Guide 4" layout="intrinsic" disable-inline-width="" data-hero i-amphtml-ssr i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjkwMCIgd2lkdGg9IjEyMDAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><img class="i-amphtml-fill-content i-amphtml-replaced-content" decoding="async" loading="lazy" alt="ennis bluebonnet trails" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=1200%2C900&amp;ssl=1" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?w=2016&amp;ssl=1 2016w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=300%2C225&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=1024%2C768&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=768%2C576&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=1536%2C1152&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=1200%2C900&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=1568%2C1176&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/04/IMG_7730.jpg?resize=706%2C530&amp;ssl=1 706w" sizes="(max-width: 780px) 100vw, 780px" title="Ennis Bluebonnet Trails: Road Trip Guide 4"></amp-img>
				
							</a></figure>
		
		<div class="entry-wrapper">
			<h3 class="entry-title"><a href="https://localprofile.com/2021/04/13/ennis-bluebonnet-trails-road-trip-guide/" rel="bookmark">Ennis Bluebonnet Trails: Road Trip Guide</a></h3>						<p>Most native Texans have probably heard this before — “If you want to see bluebonnets, take a trip to Ennis, Texas.” But why Ennis?  In 1997, the Texas State Legislature designated the city as the “Official Bluebonnet City of Texas” and as the home of the “Official Texas Bluebonnet Trail,” according to Ennis’ website. Because…</p>
				<a class="more-link" href="https://localprofile.com/2021/04/13/ennis-bluebonnet-trails-road-trip-guide/" rel="bookmark">
					Keep reading				</a>
						</div>
	</article>

					</div>
			
		</div>
				


<h3><a href="https://www.granitepark.com/event/brunch-blooms-2/" target="_blank" rel="noopener">Brunch &amp; Blooms</a></h3>



<p><em><strong>When</strong>: April 23, 2022<br></em><strong><em>Where</em></strong>: <em>The Boardwalk at Granite Park | 5800 State Highway 121</em>, <em>Plano</em><br><i><a href="https://www.granitepark.com/event/brunch-blooms-2/" target="_blank" rel="noopener">M</a></i><em><a href="https://www.granitepark.com/event/brunch-blooms-2/" target="_blank" rel="noopener">ore Info</a></em></p>



<p>What says <em>SPRING</em> more than a beautiful bouquet? The Flower Bar by Stemmed + Found Co. is coming back to the Boardwalk to give you the opportunity to create your very own bouquet to take home after brunching at your favorite restaurant.</p>



<figure class="wp-block-image size-large"><amp-img width="780" height="532" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=780%2C532&amp;ssl=1" alt="event1013, downtown plano arts district,  things to do, things to do this weekend, things to do this weekend in dallas, things to do in dallas this weekend, downtown plano, plano arts association, ukraine, sunflowers for ukraine, art, plano arts, plano tx, plano texas" class="wp-image-52978 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=1024%2C698&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=300%2C204&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=768%2C523&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=1536%2C1046&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=1200%2C817&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=1568%2C1068&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=400%2C272&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=706%2C481&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=150%2C102&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?w=2048&amp;ssl=1 2048w" sizes="(max-width: 780px) 100vw, 780px" title="The 10 Best Things To Do This Weekend In Dallas &amp;Amp; Collin County 9" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjUzMiIgd2lkdGg9Ijc4MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="532" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=780%2C532&amp;ssl=1" alt="event1013, downtown plano arts district,  things to do, things to do this weekend, things to do this weekend in dallas, things to do in dallas this weekend, downtown plano, plano arts association, ukraine, sunflowers for ukraine, art, plano arts, plano tx, plano texas" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=1024%2C698&amp;ssl=1 1024w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=300%2C204&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=768%2C523&amp;ssl=1 768w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=1536%2C1046&amp;ssl=1 1536w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=1200%2C817&amp;ssl=1 1200w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=1568%2C1068&amp;ssl=1 1568w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=400%2C272&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=706%2C481&amp;ssl=1 706w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?resize=150%2C102&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/278055358_10159644302186900_9069172141858402033_n.jpg?w=2048&amp;ssl=1 2048w" sizes="(max-width: 780px) 100vw, 780px" title="The 10 Best Things To Do This Weekend In Dallas &amp;Amp; Collin County 9"></noscript></amp-img><figcaption>Sunflowers for Ukraine art auction.</figcaption></figure>



<h3><a href="https://paa33.wildapricot.org/Sunflowers" target="_blank" rel="noopener">Sunflowers for Ukraine Online Art Auction</a></h3>



<p><em><strong>When</strong>: Until May 2, 10:30am to 8:00pm<br><a href="https://www.sunflowerofpeace.com/" target="_blank" rel="noopener">More Info</a></em></p>



<p>Sixty artists from Plano and Richardson have come together to sell sunflower-themed pieces to raise money for the people of Ukraine. The sunflower is the national flower of Ukraine and has become a symbol of support for the war-torn country. </p>



<p>One hundred percent of all winning bid donations will be forwarded to an established and vetted Ukrainian charity, <a href="https://www.facebook.com/sunflowerofpeace/?__cft__%5B0%5D=AZXglRqr9bNw9hcKqC8D4SFTrVDR8UrYUAOuB9IKwFkTeKJnpJHCfoo0PGZ40Y9PlkpGLaUsJ0Wki5aO59BpE8yQ8S45R95CReV8zJdi8CpbgilRxFn5WIBT7KiF0kre2UYfnfsIS1eCS2UKpwxqknCO6m5RsKKYcmSD4ygOK-tGmnd2v5Bpjcu4AL44kUWn5H0&amp;__tn__=kK-R" target="_blank" rel="noopener">Sunflower of Peace</a>. Sunflower of Peace supports the people of Ukraine suffering from Russia’s military invasion by raising funds to acquire medical first aid and humanitarian supplies to distribute to doctors and paramedics in Ukraine. This event is being organized by <a href="https://www.facebook.com/PlanoArtAssociation/?__cft__%5B0%5D=AZXglRqr9bNw9hcKqC8D4SFTrVDR8UrYUAOuB9IKwFkTeKJnpJHCfoo0PGZ40Y9PlkpGLaUsJ0Wki5aO59BpE8yQ8S45R95CReV8zJdi8CpbgilRxFn5WIBT7KiF0kre2UYfnfsIS1eCS2UKpwxqknCO6m5RsKKYcmSD4ygOK-tGmnd2v5Bpjcu4AL44kUWn5H0&amp;__tn__=kK-R" target="_blank" rel="noopener">Plano Art Association</a>. If you’re looking for a way to give back and pick up a new piece of art, add this event to your things to do this weekend. </p>



<h3><a href="https://www.ted.com/tedx/events/47475" target="_blank" rel="noopener">TEDx Plano at the Courtyard Theatre</a></h3>



<p><em><strong>When</strong>: April 16, 2022, 5 p.m.<br></em><strong><em>Where</em></strong>: <em>McCall Plaza | 998 East 15th Street, Plano</em><br><em><a href="https://ci.ovationtix.com/36072/production/1113264" target="_blank" rel="noopener">Tickets here</a></em></p>



<p>TEDxPlano returns, and the theme this year is Re(Connecting). The whole event will be focused around providing time to connect and reconnect. The line-up of amazing speakers will explore and celebrate ideas that embrace, amplify, build and create community. But before we hear from the speakers, there will be time to re(connect) with fellow guests. Before stage time begins, Connection Experiences will offer the opportunity to participate in a smaller group experience, where you can make friends while doing things together.</p>



<h2>Even more great things to do this weekend in Dallas &amp; Collin County</h2>



<p><strong>South Pacific at the Art Centre Theatre</strong><br><em><strong>When</strong>:  April 22, 2022</em><br><strong><em>Where</em></strong>: <em>Art Centre Theatre |1400 Summit Ave Suite E, Plano</em><br><em><a href="https://www.artcentretheatre.com/" target="_blank" rel="noreferrer noopener">More Info</a></em></p>



<p><strong>Luncheon with Roma Downey benefiting Minnie’s Food Pantry</strong><br><em><strong>When</strong>: April 22, 2022<br></em><strong><em>Where</em></strong>: <em>Gleneagles Country Club| 112 South Kentucky Street, McKinney</em><br><em><a href="https://www.eventbrite.com/e/the-gathering-tickets-305195597247" target="_blank" rel="noreferrer noopener">Tickets here.</a></em></p>



<p><strong><strong>Peaceful Earth Experience exhibit at Art Gallery Pure</strong></strong><br><em><strong>When</strong>: April 22, 2022<br></em><strong><em>Where</em></strong>: <em>The Shops at Willow Bend | 6121 W Park Blvd, Plano</em><br><em><a href="https://www.facebook.com/events/520157002796789" target="_blank" rel="noopener">More Info</a></em></p>



<p><strong>Jade Nickol at CityLine Plaza</strong><br><em><strong>When</strong>: April 16, 2022<br></em><strong><em>Where</em></strong>: <em>CityLine Plaza| 3661 N Plano Rd #2500, Richardson</em><br><em><a href="https://citylinedfw.com/events/cityline-live-042322/" target="_blank" rel="noreferrer noopener">More Info</a></em></p>



<p><strong>The Allen Civic Ballet Presents Bravo!</strong><br><em><strong>When</strong>: April 24, 2022<br></em><strong><em>Where</em></strong>: <em>Allen Civic Ballet | 368 N Greenville Ave, Allen</em><br><em><a href="https://allencivicballet.org/bravo/" target="_blank" rel="noreferrer noopener">More Info</a></em></p>



<p><strong>The Cove Take It Outside!<br></strong><em><strong>When</strong>: Until April 22 – 23, 2022<br></em><strong><em>Where</em></strong>: <em>The Cove | 402 N Tennessee St, McKinney</em><br><em><a href="https://www.thecovemckinney.org/" target="_blank" rel="noreferrer noopener">More Info</a></em></p>



<p><strong>Uptown Drifters</strong><br><em><strong>When:</strong> April 22, 2022</em><br><strong><em>Where:</em> </strong><em>Allen Public Library Civic Auditorium</em> <em>| 300 N Allen Dr, Allen</em><br><em><a href="https://www.cityofallen.org/calendar.aspx?EID=12633" target="_blank" rel="noreferrer noopener">More Info</a></em></p>



<p><strong>Barre on the Farm</strong><br><strong><em>When:</em></strong><em> April 23, 2022</em><br><strong><em>Where:</em> </strong><em>Heritage Farmstead Museum | 1900 West 15th Street, Plano</em><br><em><a href="https://www.visitplano.com/event/barre-on-the-farm/" target="_blank" rel="noopener">More info</a></em></p>

<nav class="jp-relatedposts-i2" data-layout="grid"><h3 class="jp-relatedposts-headline"><em>Related</em></h3><div class="jp-related-posts-i2__row" data-post-count="3"><ul id="related-posts-item-6260864f693da" aria-labelledby="related-posts-item-6260864f693da-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-6260864f693da-label" href="https://localprofile.com/2022/04/06/things-to-do-this-weekend-in-dallas-11/">The 10+ best things to do this weekend in Dallas &amp; Collin County</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://localprofile.com/2022/04/06/things-to-do-this-weekend-in-dallas-11/"><amp-img src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/277726252_10159929549164591_8630410031649363852_n.jpg?fit=1200%2C1198&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt="arts in bloom, things to do in mckinney, things to do this weekend in dallas, things to do this weekend, downtown mckinney" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjIwMCIgd2lkdGg9IjM1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/277726252_10159929549164591_8630410031649363852_n.jpg?fit=1200%2C1198&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt="arts in bloom, things to do in mckinney, things to do this weekend in dallas, things to do this weekend, downtown mckinney" loading="lazy"></noscript></amp-img></a></li></ul><ul id="related-posts-item-6260864f69418" aria-labelledby="related-posts-item-6260864f69418-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-6260864f69418-label" href="https://localprofile.com/2022/04/12/things-to-do-this-weekend-in-dallas-12/">The 10+ best things to do this weekend in Dallas &amp; Collin County</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://localprofile.com/2022/04/12/things-to-do-this-weekend-in-dallas-12/"><amp-img src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/277370708_5171260712917458_4480141325149630024_n.jpg?fit=1200%2C800&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt="things to do, things to do this weekend, things to do this weekend in dallas, things to do in dallas this weekend, easter weekend, downtown plano, underground movement festival, plano arts" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjIwMCIgd2lkdGg9IjM1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/04/277370708_5171260712917458_4480141325149630024_n.jpg?fit=1200%2C800&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt="things to do, things to do this weekend, things to do this weekend in dallas, things to do in dallas this weekend, easter weekend, downtown plano, underground movement festival, plano arts" loading="lazy"></noscript></amp-img></a></li></ul><ul id="related-posts-item-6260864f6943a" aria-labelledby="related-posts-item-6260864f6943a-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-6260864f6943a-label" href="https://localprofile.com/2022/03/03/best-things-to-do-this-weekend-in-dallas-5/">The 10+ best things to do this weekend in Dallas &amp; Collin County – Spring Break</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://localprofile.com/2022/03/03/best-things-to-do-this-weekend-in-dallas-5/"><amp-img src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/QH9A0283-s1-1-scaled.jpg?fit=1200%2C795&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt="" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjIwMCIgd2lkdGg9IjM1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/QH9A0283-s1-1-scaled.jpg?fit=1200%2C795&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt="" loading="lazy"></noscript></amp-img></a></li></ul></div></nav><section id="bs_zones-6" class="below-content widget bs_zones"><div><amp-ad type="broadstreetads" data-network="6972" data-zone="89884" data-keywords="not_home_page,not_landing_page,is_article_page,arts-and-culture,things-to-do,things-to-do-this-weekend-things-to-do,things-to-do,10-best-things-weekend-dallas-collin,post" data-place="" layout="responsive" data-initurl="https://cdn.broadstreetads.com/init-2.min.js?v=1.43.8" width="728" height="120" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer slot="i-amphtml-svc" style="display:block;padding-top:16.4835%"></i-amphtml-sizer></amp-ad></div></section><section id="bs_zones-14" class="below-content widget bs_zones"><div><amp-ad type="broadstreetads" data-network="6972" data-zone="89667" data-keywords="not_home_page,not_landing_page,is_article_page,arts-and-culture,things-to-do,things-to-do-this-weekend-things-to-do,things-to-do,10-best-things-weekend-dallas-collin,post" data-place="" layout="responsive" data-initurl="https://cdn.broadstreetads.com/init-2.min.js?v=1.43.8" width="800" height="600" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer slot="i-amphtml-svc" style="display:block;padding-top:75%"></i-amphtml-sizer></amp-ad></div></section>	</div>

	<footer class="entry-footer">
			</footer>

	
</article>
				</div>

			
<aside id="secondary" class="widget-area">
	<section id="bs_zones-2" class="widget bs_zones"><div><amp-ad type="broadstreetads" data-network="6972" data-zone="89045" data-keywords="not_home_page,not_landing_page,is_article_page,arts-and-culture,things-to-do,things-to-do-this-weekend-things-to-do,things-to-do,10-best-things-weekend-dallas-collin,post" data-place="" layout="responsive" data-initurl="https://cdn.broadstreetads.com/init-2.min.js?v=1.43.8" width="300" height="300" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer slot="i-amphtml-svc" style="display:block;padding-top:100%"></i-amphtml-sizer></amp-ad></div></section><section id="mc4wp_form_widget-2" class="widget widget_mc4wp_form_widget"><h2 class="widget-title accent-header"><span>Newsletter</span></h2><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-28045" action-xhr="https://localprofile.com/wp-json/mc4wp/v1/form" method="post" data-id="28045" data-name="Newsletter Sign-Up" target="_top"><div class="mc4wp-form-fields"><p>
	<label>Have you subscribed to our free weekly newsletter? <br><br>It’s awesome.<br><br>
		<input type="email" name="EMAIL" placeholder="Your email here." required>
</label>
</p>

<p>
	<input type="submit" value="Sign up" data-amp-original-style="background-color:#ff5959;" class="amp-wp-be8153e">
</p>		<div submitting>
			<template type="amp-mustache">
				Submitting...			</template>
		</div>
		<div submit-success>
			<template type="amp-mustache">
				Thank you, your sign-up request was successful! Please check your email inbox to confirm.			</template>
		</div>
		<div submit-error>
			<template type="amp-mustache">
				{{message}}
			</template>
		</div>
		</div><label data-amp-original-style="display: none !important;" class="amp-wp-3e2e7c3">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off"></label><input type="hidden" name="_mc4wp_timestamp" value="1650493007"><input type="hidden" name="_mc4wp_form_id" value="28045"><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1"><div class="mc4wp-response"></div></form></section><section id="bs_zones-3" class="widget bs_zones"><div><amp-ad type="broadstreetads" data-network="6972" data-zone="89046" data-keywords="not_home_page,not_landing_page,is_article_page,arts-and-culture,things-to-do,things-to-do-this-weekend-things-to-do,things-to-do,10-best-things-weekend-dallas-collin,post" data-place="" layout="responsive" data-initurl="https://cdn.broadstreetads.com/init-2.min.js?v=1.43.8" width="300" height="300" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer slot="i-amphtml-svc" style="display:block;padding-top:100%"></i-amphtml-sizer></amp-ad></div></section>
		<section id="recent-posts-4" class="widget widget_recent_entries">
		<h2 class="widget-title accent-header"><span>Recent News</span></h2>
		<ul>
											<li>
					<a href="https://localprofile.com/2022/04/20/10-best-things-weekend-dallas-collin/" aria-current="page">The 10 Best Things To Do This Weekend In Dallas &amp; Collin County</a>
											<span class="post-date">April 20, 2022</span>
									</li>
											<li>
					<a href="https://localprofile.com/2022/04/20/hello-kitty-cafe-truck-plano/">Hello Kitty Cafe Truck Returns To North Texas</a>
											<span class="post-date">April 20, 2022</span>
									</li>
											<li>
					<a href="https://localprofile.com/2022/04/19/frisco-fair-2022-rides-food-fun/">The Frisco Fair Returns For 2022 With More Rides, Food And Fun</a>
											<span class="post-date">April 19, 2022</span>
									</li>
											<li>
					<a href="https://localprofile.com/2022/04/19/hitmakers-from-north-texas/">Here Are 7 Hitmakers Who Are From North Texas</a>
											<span class="post-date">April 19, 2022</span>
									</li>
											<li>
					<a href="https://localprofile.com/2022/04/18/covid-19-breathalyzer-fda-approval/">Frisco-developed COVID-19 Breathalyzer Gets FDA Approval</a>
											<span class="post-date">April 18, 2022</span>
									</li>
					</ul>

		</section><section id="bs_zones-4" class="widget bs_zones"><div><amp-ad type="broadstreetads" data-network="6972" data-zone="89047" data-keywords="not_home_page,not_landing_page,is_article_page,arts-and-culture,things-to-do,things-to-do-this-weekend-things-to-do,things-to-do,10-best-things-weekend-dallas-collin,post" data-place="" layout="responsive" data-initurl="https://cdn.broadstreetads.com/init-2.min.js?v=1.43.8" width="300" height="300" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer slot="i-amphtml-svc" style="display:block;padding-top:100%"></i-amphtml-sizer></amp-ad></div></section><section id="bs_zones-8" class="widget bs_zones"><div><amp-ad type="broadstreetads" data-network="6972" data-zone="92285" data-keywords="not_home_page,not_landing_page,is_article_page,arts-and-culture,things-to-do,things-to-do-this-weekend-things-to-do,things-to-do,10-best-things-weekend-dallas-collin,post" data-place="" layout="responsive" data-initurl="https://cdn.broadstreetads.com/init-2.min.js?v=1.43.8" width="320" height="600" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer slot="i-amphtml-svc" style="display:block;padding-top:187.5%"></i-amphtml-sizer></amp-ad></div></section><section id="bs_zones-15" class="widget bs_zones"><div><amp-ad type="broadstreetads" data-network="6972" data-zone="90132" data-keywords="not_home_page,not_landing_page,is_article_page,arts-and-culture,things-to-do,things-to-do-this-weekend-things-to-do,things-to-do,10-best-things-weekend-dallas-collin,post" data-place="" layout="responsive" data-initurl="https://cdn.broadstreetads.com/init-2.min.js?v=1.43.8" width="300" height="600" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer slot="i-amphtml-svc" style="display:block;padding-top:200%"></i-amphtml-sizer></amp-ad></div></section><section id="jetpack-search-filters-2" class="widget jetpack-filters widget_search">			<div id="jetpack-search-filters-2-wrapper">
		<div class="jetpack-search-form">
<form role="search" method="get" class="search-form" action="https://localprofile.com/" target="_top">
	<label for="search-form-5">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-5" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z" /><path d="M0 0h24v24H0z" fill="none" /></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
<input type="hidden" name="orderby" value="relevance_desc"><input type="hidden" name="order" value="DESC"></form>
</div>					<div class="jetpack-search-sort-wrapper">
				<label>
					Sort by					<select class="jetpack-search-sort">
													<option value="relevance|DESC">
								Relevance							</option>
													<option value="date|DESC">
								Newest first							</option>
													<option value="date|ASC">
								Oldest first							</option>
											</select>
				</label>
			</div>
					
			</div></section></aside>

		</main>
	</section>


	
	<section class="newspack-broadstreet-footer amp-wp-543be6b" data-amp-original-style="text-align:center; padding: 25px;"><amp-ad type="broadstreetads" data-network="6972" data-zone="89160" data-keywords="not_home_page,not_landing_page,is_article_page,arts-and-culture,things-to-do,things-to-do-this-weekend-things-to-do,things-to-do,10-best-things-weekend-dallas-collin,post" layout="responsive" data-initurl="https://cdn.broadstreetads.com/init-2.min.js?v=1.43.8" width="1056" height="151" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer slot="i-amphtml-svc" style="display:block;padding-top:14.2992%"></i-amphtml-sizer></amp-ad></section>
	</div>

	<footer id="colophon" class="site-footer">

					<div class="footer-branding">
		<div class="wrapper">
							<a class="footer-logo-link" href="https://localprofile.com/" rel="home">
					<amp-img width="400" height="176" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?fit=400%2C176&amp;ssl=1" class="footer-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?w=400&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?resize=300%2C132&amp;ssl=1 300w" sizes="(max-width: 400px) 100vw, 400px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjE3NiIgd2lkdGg9IjQwMCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="400" height="176" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?fit=400%2C176&amp;ssl=1" alt="" loading="lazy" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?w=400&amp;ssl=1 400w, https://i0.wp.com/localprofile.com/wp-content/uploads/2021/01/cropped-local-profile-footer-logo-2021.png?resize=300%2C132&amp;ssl=1 300w" sizes="(max-width: 400px) 100vw, 400px"></noscript></amp-img>				</a>
				<nav class="social-navigation" aria-label="Social Links Menu">
		<ul id="menu-social-menu-1" class="social-links-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30800"><a href="https://www.facebook.com/LocalProfile"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z" /></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30802"><a href="https://www.instagram.com/localprofile_cc/"><span class="screen-reader-text">Instagram</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z" /></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47230"><a href="https://twitter.com/localprofile_cc?lang=en"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z" /></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30804"><a href="https://www.linkedin.com/company/localprofile"><span class="screen-reader-text">LinkedIn</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M19.7,3H4.3C3.582,3,3,3.582,3,4.3v15.4C3,20.418,3.582,21,4.3,21h15.4c0.718,0,1.3-0.582,1.3-1.3V4.3 C21,3.582,20.418,3,19.7,3z M8.339,18.338H5.667v-8.59h2.672V18.338z M7.004,8.574c-0.857,0-1.549-0.694-1.549-1.548 c0-0.855,0.691-1.548,1.549-1.548c0.854,0,1.547,0.694,1.547,1.548C8.551,7.881,7.858,8.574,7.004,8.574z M18.339,18.338h-2.669 v-4.177c0-0.996-0.017-2.278-1.387-2.278c-1.389,0-1.601,1.086-1.601,2.206v4.249h-2.667v-8.59h2.559v1.174h0.037 c0.356-0.675,1.227-1.387,2.526-1.387c2.703,0,3.203,1.779,3.203,4.092V18.338z" /></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47231"><a href="https://www.youtube.com/channel/UC_9B-HjCwFD2-VjWys6c59g"><span class="screen-reader-text">Youtube</span><svg class="svg-icon" width="0" height="0" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z" /></svg></a></li>
</ul>	</nav>
		</div>
	</div>
		
	<aside class="widget-area footer-widgets" role="complementary" aria-label="Footer">
		<div class="wrapper">
			<section id="text-5" class="widget widget_text"><h2 class="widget-title">BROWSE LATEST ISSUE</h2>			<div class="textwidget"><p><a href="https://www.qgdigitalpublishing.com/publication/?i=732580" target="_blank" rel="noopener"><amp-img class="alignnone wp-image-52067 size-medium amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/Screenshot-2022-03-03-8.13.50-AM.png?resize=226%2C300&amp;ssl=1" alt="" width="226" height="300" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/Screenshot-2022-03-03-8.13.50-AM.png?w=461&amp;ssl=1 461w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/Screenshot-2022-03-03-8.13.50-AM.png?resize=226%2C300&amp;ssl=1 226w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/Screenshot-2022-03-03-8.13.50-AM.png?resize=300%2C400&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/Screenshot-2022-03-03-8.13.50-AM.png?resize=150%2C199&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/Screenshot-2022-03-03-8.13.50-AM.png?resize=400%2C531&amp;ssl=1 400w" sizes="(max-width: 226px) 100vw, 226px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjMwMCIgd2lkdGg9IjIyNiIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img loading="lazy" src="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/Screenshot-2022-03-03-8.13.50-AM.png?resize=226%2C300&amp;ssl=1" alt="" width="226" height="300" srcset="https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/Screenshot-2022-03-03-8.13.50-AM.png?w=461&amp;ssl=1 461w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/Screenshot-2022-03-03-8.13.50-AM.png?resize=226%2C300&amp;ssl=1 226w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/Screenshot-2022-03-03-8.13.50-AM.png?resize=300%2C400&amp;ssl=1 300w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/Screenshot-2022-03-03-8.13.50-AM.png?resize=150%2C199&amp;ssl=1 150w, https://i0.wp.com/localprofile.com/wp-content/uploads/2022/03/Screenshot-2022-03-03-8.13.50-AM.png?resize=400%2C531&amp;ssl=1 400w" sizes="(max-width: 226px) 100vw, 226px"></noscript></amp-img></a></p>
<p> </p>
<p> </p>
</div>
		</section><section id="text-4" class="widget widget_text"><h2 class="widget-title">SECTIONS</h2>			<div class="textwidget"><p><a href="https://localprofile.com?footernav">Home</a><br>
<a href="https://localprofile.com/category/latest/">Latest</a><br>
<a href="https://localprofile.com/category/covid-19/">COVID-19</a><br>
<a href="https://localprofile.com/category/arts-and-culture/">Arts + Culture</a><br>
<a href="https://localprofile.com/category/business/">Business</a><br>
<a href="https://localprofile.com/category/community/">Community</a><br>
<a href="https://localprofile.com/category/food-and-drink/">Food + Drink</a><br>
<a href="https://localprofile.com/category/health/">Health</a><br>
<a href="https://localprofile.com/category/lifestyle">Lifestyle</a><br>
<a href="https://localprofile.com/category/things-to-do/">Things To Do</a><br>
<a href="https://localprofile.com/category/top-listings">Top Listings</a><br>
<a href="https://localprofile.com/category/women-in-business/">Women In Business</a></p>
</div>
		</section><section id="mc4wp_form_widget-3" class="widget widget_mc4wp_form_widget"><h2 class="widget-title">NEWSLETTER</h2><form id="mc4wp-form-2" class="mc4wp-form mc4wp-form-28045" action-xhr="https://localprofile.com/wp-json/mc4wp/v1/form" method="post" data-id="28045" data-name="Newsletter Sign-Up" target="_top"><div class="mc4wp-form-fields"><p>
	<label>Have you subscribed to our free weekly newsletter? <br><br>It’s awesome.<br><br>
		<input type="email" name="EMAIL" placeholder="Your email here." required>
</label>
</p>

<p>
	<input type="submit" value="Sign up" data-amp-original-style="background-color:#ff5959;" class="amp-wp-be8153e">
</p>		<div submitting>
			<template type="amp-mustache">
				Submitting...			</template>
		</div>
		<div submit-success>
			<template type="amp-mustache">
				Thank you, your sign-up request was successful! Please check your email inbox to confirm.			</template>
		</div>
		<div submit-error>
			<template type="amp-mustache">
				{{message}}
			</template>
		</div>
		</div><label data-amp-original-style="display: none !important;" class="amp-wp-3e2e7c3">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off"></label><input type="hidden" name="_mc4wp_timestamp" value="1650493007"><input type="hidden" name="_mc4wp_form_id" value="28045"><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-2"><div class="mc4wp-response"></div></form></section><section id="text-6" class="widget widget_text"><h2 class="widget-title">CONTACT US</h2>			<div class="textwidget"><p>1413 Gables Court<br>
Plano, Texas 75075<br>
(972) 769-7272<br>
<span class="email-address">connect@localprofile.com</span></p>
</div>
		</section>		</div>
	</aside>


		<div class="site-info">

			
			<div class="wrapper site-info-contain">
													<span class="copyright">© 2022 Community Profile, LLC, 2021.</span>
				
				<a target="_blank" href="https://newspack.pub/" class="imprint">
					Proudly powered by Newspack by Automattic				</a>

							</div>
		</div>
	</footer>

</div>










	<amp-state id="newspackHomepagePosts" class="i-amphtml-layout-container" i-amphtml-layout="container">
		<script type="application/json">{"exclude_ids":[52450,52802,40890,53155]}</script>
	</amp-state>
				<amp-analytics type="gtag" config='https://localprofile.com/wp-content/plugins/newspack-popups/includes/../api/segmentation/index.php?client_id=CLIENT_ID(newspack-cid)&amp;post_id=53155&amp;custom_dimensions=[{"role":"category","option":{"value":"category","label":"Category"},"gaID":"ga:dimension1"}]&amp;custom_dimensions_existing_values={"dimension1":"arts-and-culture,things-to-do,things-to-do-this-weekend-things-to-do"}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"></amp-analytics>
		

    		<amp-install-serviceworker src="https://localprofile.com/wp.serviceworker" data-iframe-src="https://localprofile.com/?amp_install_service_worker_iframe=1" layout="nodisplay" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		</amp-install-serviceworker>
		

<amp-analytics type="gtag" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"><script type="application/json">{"optoutElementId":"__gaOptOutExtension","vars":{"gtag_id":"UA-19203311-1","config":{"UA-19203311-1":{"groups":"default","linker":[],"send_page_view":false,"dimension1":"arts-and-culture,things-to-do,things-to-do-this-weekend-things-to-do"}}}}</script></amp-analytics>



<amp-analytics config="https://www.googletagmanager.com/amp.json?id=GTM-5VJ7RHF" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"><script type="application/json">{"optoutElementId":"__gaOptOutExtension"}</script></amp-analytics>

<amp-analytics id="parsely" type="parsely" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"><script type="application/json">{"vars":{"apikey":"localprofile.com"}}</script></amp-analytics>	
	
































			<amp-analytics class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed">
				<script type="application/json">{"linkers":{"enabled":true,"ref_newspack_cid":{"ids":{"cid":"CLIENT_ID(newspack-cid)"}}},"cookies":{"enabled":true,"newspack-cid":{"value":"LINKER_PARAM(ref_newspack_cid, cid)"}}}</script>
			</amp-analytics>
						<amp-analytics type="gtag" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed">
					<script type="application/json">{"optoutElementId":"__gaOptOutExtension","vars":{"gtag_id":"UA-19203311-1","config":{"UA-19203311-1":{"groups":"default","linker":{"domains":["localprofile.com"]},"send_page_view":false}}},"triggers":{"n356":{"request":"event","on":"click","vars":{"event_name":"social share","event_category":"NTG social","event_label":"facebook"},"selector":"amp-social-share[type=\"facebook\"]"},"n359":{"request":"event","on":"click","vars":{"event_name":"social share","event_category":"NTG social","event_label":"twitter"},"selector":"amp-social-share[type=\"twitter\"]"},"n35a":{"request":"event","on":"click","vars":{"event_name":"social share","event_category":"NTG social","event_label":"whatsapp"},"selector":"amp-social-share[type=\"whatsapp\"]"},"n35b":{"request":"event","on":"click","vars":{"event_name":"social share","event_category":"NTG social","event_label":"linkedin"},"selector":"amp-social-share[type=\"linkedin\"]"},"n35c":{"request":"event","on":"click","vars":{"event_name":"social share","event_category":"NTG social","event_label":"reddit"},"selector":"amp-social-share[type=\"reddit\"]"},"n35d":{"request":"event","on":"click","vars":{"event_name":"social share","event_category":"NTG social","event_label":"telegram"},"selector":"amp-social-share[type=\"telegram\"]"},"n371":{"request":"event","on":"scroll","vars":{"event_name":"25%","event_category":"NTG article milestone","non_interaction":true,"value":25,"event_label":"The 10 Best Things To Do This Weekend In Dallas \u0026#038; Collin County"},"event_value":25,"scrollSpec":{"verticalBoundaries":[25]}},"n3f6":{"request":"event","on":"scroll","vars":{"event_name":"50%","event_category":"NTG article milestone","non_interaction":true,"value":50,"event_label":"The 10 Best Things To Do This Weekend In Dallas \u0026#038; Collin County"},"event_value":50,"scrollSpec":{"verticalBoundaries":[50]}},"n431":{"request":"event","on":"scroll","vars":{"event_name":"100%","event_category":"NTG article milestone","non_interaction":true,"value":100,"event_label":"The 10 Best Things To Do This Weekend In Dallas \u0026#038; Collin County"},"event_value":100,"scrollSpec":{"verticalBoundaries":[100]}},"c4c3":{"request":"event","on":"ini-load","vars":{"event_name":"Load","event_category":"Newspack Announcement","non_interaction":true,"event_label":"Center: Email newsletter (39633) - Everyone"},"selector":"#c7e1"}}}</script>
				</amp-analytics>
							<amp-analytics type="gtag" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed">
					<script type="application/json">{"optoutElementId":"__gaOptOutExtension","vars":{"gtag_id":"UA-19203311-1","config":{"UA-19203311-1":{"groups":"default","linker":{"domains":["localprofile.com"]},"send_page_view":false}}},"triggers":{"c4c7":{"request":"event","on":"visible","vars":{"event_name":"Seen","event_category":"Newspack Announcement","non_interaction":true,"event_label":"Center: Email newsletter (39633) - Everyone"},"selector":"#c7e1","visibilitySpec":{"totalTimeMin":500}},"c4c9":{"request":"event","on":"amp-form-submit","vars":{"event_name":"Form Submission","event_category":"Newspack Announcement","event_label":"Center: Email newsletter (39633) - Everyone"},"selector":"#c7e1 form:not(.c7e1)"},"c4cb":{"request":"event","on":"amp-form-submit-success","vars":{"event_name":"Dismissal","event_category":"Newspack Announcement","non_interaction":true,"event_label":"Center: Email newsletter (39633) - Everyone"},"selector":".c7e10"},"c4cc":{"request":"event","on":"amp-form-submit-success","vars":{"event_name":"Permanent Dismissal","event_category":"Newspack Announcement","non_interaction":true,"event_label":"Center: Email newsletter (39633) - Everyone"},"selector":".c7e11"},"nc88":{"request":"event","on":"amp-form-submit-success","vars":{"event_name":"newsletter signup","event_category":"NTG newsletter","event_label":"success"},"selector":"#nc85 form","visibilitySpec":{"totalTimeMin":500}},"nc8b":{"request":"event","on":"visible","vars":{"event_name":"newsletter modal impression 2","event_category":"NTG newsletter","non_interaction":true,"event_label":"The 10 Best Things To Do This Weekend In Dallas \u0026#038; Collin County"},"selector":"#nc85","visibilitySpec":{"totalTimeMin":500}}}}</script>
				</amp-analytics>
				<amp-pixel src="https://pixel.wp.com/g.gif?v=ext&amp;j=1%3A10.9-a.7&amp;blog=177389529&amp;post=53155&amp;tz=-5&amp;srv=localprofile.com&amp;hp=atomic&amp;ac=6&amp;amp=1&amp;host=localprofile.com&amp;rand=RANDOM&amp;ref=DOCUMENT_REFERRER" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"></amp-pixel>
	

</body></html>
<!--
	generated 164 seconds ago
	generated in 1.530 seconds
	served from batcache in 0.003 seconds
	expires in 136 seconds
-->
